(address . guix-patches@gnu.org)(name . Jaeme Sifat)(address . jaeme@runbox.com)
Change-Id: I922b98d5a047760974a22499d7a299bdf932ef1a
---
gnu/packages/video.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (67 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b4dd7c27ae..e5166a3aa2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -66,6 +66,7 @@
;;; Copyright © 2023 Ott Joon <oj@vern.cc>
;;; Copyright © 2023 Dominik Delgado Steuter <dds@disroot.org>
;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -116,6 +117,7 @@ (define-module (gnu packages video)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages bittorrent)
#:use-module (gnu packages boost)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages check)
@@ -194,6 +196,7 @@ (define-module (gnu packages video)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages ssh)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages terminals)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
@@ -5721,3 +5724,34 @@ (define-public svtplay-dl
broadcasters including SVT Play, Sveriges Radio, TV4 Play, along with many
others.")
(license license:expat)))
+
+(define-public ani-cli
+ (package
+ (name "ani-cli")
+ (version "4.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pystardust/ani-cli")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ni9pzjb5qh87iz7c8252bx79qadr1qx6jnkqvvjcqrchh7q473a"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("ani-cli" "bin/")
+ ("ani-cli.1" "share/man/man1/"))))
+ (home-page "https://github.com/pystardust/ani-cli")
+ (synopsis "CLI to browse and watch anime")
+ (description
+ "ani-cli is a shell script command-line tool for browsing and watching
+anime using allanime as a source. It can stream at multiple resolutions and
+provides multiple interfaces such as rofi.")
+ (propagated-inputs (list mpv
+ yt-dlp
+ ffmpeg
+ fzf
+ curl
+ aria2))
+ (license license:gpl3)))
base-commit: 56742f79c0d41e7a642154d9f04b9a344c47a6dc
--
2.34.1