[PATCH] gnu: Add emacs-color-theme-sanityinc-tomorrow.

  • Open
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Rostislav Svoboda
  • Steve George
Owner
unassigned
Submitted by
Rostislav Svoboda
Severity
normal
Merged with
R
R
Rostislav Svoboda wrote on 14 Oct 2023 19:47
(address . guix-patches@gnu.org)(name . Rostislav Svoboda)(address . Rostislav.Svoboda@gmail.com)
46b29e88905aee8c059a84ab355f87554cd3d60c.1697305618.git.Rostislav.Svoboda@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-color-theme-sanityinc-tomorrow): New variable.
---
gnu/packages/emacs-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb8c25f9b5..1d10188b9c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11057,6 +11057,46 @@ (define-public emacs-moe-theme-el
variants.")
(license license:gpl3+)))
+(define-public emacs-color-theme-sanityinc-tomorrow
+ (let ((commit "d34e8db507ee0c7b465ff18a8f220c33ed77cd79")
+ (revision "0"))
+ (package
+ (name "emacs-color-theme-sanityinc-tomorrow")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/purcell/color-theme-sanityinc-tomorrow")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mfildi7rav2j42avii7z4gp4ghl04cqv8wp1vyxzl8vkyj60nkb"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #true
+ #:test-command
+ #~(list "emacs" "-Q" "--batch" "--eval" "
+(progn
+ (setq byte-compile-error-on-warn t)
+ (push default-directory load-path))
+"
+ "-f" "batch-byte-compile"
+ "color-theme-sanityinc-tomorrow.el"
+ "sanityinc-tomorrow-blue-theme.el"
+ "sanityinc-tomorrow-bright-theme.el"
+ "sanityinc-tomorrow-day-theme.el"
+ "sanityinc-tomorrow-eighties-theme.el"
+ "sanityinc-tomorrow-night-theme.el")))
+ (home-page "https://github.com/purcell/color-theme-sanityinc-tomorrow")
+ (synopsis "Emacs color themes based on Chris Kempson's 'tomorrow' themes")
+ (description
+ "An Emacs version of Chris Kempson's \"Tomorrow\" themes, with much more
+extensive face definitions than the \"official\" Emacs variant.")
+ (license license:gpl3+))))
+
(define-public emacs-solarized-theme
(package
(name "emacs-solarized-theme")

base-commit: 3d0cdf963820da665d71987c15cae6e503efc701
--
2.41.0
L
L
Liliana Marie Prikler wrote on 14 Oct 2023 20:29
ec4605f1b8ef76695e035d14181541a419d323fd.camel@gmail.com
Am Samstag, dem 14.10.2023 um 19:47 +0200 schrieb Rostislav Svoboda:
Toggle quote (50 lines)
> * gnu/packages/emacs-xyz.scm (emacs-color-theme-sanityinc-tomorrow):
> New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 40
> ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 40 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index bb8c25f9b5..1d10188b9c 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -11057,6 +11057,46 @@ (define-public emacs-moe-theme-el
>  variants.")
>      (license license:gpl3+)))
>  
> +(define-public emacs-color-theme-sanityinc-tomorrow
> +  (let ((commit "d34e8db507ee0c7b465ff18a8f220c33ed77cd79")
> +        (revision "0"))
> +    (package
> +      (name "emacs-color-theme-sanityinc-tomorrow")
> +      (version (git-version "0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url
> +               
> "https://github.com/purcell/color-theme-sanityinc-tomorrow")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> "1mfildi7rav2j42avii7z4gp4ghl04cqv8wp1vyxzl8vkyj60nkb"))))
> +      (build-system emacs-build-system)
> +      (arguments
> +       (list
> +        #:tests? #true
> +        #:test-command
> +        #~(list "emacs" "-Q" "--batch" "--eval" "
> +(progn
> +  (setq byte-compile-error-on-warn t)
> +  (push default-directory load-path))
> +"
> +                "-f" "batch-byte-compile"
> +                "color-theme-sanityinc-tomorrow.el"
> +                "sanityinc-tomorrow-blue-theme.el"
> +                "sanityinc-tomorrow-bright-theme.el"
> +                "sanityinc-tomorrow-day-theme.el"
> +                "sanityinc-tomorrow-eighties-theme.el"
> +                "sanityinc-tomorrow-night-theme.el")))
The tests should not be byte compilation. In fact, these files should
be compiled by the build phase.
Toggle quote (16 lines)
> +      (home-page
> "https://github.com/purcell/color-theme-sanityinc-tomorrow")
> +      (synopsis "Emacs color themes based on Chris Kempson's
> 'tomorrow' themes")
> +      (description
> +       "An Emacs version of Chris Kempson's \"Tomorrow\" themes,
> with much more
> +extensive face definitions than the \"official\" Emacs variant.")
> +      (license license:gpl3+))))
> +
>  (define-public emacs-solarized-theme
>    (package
>      (name "emacs-solarized-theme")
>
> base-commit: 3d0cdf963820da665d71987c15cae6e503efc701

Cheers
R
R
Rostislav Svoboda wrote on 14 Oct 2023 22:26
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
CAEtmmewNtKbqd39mttDhYW3pYnNZhYF1CqWFzmFm_jbD-GERDQ@mail.gmail.com
Toggle quote (2 lines)
> The tests should not be byte compilation. In fact, these files should be compiled by the build phase.

I see now that the emacs-build-system 'byte compiles all Emacs Lisp
files.' Then, I think the entire `(arguments ...)` can be elided. If
this is correct, I am resending the patch (see attachment). If not,
please direct me to some examples or explain in more detail how to
byte-compile the *.el file during the build phase. Thank you.

(FYI the code under #:test-command was from
R
R
Rostislav Svoboda wrote on 15 Oct 2023 00:09
Re: bug#66545: Acknowledgement ([PATCH] gnu: Add emacs-color-theme-sanityinc-tomorrow.)
(address . 66545@debbugs.gnu.org)
CAEtmmeyM4n3tyC51bqfpMVbJ5YZ9bF7kyG6jk_mFqkyZS4oYTQ@mail.gmail.com
Please consider reviewing the following two patches together:

[PATCH] gnu: Add emacs-color-theme-sanityinc-tomorrow.

[PATCH] gnu: Add emacs-color-theme-sanityinc-solarized.

Le sam. 14 oct. 2023 à 19:49, GNU bug Tracking System
<help-debbugs@gnu.org> a écrit :
Toggle quote (26 lines)
>
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
> Andrew Tropin <andrew@trop.in>, Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>, Liliana Marie Prikler <liliana.prikler@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 66545@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 66545: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=66545
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
S
S
Steve George wrote on 5 Mar 12:52 +0100
merging 66545 66550
(address . control@debbugs.gnu.org)
1709639527-3638-bts-steve@futurile.net
merge 66545 66550
thanks
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66545@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66545
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch