[PATCH] gnu: ffmpeg: add svt-av1 support

  • Done
  • quality assurance status badge
Details
6 participants
  • Andy Tai
  • Andy Tai
  • Andy Tai
  • Maxim Cournoyer
  • Bruno Victal
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
Merged with

Debbugs page

Andy Tai wrote 1 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
b91a2b081184d6b59123d22b43541fe8bb197dde.1697004980.git.atai@atai.org
* gnu/packages/video.scm (ffmpeg): Add support for svt-av1
[inputs]: Add svt-av1
[arguments] (configure-flags): Add "--enable-libsvtav1"
---
gnu/packages/video.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bb6ce0cbf1..a2d9fe054c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1624,6 +1624,7 @@ (define-public ffmpeg
soxr
speex
srt
+ svt-av1
twolame
vidstab
x265
@@ -1712,6 +1713,7 @@ (define-public ffmpeg
"--enable-libsoxr"
"--enable-libspeex"
"--enable-libsrt"
+ "--enable-libsvtav1"
"--enable-libtheora"
"--enable-libtwolame"
"--enable-libvidstab"

base-commit: f4e8baf3806e79d7111d2943859865ae4ee0b59d
--
2.41.0
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E-WpLndxyMVy+=xaT1MDihz4k_S6HZajR2FvVpj9D=QDA@mail.gmail.com
merge 63095 66460
Bruno Victal wrote 1 years ago
(name . Andy Tai)(address . atai@atai.org)
87pm1l1aha.fsf@makinata.eu
Hi Andy,

Does svt-av1 imply the use of AVX2?
Maxim has observed some breakage in [1] with the use of svt-hevc.



--
Thanks,
Bruno.
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E_zKEgafY=mZ9ud7WKM52kpeJqcchKrxCYEiVGwy5WjRg@mail.gmail.com
unmerge 63095
unmerge 61990
Maxim Cournoyer wrote 1 years ago
(name . Bruno Victal)(address . mirai@makinata.eu)
87lec9ch9q.fsf@gmail.com
Hi,

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (5 lines)
> Hi Andy,
>
> Does svt-av1 imply the use of AVX2?
> Maxim has observed some breakage in [1] with the use of svt-hevc.

It seems not an issue, reading
If there's no AVX2 support, SSE2 will be used, which will be slower but
backward compatible with all x86_64 CPUs made after the year 2000 :-).

--
Thanks,
Maxim
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E8Mj5zRyd6UtpRp24DmQgMhFNqokO8+Xb9YnVKziZL7bw@mail.gmail.com
merge 66459 61990
merge 66460 63095 66331
Andy Tai wrote 1 years ago
(address . 66460@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
9c2cf12741d28c6c4a3b3ab5f5effdeff5f0e3e0.1697785165.git.atai@atai.org
* gnu/packages/video.scm (ffmpeg): Add support for svt-av1
[inputs]: Add svt-av1
[arguments] (configure-flags): Add "--enable-libsvtav1"
---
gnu/packages/video.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bb6ce0cbf1..a2d9fe054c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1624,6 +1624,7 @@ (define-public ffmpeg
soxr
speex
srt
+ svt-av1
twolame
vidstab
x265
@@ -1712,6 +1713,7 @@ (define-public ffmpeg
"--enable-libsoxr"
"--enable-libspeex"
"--enable-libsrt"
+ "--enable-libsvtav1"
"--enable-libtheora"
"--enable-libtwolame"
"--enable-libvidstab"

base-commit: 68fe73cf39cb9347ecb4c87f466ddf1fd044269c
--
2.41.0
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E_LZjbgfU9=__S9sy3PLgf7ZGMZWioaGPqJtNdPsNBG7A@mail.gmail.com
close 63095

thanks

already applied
Vagrant Cascadian wrote 12 months ago
(address . control@debbugs.gnu.org)
87jzlvv2am.fsf@wireframe
unarchive 63095
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZfyDoQAKCRDcUY/If5cW
qnlIAQD8l8q3q5TJezCKji03YJ3vzGI3OVU3p9DNlDA7jLg6nQD+J5L1BVmAruXq
zFPE0E9ayag1w5JzqTDaLZD2akjLQwA=
=VkpE
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 66460@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66460
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help