[PATCH] gnu: libepoxy: Hardcode paths to GLES libraries.

  • Done
  • quality assurance status badge
Details
2 participants
  • iyzsong
  • John Kehayias
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 19 Aug 2023 04:59
(address . guix-patches@gnu.org)
4d6f572f6f936a57f80f0447ef8b7ce0ec06b663.1692413930.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>


* gnu/packages/gl.scm (libepoxy)[arguments]<#:phases>:
Hardcode paths to libGLESv1_CM.so.1 and libGLESv2.so.2.
---
gnu/packages/gl.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index b53b42a9ba..f662f0f7da 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -742,10 +742,14 @@ (define-public libepoxy
#~(modify-phases %standard-phases
(add-before 'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
- (let ((mesa (dirname (search-input-file inputs "lib/libGL.so"))))
+ (let ((mesa-lib
+ (lambda (file)
+ (search-input-file inputs (string-append "lib/" file)))))
(substitute* (find-files "." "\\.[ch]$")
- (("libGL.so.1") (string-append mesa "/libGL.so.1"))
- (("libEGL.so.1") (string-append mesa "/libEGL.so.1")))))))))
+ (("libGL.so.1") (mesa-lib "libGL.so.1"))
+ (("libEGL.so.1") (mesa-lib "libEGL.so.1"))
+ (("libGLESv1_CM.so.1") (mesa-lib "libGLESv1_CM.so.1"))
+ (("libGLESv2.so.2") (mesa-lib "libGLESv2.so.2")))))))))
(build-system meson-build-system)
(native-inputs
(list pkg-config python))

base-commit: 597af70fd24eb85a85fa8c45008c9cfa241f4d0b
--
2.41.0
J
J
John Kehayias wrote on 6 Oct 2023 17:47
Re: bug#64981: GTK4 applications broken (missing libGLESv2)
8734ynah3r.fsf_-_@protonmail.com
Hi everyone,

Not sure if people saw this patch, has anyone tested if it fixes the
problem for them? I can include it in an upcoming mesa-updates branch
with other related updates/rebuilds.


Hope I got everyone from the original bug thread (seems many replies
didn't go directly to everyone) and cc'ed the patch number as well.

Thanks!
John

On Sat, Aug 19, 2023 at 10:59 AM, iyzsong@envs.net wrote:

Toggle quote (34 lines)
> From: ??? <iyzsong@member.fsf.org>
>
> Fixes <https://issues.guix.gnu.org/64981>.
>
> * gnu/packages/gl.scm (libepoxy)[arguments]<#:phases>:
> Hardcode paths to libGLESv1_CM.so.1 and libGLESv2.so.2.
> ---
> gnu/packages/gl.scm | 10 +++++++---
> 1 file changed, 7 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
> index b53b42a9ba..f662f0f7da 100644
> --- a/gnu/packages/gl.scm
> +++ b/gnu/packages/gl.scm
> @@ -742,10 +742,14 @@ (define-public libepoxy
> #~(modify-phases %standard-phases
> (add-before 'configure 'patch-paths
> (lambda* (#:key inputs #:allow-other-keys)
> - (let ((mesa (dirname (search-input-file inputs "lib/libGL.so"))))
> + (let ((mesa-lib
> + (lambda (file)
> + (search-input-file inputs (string-append "lib/" file)))))
> (substitute* (find-files "." "\\.[ch]$")
> - (("libGL.so.1") (string-append mesa "/libGL.so.1"))
> - (("libEGL.so.1") (string-append mesa "/libEGL.so.1")))))))))
> + (("libGL.so.1") (mesa-lib "libGL.so.1"))
> + (("libEGL.so.1") (mesa-lib "libEGL.so.1"))
> + (("libGLESv1_CM.so.1") (mesa-lib "libGLESv1_CM.so.1"))
> + (("libGLESv2.so.2") (mesa-lib "libGLESv2.so.2")))))))))
> (build-system meson-build-system)
> (native-inputs
> (list pkg-config python))
>
> base-commit: 597af70fd24eb85a85fa8c45008c9cfa241f4d0b
J
J
John Kehayias wrote on 28 Nov 2023 06:33
87zfyy8mt6.fsf@protonmail.com
On Fri, Oct 06, 2023 at 03:47 PM, John Kehayias wrote:

Toggle quote (12 lines)
> Hi everyone,
>
> Not sure if people saw this patch, has anyone tested if it fixes the
> problem for them? I can include it in an upcoming mesa-updates branch
> with other related updates/rebuilds.
>
> <https://issues.guix.gnu.org/65375>
>
> Hope I got everyone from the original bug thread (seems many replies
> didn't go directly to everyone) and cc'ed the patch number as well.
>

Pushed as 37fc2c99e0067dfd669526c61dc10d014b89c08b (on mesa-updates
first and then merged to master).

Thanks!
Closed
?