[PATCH 2/5] gnu: Add python-pymarshal.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
Merged with
S
S
Sughosha wrote on 18 Aug 2023 17:35
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
edad4fb8bdf65ecc65734f2510b2edeecf6d28a2.1692372645.git.sughosha@disroot.org
* gnu/packages/python-xyz.scm (python-pymarshal): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f8c976753..67721666ec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30686,6 +30686,28 @@ (define-public python-peachpy
supports x86_64 instructions up to AVX-512 and SHA.")
(license license:bsd-2))))
+(define-public python-pymarshal
+ (package
+ (name "python-pymarshal")
+ (version "2.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pymarshal" version))
+ (sha256
+ (base32
+ "1lhb7yim60pvclbd440zd4n50xs1d2rvmnrhhvib3hyv0dxil5j3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ;fails due to unrecognized arguments
+ (native-inputs
+ (list python-pytest))
+ (propagated-inputs (list python-bson python-pyyaml))
+ (home-page "https://gitlab.com/d3v-t00lz/pymarshal")
+ (synopsis "Pythonic implementation of Golang struct (un)marshalling")
+ (description "PyMarshal replicates the feature of (un)marshalling structs
+in Golang.")
+ (license license:bsd-2)))
+
(define-public python-sgmllib3k
(let ((commit "799964676f35349ca2dd04503e34c2b3ad522c0d")
(revision "1"))
--
2.41.0
C
C
Christopher Baines wrote on 13 Oct 2023 11:48
(no subject)
(address . control@debbugs.gnu.org)
87bkd297l3.fsf@cbaines.net
merge 65367 65368 65369
thanks
L
L
Ludovic Courtès wrote on 13 Jun 11:36 +0200
Re: [bug#65367] [PATCH v4 0/4] gnu: Add stargate.
(name . Sughosha)(address . sughosha@disroot.org)
871q51jiap.fsf@gnu.org
Hi,

Sughosha <sughosha@disroot.org> skribis:

Toggle quote (5 lines)
> gnu: Add python-pymarshal.
> gnu: Add python-mido.
> gnu: Add python-wavefile.
> gnu: Add stargate.

I applied the whole series and followed up with a patch that moves
‘stargate-sbsms’ and ‘stargate-soundtouch’ to audio.scm.

Thanks!

Ludo’.
Closed
S
S
Sughosha wrote on 13 Jun 18:01 +0200
(name . Ludovic Courtès)(address . ludo@gnu.org)
D80A6FD2-2B5B-4B25-ADC6-FC305DC336CB@disroot.org
On 13 June 2024 3:06:30 pm IST, "Ludovic Courtès" <ludo@gnu.org> wrote:
Toggle quote (16 lines)
>Hi,
>
>Sughosha <sughosha@disroot.org> skribis:
>
>> gnu: Add python-pymarshal.
>> gnu: Add python-mido.
>> gnu: Add python-wavefile.
>> gnu: Add stargate.
>
>I applied the whole series and followed up with a patch that moves
>‘stargate-sbsms’ and ‘stargate-soundtouch’ to audio.scm.
>
>Thanks!
>
>Ludo’.

Hi Ludo, thanks for applying the patches. But does it make sence to package stargate's forks (which are modified to work with stargate), when we already have the upstream packages (both libsbms and soundtorch) packaged?
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65369@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65369
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch