(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
* gnu/packages/python-xyz.scm (python-wavefile): New variable.
---
gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Toggle diff (60 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c5e170b628..7f8c976753 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -163,6 +163,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages algebra)
#:use-module (gnu packages astronomy)
#:use-module (gnu packages attr)
+ #:use-module (gnu packages audio)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
@@ -230,6 +231,7 @@ (define-module (gnu packages python-xyz)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages protobuf)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -1711,6 +1713,37 @@ (define-public python-pymediainfo
access the technical and tag data for video and audio files.")
(license license:expat)))
+(define-public python-wavefile
+ (package
+ (name "python-wavefile")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "wavefile" version))
+ (sha256
+ (base32
+ "02qcms8xx24r1d14idwyx04sw9ydp6rivff5s64hgp668mnfdar3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-libsndfile-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "wavefile/libsndfile.py"
+ (("libsndfile\\.so")
+ (search-input-file inputs "/lib/libsndfile.so")))))
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (setenv "LD_LIBRARY_PATH" (getenv "LIBRARY_PATH")))))))
+ (inputs
+ (list libsndfile))
+ (propagated-inputs (list python-numpy python-pyaudio))
+ (home-page "https://github.com/vokimon/python-wavefile")
+ (synopsis "Pythonic wave file reader and writer")
+ (description "This package provides pythonic wave file reader and writer.")
+ (license license:gpl3+)))
+
(define-public python-psutil
(package
(name "python-psutil")
--
2.41.0