[PATCH] gnu: ardour: Build locales.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Denys Nykula
Owner
unassigned
Submitted by
Denys Nykula
Severity
normal

Debbugs page

Denys Nykula wrote 2 years ago
(address . guix-patches@gnu.org)(name . Denys Nykula)(address . vegan@libre.net.ua)
20230813143802.15927-1-vegan@libre.net.ua
The TRANSLATORS file in the Ardour source says the i18n waf phase
is optional between the build and install phases.

* gnu/packages/audio.scm (ardour)[#:phases] Add build-i18n.
---
Tested the resulting build by running 'LANG=de_DE.UTF-8 ardour7'.

gnu/packages/audio.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8c15189b2b..006d21bbff 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -776,6 +776,9 @@ (define-public ardour
libdir "/panners" ":"
libdir "/surfaces" ":"
libdir "/vamp" "\"]"))))))
+ (add-after 'build 'build-i18n
+ (lambda _
+ (invoke "python" "waf" "i18n")))
(add-after 'install 'install-freedesktop-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.40.1
Maxim Cournoyer wrote 2 years ago
(name . Denys Nykula)(address . vegan@libre.net.ua)(address . 65271-done@debbugs.gnu.org)
87o7igf864.fsf@gmail.com
Hi!

Denys Nykula <vegan@libre.net.ua> writes:

Toggle quote (22 lines)
> The TRANSLATORS file in the Ardour source says the i18n waf phase
> is optional between the build and install phases.
>
> * gnu/packages/audio.scm (ardour)[#:phases] Add build-i18n.
> ---
> Tested the resulting build by running 'LANG=de_DE.UTF-8 ardour7'.
>
> gnu/packages/audio.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 8c15189b2b..006d21bbff 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -776,6 +776,9 @@ (define-public ardour
> libdir "/panners" ":"
> libdir "/surfaces" ":"
> libdir "/vamp" "\"]"))))))
> + (add-after 'build 'build-i18n
> + (lambda _
> + (invoke "python" "waf" "i18n")))

Installed, thanks for your contribution.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 65271@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 65271
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help