(address . guix-patches@gnu.org)
The importlib workaround inherited from python-shiboken-2 is not required for
building python-pyside-6, and will cause a build issue on the identation.
* gnu/packages/qt.scm (python-shiboken-6)[arguments]<#:phases>: Delete
'workaround-importlib-error.
Reported-by: Formbi <formbi@protonmail.com>
---
gnu/packages/qt.scm | 1 +
1 file changed, 1 insertion(+)
Toggle diff (16 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a79338f84e..e8654eee44 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4005,6 +4005,7 @@ (define-public python-shiboken-6
(substitute-keyword-arguments (package-arguments python-shiboken-2)
((#:phases p)
#~(modify-phases #$p
+ (delete 'workaround-importlib-error)
(replace 'use-shiboken-dir-only
(lambda _ (chdir "sources/shiboken6")))))
((#:configure-flags flags)
base-commit: 76e041f9eef85bb039c5251d3350c62ee2066883
--
2.41.0