[PATCH] gnu: python-shiboken-6: Remove inherited workaround.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Hilton Chain
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 25 Jul 2023 02:16
(address . guix-patches@gnu.org)
bdf8a8591e97f061da0b27694700648813349c20.1690244119.git.hako@ultrarare.space

The importlib workaround inherited from python-shiboken-2 is not required for
building python-pyside-6, and will cause a build issue on the identation.

* gnu/packages/qt.scm (python-shiboken-6)[arguments]<#:phases>: Delete
'workaround-importlib-error.

Reported-by: Formbi <formbi@protonmail.com>
---
gnu/packages/qt.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a79338f84e..e8654eee44 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4005,6 +4005,7 @@ (define-public python-shiboken-6
(substitute-keyword-arguments (package-arguments python-shiboken-2)
((#:phases p)
#~(modify-phases #$p
+ (delete 'workaround-importlib-error)
(replace 'use-shiboken-dir-only
(lambda _ (chdir "sources/shiboken6")))))
((#:configure-flags flags)

base-commit: 76e041f9eef85bb039c5251d3350c62ee2066883
--
2.41.0
A
A
Andreas Enge wrote on 26 Jul 2023 14:42
(name . Hilton Chain)(address . hako@ultrarare.space)
ZMEUv1by5ORpdd4F@jurong
Hello,

Am Tue, Jul 25, 2023 at 08:16:11AM +0800 schrieb Hilton Chain:
Toggle quote (2 lines)
thanks for the report and the fix! I confirm it makes the package itself and
its unique dependent package python-pyside-6 build.

Closing the bug.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64841@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64841
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch