(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
Hi!
The package python-shiboken-6 fails with this error:
*** Error compiling 'signature_bootstrap.py'...
Sorry: IndentationError: unexpected indent (signature_bootstrap.py, line 64)
The line in question (and the neighboring ones for context) looks like this:
import base64
import importlib
import importlib.machinery as imachi
import io
import sys
import traceback
import zipfile
I tried adding this to the package definition, but it didn't help:
(add-before 'build 'remove-indent
(lambda _
(substitute* "sources/shiboken6/libshiboken/embed/signature_bootstrap.py"
((" import importlib.machinery as imachi")
"import importlib.machinery as imachi"))))
Someone on IRC suggested to use this, but it didn't work either:
(add-before 'build 'remove-indent
(lambda _
(substitute* "libshiboken/embed/signature_bootstrap.py"
(("[ \t]*(import
importlib\\.machinery.*)" _ suffix) suffix))))
How should I go about fixing this?
Kind regards