‘guix system image’ fails to create image while invoking ‘grub-bios-setup’

  • Done
  • quality assurance status badge
Details
6 participants
  • Yann Dupont
  • Josselin Poiret
  • Ludovic Courtès
  • Ludovic Courtès
  • Nicolas Graves
  • Sergey Trofimov
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 13 Jul 2023 11:33
(address . bug-guix@gnu.org)
87sf9syx3m.fsf@inria.fr
Hello,

There seems to be a recent regression:

Toggle snippet (58 lines)
$ cat mini-os.scm
(use-modules (gnu))
(operating-system
(host-name "mini-1")
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(targets '("/dev/sda"))))
(file-systems (cons (file-system
(device (file-system-label "my-root"))
(mount-point "/")
(type "ext4")) %base-file-systems))
(kernel-arguments (list "console=tty0 console=ttyS0,115200")))
$ guix system image mini-os.scm

[...]

building /gnu/store/99wmrm4ali4f4pnii21rlhjvpfds762j-boot.drv...
building /gnu/store/6gra5cyiilyv3dm3jc7yhkga0kygblhn-system.drv...
building /gnu/store/xf50b8cm7ida4rgxp2q69vp2jhsl3kzp-grub.cfg.drv...
building /gnu/store/69nhv7idhf1i7a3j8pdchkdd5jj5fl7l-partition.img.drv...
building /gnu/store/74sxq3x9gwq0wlwqrrs0lqkr0n14p1kd-partition.img.drv...
building /gnu/store/dnqxyq1x7fd5131rby4z46rx8wkzw1k6-genimage.cfg.drv...
building /gnu/store/rvq9sqk55qwk27j8m3gjhba7f4zjid2k-disk-image.drv...
-builder for `/gnu/store/rvq9sqk55qwk27j8m3gjhba7f4zjid2k-disk-image.drv' failed with exit code 1
build of /gnu/store/rvq9sqk55qwk27j8m3gjhba7f4zjid2k-disk-image.drv failed
View build log at '/var/log/guix/drvs/rv/q9sqk55qwk27j8m3gjhba7f4zjid2k-disk-image.drv.gz'.
guix system: error: build of `/gnu/store/rvq9sqk55qwk27j8m3gjhba7f4zjid2k-disk-image.drv' failed
$ zcat /var/log/guix/drvs/rv/q9sqk55qwk27j8m3gjhba7f4zjid2k-disk-image.drv.gz | tail -20
INFO: hdimage(image): writing GPT
INFO: hdimage(image): writing protective MBR
INFO: hdimage(image): writing MBR
/gnu/store/0f4z2i472rfd3qphl82j7jm49qgm672d-grub-2.06/sbin/grub-bios-setup: error: cannot find a device for . (is /dev mounted?).
Backtrace:
2 (primitive-load "/gnu/store/i6khnb475pxagfvjwnhi09z07n5?")
In ice-9/eval.scm:
619:8 1 (_ #(#<directory (guile-user) 7ffff77f7c80> ("/gn?" ?) ?))
In ./guix/build/utils.scm:
812:6 0 (invoke "/gnu/store/0f4z2i472rfd3qphl82j7jm49qgm672d-g?" ?)

./guix/build/utils.scm:812:6: In procedure invoke:
ERROR:
1. &invoke-error:
program: "/gnu/store/0f4z2i472rfd3qphl82j7jm49qgm672d-grub-2.06/sbin/grub-bios-setup"
arguments: ("-m" "device.map" "-r" "hd0,msdos2" "-d" "." "images/image")
exit-status: 1
term-signal: #f
stop-signal: #f
environment variable `PATH' set to `/gnu/store/n31fw25l5yxq17x52mm7jjbvld58f8zd-genimage-15-1.ec44ae0/bin:/gnu/store/yr39rh6wihd1wv6gzf7w4w687dwzf3vb-coreutils-9.1/bin:/gnu/store/016lrymzc8a1rpx2p1app1awp2w2wlpk-findutils-4.9.0/bin:/gnu/store/nl2ddwgdw4mzghv6kzl6akg1s7p7yik8-qemu-minimal-7.2.1/bin'
$ guix describe
Generation 269 Jul 10 2023 00:17:51 (current)
guix d2cf631
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: d2cf63165119fc78c9f52abce2ce66af23e49243

Conversely, it works with a commit from two weeks ago:

Toggle snippet (13 lines)
$ guix time-machine --commit=269cfe341f242c2b5f37774cb9b1e17d9aa68e2c -- system image mini-os.scm

[...]

building /gnu/store/k4r5d09slzl70sn4zbl0gpnzn1mb5ksy-system.drv...
building /gnu/store/13z2cyi9n4isyrw5ashhcazy4ps8qffy-grub.cfg.drv...
building /gnu/store/7sx021qpby1p57fqv5n5jkfz20qi9933-partition.img.drv...
building /gnu/store/vw5n9q3z6k59mcsw7z4kb6ckp9bbc8nh-partition.img.drv...
building /gnu/store/hq7lw7qm3fbl4fhlmqxxp9sw1v8h3h3m-genimage.cfg.drv...
building /gnu/store/dil3qjisdkprw20kybr1bxmp6sid7g2v-disk-image.drv...
/gnu/store/5lsi1wp59vwnk8rk2124y14p9r2fr9yc-disk-image

A relevant difference seems to be GPT vs. MBR (the latter works, the
former breaks):

Toggle snippet (10 lines)
$ cat $(guix build /gnu/store/hq7lw7qm3fbl4fhlmqxxp9sw1v8h3h3m-genimage.cfg.drv) |head -3
image image {
hdimage {
partition-table-type = "mbr"
$ cat $(guix build /gnu/store/dnqxyq1x7fd5131rby4z46rx8wkzw1k6-genimage.cfg.drv) |head -3
image image {
hdimage {
partition-table-type = "gpt"

The culprit might be 209204e23b39af09e0ea92540b6fa00a60e6a0ae, from

Josselin, Sergey, WDYT?

Ludo’.
J
J
Josselin Poiret wrote on 16 Jul 2023 13:08
Re: bug#64593: ‘guix system image ’ fails to create image while invoking ‘grub-bios-setup’
87351of71j.fsf@jpoiret.xyz
Hi Ludo,

Ludovic Courtès <ludovic.courtes@inria.fr> writes:

Toggle quote (5 lines)
> The culprit might be 209204e23b39af09e0ea92540b6fa00a60e6a0ae, from
> <https://issues.guix.gnu.org/62223>.
>
> Josselin, Sergey, WDYT?

Apologies! Our install-grub-disk-image doesn't really support GPT
right, now but this is easy to fix (I've successfully booted your
example with a local change). However, for this to work we need to have
a BIOS Boot partition instead of the ESP that's defined for efi images.
We have two options here, either add a new image type that has that
instead of the ESP (which means duplicating a bunch of them...), or make
the partition of efi-raw change depending on the bootloader, which would
need some refactoring. I'm not a big fan of either options though :)

WDYT?
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmSzz5kQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaijNuC/4jNQrsuW9Yo1mb4ol52uKFSW+jK3RxLwct
VrXJT0o+XFsX/jawHxCsiJcHh+giRc31RbAwYplup9dsoAQXSGbO79Oi7vyiKpDl
hrLoxHQ2IFF6G8b/0UdCYs+Xc0BtZZplqjP+bdoJep8CfM6Na9ujItE+pw/nusp6
zNT/y57LVH2fErE5d7FZRVQcr3/NflxS+yG8TJt5O0dx+obWNzMcHDXj5POW5NAh
1I9qRSr7dCtaYDbQ1HWIUeWCIMW7Kita4EZnjp5YkHn2GAqGlIP2hPozTvIANOTM
VOT0YRNZdbeAljJd3w7SlPfkgC8/NiHIqLKQs9p+tIPK9igT6KnDW0E5T34Zn59x
kq9XijGMuS/pO59FVye9eCsqBgOtP9EqreE24L0BmECcU2Lxpv7USPix/0vOM9kb
502X6D9sFh51ay15QKFdPwYk85rcLnX9WLm/WiX6SRv6WnKD1YdHewt6D4ONmEqP
DW1JvvPIIcoQ6lU4r2Bspq+INRHaMLc=
=ZAUc
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 17 Jul 2023 18:11
(name . Josselin Poiret)(address . dev@jpoiret.xyz)
87mszuplfj.fsf@inria.fr
Hi Josselin,

Josselin Poiret <dev@jpoiret.xyz> skribis:

Toggle quote (16 lines)
> Ludovic Courtès <ludovic.courtes@inria.fr> writes:
>
>> The culprit might be 209204e23b39af09e0ea92540b6fa00a60e6a0ae, from
>> <https://issues.guix.gnu.org/62223>.
>>
>> Josselin, Sergey, WDYT?
>
> Apologies! Our install-grub-disk-image doesn't really support GPT
> right, now but this is easy to fix (I've successfully booted your
> example with a local change). However, for this to work we need to have
> a BIOS Boot partition instead of the ESP that's defined for efi images.
> We have two options here, either add a new image type that has that
> instead of the ESP (which means duplicating a bunch of them...), or make
> the partition of efi-raw change depending on the bootloader, which would
> need some refactoring. I'm not a big fan of either options though :)

I’m not sure what a good fix is, but I think we should make sure ‘guix
system image’ (‘-t efi-raw’, that is) doesn’t remain broken.

One possible short-term option is to revert, or maybe we could
special-case along these lines:
Toggle diff (18 lines)
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index 841e7e0c7e..b4ed4181ac 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -204,7 +204,12 @@ (define-syntax-rule (image-with-os base-image os)
(define efi-raw-image-type
(image-type
(name 'efi-raw)
- (constructor (cut image-with-os efi-disk-image <>))))
+ (constructor (cut image-with-os
+ (image-without-os
+ (format 'disk-image)
+ (partition-table-type 'mbr) ;XXX
+ (partitions (list esp-partition root-partition)))
+ <>))))
(define efi32-raw-image-type
(image-type
WDYT?
Ludo’.
S
S
Sergey Trofimov wrote on 18 Jul 2023 20:34
(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
871qh56p84.fsf@sarg.org.ru
Hi Ludovic,

shouldn't it be `(bootloader grub-efi-bootloader)` if you're
building a `efi-raw` image?
With efi grub it builds and boots just fine, as I've tested before
submitting the patch.

Ludovic Courtès <ludovic.courtes@inria.fr> writes:

Toggle quote (20 lines)
> Hello,
>
> There seems to be a recent regression:
>
> $ cat mini-os.scm
> (use-modules (gnu))
>
> (operating-system
> (host-name "mini-1")
>
> (bootloader (bootloader-configuration
> (bootloader grub-bootloader)
> (targets '("/dev/sda"))))
> (file-systems (cons (file-system
> (device (file-system-label "my-root"))
> (mount-point "/")
> (type "ext4")) %base-file-systems))
> (kernel-arguments (list "console=tty0 console=ttyS0,115200")))
> $ guix system image mini-os.scm
>
J
J
Josselin Poiret wrote on 19 Jul 2023 10:43
87v8ege1f8.fsf@jpoiret.xyz
Hi Sergey,

Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (5 lines)
> shouldn't it be `(bootloader grub-efi-bootloader)` if you're
> building a `efi-raw` image?
> With efi grub it builds and boots just fine, as I've tested before
> submitting the patch.

I think I agree with you that you should expect efi images to use efi
bootloaders. The efi-raw image name is a bit misleading I would argue,
since the image type doesn't decide what bootloader is used, and using a
BIOS bootloader with an efi image seems a bit weird. The fact that it's
used as the default image type is a bit troubling though, so we could
add a new default image type that uses MBR, so that BIOS bootloaders
work with it.

WDYT Ludo?

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmS3oksQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5Fhcaip1YC/9csr64ejULka1ImiJuMrIXANv3JJDsVGnQ
kc7oN/tMJHDOqrS2g3Jpv/BGSPTVxaCF6zpOMARKNbPjBH7Sus2O116g4AW9G1/p
vX2OTL7yQHXsS9jnsoY65409jcs8CCHaSDJz3Yl4TYyLMjctOAjsMLhejxV3Fmhr
qHMEXeelJgM9j1/1+Vk5F/MRN8a+7Ob9irr4iTz0MmPYGCrEgU99Hpv1jGIUNBy+
L9z7InX3F+LslPR+iOiOFNtO+qwQwfryowpTOP9jwlM3IatQwvmXtMs+baV06IKW
b5m+NyshSDCb0QlnTfXtLeVUp2LGCpuO+wnL9gp4ZCN9E/0hs1N4ppvsJcgv7XDy
URrY/pgrlVft512bM4GiAd00KdmAvlxkwYEOOxO1CeZGY/2vMRJ1sx9Qh8V0CQHh
ydkHLs/ZqROOIB/anb/k/AoVerNmzFGayB4kabnEHLAPOxFtPYx4aMGWp5Pp2rJH
wY2wa8F0LSHUdgEJewbWyLWcimOS5MA=
=9d/G
-----END PGP SIGNATURE-----

Y
Y
Yann Dupont wrote on 21 Jul 2023 09:43
‘guix system image’ fails to create image while invoking ‘grub-bios-setup’
(address . 64593@debbugs.gnu.org)
c39e1c98-7340-6cce-e478-83c8c5f8a2eb@univ-nantes.fr
Hello, as it was after discussion with Ludovic that he posted this bug
report, let me express my opinion as a simple user.

it's just a matter of consistency: very basically, the examples mention
grub-bootloader. With the default image type (efi-raw), it's been
working perfectly for years (maybe by chance, but in any case it seemed
to be a compatible combination). The recent change means that it no
longer works :-).  What's more, the error message isn't very explicit,
and doesn't point to a configuration error but to what may appear to be
a recently-introduced bug. Switching to grub-efi-bootloader allows you
to build the image (and start it).

I don't know if it's simply possible to have a consistency check between
the image type and the bootloader used: "Bootloader probably not
compatible with image type, please use grub-efi-bootloader".

Maybe just change the doc to include grub-efi-bootloader in the
examples. Or indeed have a format that remains compatible with MBR
partitioning and the appropriate grub.

--

Yann
Attachment: smime.p7s
J
J
Josselin Poiret wrote on 27 Jul 2023 18:35
[PATCH] image: Add mbr-raw-image-type and use by default.
e728bab29dce1766f3212daa8b3ac92d63a95170.1690475375.git.dev@jpoiret.xyz
From: Josselin Poiret <dev@jpoiret.xyz>

* gnu/system/image.scm (mbr-disk-image, mbr-raw-image-type): New variables.
* guix/scripts/system.scm (%default-options): Use mbr-raw-image-type by
default.
---

How about this for now? I think the bootloader/image-type situation is not
clear, but at least this keeps the behavior of the previous default option.

gnu/system/image.scm | 16 ++++++++++++++++
guix/scripts/system.scm | 2 +-
2 files changed, 17 insertions(+), 1 deletion(-)

Toggle diff (65 lines)
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index 841e7e0c7e..92e659753e 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -76,6 +76,7 @@ (define-module (gnu system image)
esp32-partition
root-partition
+ mbr-disk-image
efi-disk-image
iso9660-image
docker-image
@@ -84,6 +85,7 @@ (define-module (gnu system image)
raw-with-offset-disk-image
image-with-os
+ mbr-raw-image-type
efi-raw-image-type
efi32-raw-image-type
qcow2-image-type
@@ -145,6 +147,15 @@ (define root-partition
(flags '(boot))
(initializer (gexp initialize-root-partition))))
+(define mbr-disk-image
+ (image-without-os
+ (format 'disk-image)
+ (partition-table-type 'mbr)
+ (partitions
+ (list (partition
+ (inherit root-partition)
+ (offset root-offset))))))
+
(define efi-disk-image
(image-without-os
(format 'disk-image)
@@ -201,6 +212,11 @@ (define-syntax-rule (image-with-os base-image os)
(inherit base-image)
(operating-system os)))
+(define mbr-raw-image-type
+ (image-type
+ (name 'mbr-raw)
+ (constructor (cut image-with-os mbr-disk-image <>))))
+
(define efi-raw-image-type
(image-type
(name 'efi-raw)
diff --git a/guix/scripts/system.scm b/guix/scripts/system.scm
index d7163dd3eb..95c68a5f33 100644
--- a/guix/scripts/system.scm
+++ b/guix/scripts/system.scm
@@ -1168,7 +1168,7 @@ (define %default-options
(debug . 0)
(verbosity . #f) ;default
(validate-reconfigure . ,ensure-forward-reconfigure)
- (image-type . efi-raw)
+ (image-type . mbr-raw)
(image-size . guess)
(install-bootloader? . #t)
(label . #f)

base-commit: c7e45139faa27b60f2c7d0a4bc140f9793d97d47
--
2.41.0
N
N
Nicolas Graves wrote on 27 Jul 2023 19:47
87mszhdz5p.fsf@ngraves.fr
On 2023-07-27 18:35, Josselin Poiret via Bug reports for wrote:

Toggle quote (10 lines)
> From: Josselin Poiret <dev@jpoiret.xyz>
>
> * gnu/system/image.scm (mbr-disk-image, mbr-raw-image-type): New variables.
> * guix/scripts/system.scm (%default-options): Use mbr-raw-image-type by
> default.
> ---
>
> How about this for now? I think the bootloader/image-type situation is not
> clear, but at least this keeps the behavior of the previous default option.

I can confirm that this works for my particular issue of failure when running
guix system image --expression="(@(gnu system install) installation-os)".

--
Best regards,
Nicolas Graves
L
L
Ludovic Courtès wrote on 7 Aug 2023 09:35
Re: bug#64593: ‘guix system image ’ fails to create image while invoking ‘grub-bios-setup’
(name . Josselin Poiret)(address . dev@jpoiret.xyz)
87edkfxq2f.fsf@inria.fr
Hi,

Josselin Poiret <dev@jpoiret.xyz> skribis:

Toggle quote (15 lines)
> Sergey Trofimov <sarg@sarg.org.ru> writes:
>
>> shouldn't it be `(bootloader grub-efi-bootloader)` if you're
>> building a `efi-raw` image?
>> With efi grub it builds and boots just fine, as I've tested before
>> submitting the patch.
>
> I think I agree with you that you should expect efi images to use efi
> bootloaders. The efi-raw image name is a bit misleading I would argue,
> since the image type doesn't decide what bootloader is used, and using a
> BIOS bootloader with an efi image seems a bit weird. The fact that it's
> used as the default image type is a bit troubling though, so we could
> add a new default image type that uses MBR, so that BIOS bootloaders
> work with it.

Yes, we could do that.

I guess my confusion stems from the fact that the default image type
changed to EFI recently (right?).

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 7 Aug 2023 09:39
(name . Josselin Poiret)(address . dev@jpoiret.xyz)
87a5v3xpvd.fsf_-_@gnu.org
Hi,

Josselin Poiret <dev@jpoiret.xyz> skribis:

Toggle quote (10 lines)
> From: Josselin Poiret <dev@jpoiret.xyz>
>
> * gnu/system/image.scm (mbr-disk-image, mbr-raw-image-type): New variables.
> * guix/scripts/system.scm (%default-options): Use mbr-raw-image-type by
> default.
> ---
>
> How about this for now? I think the bootloader/image-type situation is not
> clear, but at least this keeps the behavior of the previous default option.

LGTM!

Maybe add “Fixes https://issues.guix.gnu.org/64593.” to the commit log.

Ludo’.
J
J
Josselin Poiret wrote on 8 Aug 2023 11:02
(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
87wmy5ewl2.fsf@jpoiret.xyz
Hi everyone,

Ludovic Courtès <ludovic.courtes@inria.fr> writes:

Toggle quote (3 lines)
> I guess my confusion stems from the fact that the default image type
> changed to EFI recently (right?).

No, the image type had always been efi-raw iirc, just that efi images
now use GPT partitioning, and BIOS booting on GPT drives need an extra
BIOS partition to store the bootloader which used to be stored in empty
space after the MBR headers. There really wasn't anything EFI at all
about the efi image type before though imo…

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmTSBIoQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcailYNC/0V0fyt+y8q5G6K3BPGdFwzUPol4jYnHpoG
9VRdgRTVyDh+iqOiw7M9kzKFsgKzMTGZomSUk/8TGlOew4RIgHPVDlUfTuSkSpKV
9oSBBm1ClpIIABZjLzqJLbzUkJYP2s9g5DBqKC6WYdUJQLOa2NaR1U+jTtigwNSE
8b8cfzdJp5ewLqa+8LKeYwJdfPqLP/hoqXeJRdo9BaX93k+6TEH718gPNIZLq/a1
aEehZ5IiIn2pLlDpRJxzsIM2iWT0dbSZ/QNX67RVQvKYPKeX1wMqOEdx8529CVaQ
1EZZAKnGzr9+jUDfVvNQHrhjR5pIPOY6z5D+JNXEzUXuS9fiqyCnR8WeXcI0B3jM
nNGYuB+Ch4uWJGy8kbBwhxrrnQBS4DoX3l1H3w46ef0Q4tSc34qwaMeZKe3BVCax
V88mhVJwQB6ApxqBIAj/HufymTZUrmZkN2+NQ8AMAWDrZC9agjoCZ4Tll88lDUHj
nuB2LEQ2Ns5t8kRSRkkJmc6JvEVqLIs=
=4eDW
-----END PGP SIGNATURE-----

J
J
Josselin Poiret wrote on 25 Aug 2023 18:33
(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
87il93t72i.fsf@jpoiret.xyz
Hi,

Pushed d57cab764122af69d52d8cc9c843456044e5d7bc that adds mbr-image-type
and sets it as default.

LMKWYT, closing tentatively.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmTo1/UQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaionkC/9VlQDfpkd2/5eUZf5KhOyLPUWZjgmTirTQ
E9Dayz4aSgLqWgg4wL30oaET57cCNenPgcNUWn1/hrv/SRtkIpZwKO617NX4tYSe
2nSZ4RYrGzJsCVc6+jKfe2KyRNYnBiQsn3q7fEJipCRsZBzGJq5TlaWIjsoWyzcT
h8oGbFER4TE7r5UXxr0VcxTHMaO5BwPlPW0uKbEZEdJJe+wtzp9zT+QcJxULwM0l
Fxw2fcEeZIK32BYMCdUoMVTYopM4N6nBfWgVO7IR4kgakM3l2NQBIRtyTRQ6teR3
29TaXbc2BpA4DqreT1kdAMFT74BOpracvVydaTrMtRNNIkt+z6B6mgQSQu3PXtyC
hTvCjYt+Qk5gPnYobs27HlEy3/Exe7a80pEaFBgL8LVBsVth01iV0Jw5NFTm2SkX
XwjapIIiO/vc6UCpcla1LyGTo7RX5dpudjGBmwsgZXlnGoUCMFjzlKjTTkom0E5o
P+RYvBUcssJo+gYFLWjW8Qn+Cvyn22Y=
=sL8G
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64593@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64593
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch