[PATCH 0/9]: gnu: Monthly astronomy packages update II.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Tobias Geerinckx-Rice
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:26
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1687727967.git.sharlatanus@gmail.com
Hi Guix!

Here is the second portion of updated packages which required slightly more
time to fix build.

Toggle quote (11 lines)
> ./pre-inst-env guix build $(./pre-inst-env guix refresh --list-dependent weightwatcher swarp eye missfits skymaker stuff xplanet celestia celestia-gtk | awk -F: '{print $2}')
> /gnu/store/wlj0qmqmdanf9lnp8pwhl8cbp17hfy0h-weightwatcher-1.12
> /gnu/store/rjmllavswr3gh16r2a71lsv3xpy77jb9-swarp-2.41.2
> /gnu/store/849qwh680v5jfwvkqmzxywc5fc2m5yw4-eye-1.4.1
> /gnu/store/0j8d53v2xqhv01ynf2mfrvs6gq7apvrq-missfits-2.8.0
> /gnu/store/h32vvmk6skh6ayg2k85v8pr13yxladys-skymaker-3.10.5-0.1a69c47
> /gnu/store/pfz0kn2pzg3jwsa14xc79n1vs4gis053-stuff-1.26.0-0.9008dc0
> /gnu/store/zjcj1f3y5rznrfxrp170i6rxdjlixazr-xplanet-1.3.1
> /gnu/store/8z64qb4cwlg6858rx4mfzc36fpwvhiri-celestia-1.6.3
> /gnu/store/f3gz0dax5xdyw9zc7y4mwmjaymki2lb1-celestia-gtk-1.6.3

Sharlatan Hellseher (9):
gnu: weightwatcher: Fix build.
gnu: swarp: Update to 2.41.2, fix build.
gnu: eye: Fix build.
gnu: missfits: Fix build.
gnu: skymaker: Update to 3.10.5-0.1a69c47, fix build.
gnu: stuff: Update to 1.26.0-0.9008dc0, fix build.
gnu: xplanet: Use G-expressions.
gnu: celestia: Update to 1.6.3.
gnu: celestia-gtk: Fix build.

gnu/packages/astronomy.scm | 321 ++++++++++++++++++++++---------------
1 file changed, 194 insertions(+), 127 deletions(-)


base-commit: e4087930f3ad60918689be5f4bca4ce3e22429f5
prerequisite-patch-id: 7c008dd4fca64d840022c7493ddcda0945d1a8f0
prerequisite-patch-id: 248d09752ee3528ab7c045fd7c02fbd96bcd07fb
prerequisite-patch-id: 01eee56f1f2420e733ae33bd39f5dfbb83206aaf
prerequisite-patch-id: b6ad7866b5505bb97ada7a9f753472d579bffe29
prerequisite-patch-id: 3e7c5aa22cc6bb3e339a6ecb409493f1aeb62000
prerequisite-patch-id: 05b64135894b24f6dc13d710f6b772fe217ca160
prerequisite-patch-id: c9e7396a083dfccebd4d66c676dc37c943b1a2f8
prerequisite-patch-id: 1cd7ce03c60d65b087e7e32927a3dcb22d917891
prerequisite-patch-id: f6fd4ac8c72806e169fc93dc0095995318186791
prerequisite-patch-id: 67c06616d8e3020a82731f83e2270049a05e06c7
prerequisite-patch-id: 3d7cffe6b2cd524f638ae0240fc1ed613b7b1029
prerequisite-patch-id: 7889c1c3dae3a087ab122a428546c0bd164624ed
prerequisite-patch-id: d9d5994805a5acd9dd5c3df21e40d464185ad838
prerequisite-patch-id: 7bfbbf9850fb5812585d257372f34fedabd47378
prerequisite-patch-id: 14e8a915fdd6aa622328a7b2a17b16f3259f8325
prerequisite-patch-id: 466d016b2cd921bc731f3ec6abc4c2e5768d592f
prerequisite-patch-id: 3323bc68f3e425662103c8c515cd293eb9673386
prerequisite-patch-id: 616bcc41a9f9bcfed23f3aedb532c5f4059f54d3
prerequisite-patch-id: 9f1c337775791a16aa470f2b965c6e5caa59d183
prerequisite-patch-id: 3628c515672b3893ae23e417f32667a5666701e5
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 1/9] gnu: weightwatcher: Fix build.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
03d1a3b2e920b08aceff49350d4719a3d88e4fc9.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (weightwatcher): Fix build.
[source]: Swap to 'git-fetch, as source was removed from home page.
[arguments]: Add #:configure-flags to fix the build phase.
---
gnu/packages/astronomy.scm | 18 ++++++++++++++----
1 file changed, 14 insertions(+), 4 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 6c43003618..a7faa2c425 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -641,12 +641,22 @@ (define-public weightwatcher
(version "1.12")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/weightwatcher/"
- "weightwatcher-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/weightwatcher")
+ (commit version)))
(sha256
- (base32 "1zaqd8d9rpgcwjsp92q3lkfaa22i20gppb91dz34ym54swisjc2p"))))
+ (base32
+ "0701z6bdqq32jv7ga3n6jh27q684ni0hbfjm1mak7rh0qqx089gi"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list
+ ;; Address this link error:
+ ;; ld: ... multiple definition of ... first defined here
+ "CFLAGS=-O2 -g -fcommon")))
(home-page "https://www.astromatic.net/software/weightwatcher")
(synopsis "Weight-map/flag-map multiplexer and rasteriser")
(description
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 2/9] gnu: swarp: Update to 2.41.2, fix build.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
7e40590ad060bef311017b13740651748867e528.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (swarp): Update to 2.41.2, fix build.
[source]: Swap to 'git-fetch.
[native-inputs]: Add automake, autoconf, libtool, pkg-config.
[inputs]: Add cfitsio.
---
gnu/packages/astronomy.scm | 23 ++++++++++++++++++-----
1 file changed, 18 insertions(+), 5 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a7faa2c425..17bc4ed7d7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1073,15 +1073,28 @@ (define-public stuff
(define-public swarp
(package
(name "swarp")
- (version "2.38.0")
+ (version "2.41.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/swarp/"
- "swarp-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/swarp")
+ (commit (string-append "v" version))))
(sha256
- (base32 "1i670waqp54vin1cn08mqckcggm9zqd69nk7yya2vvqpdizn6jpm"))))
+ (base32 "1ycdk5h77mflw3hnmkczj1m2603aks9vq6555f3vc5vj1shx2d4m"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list
+ ;; Address this link error:
+ ;; ld: ... multiple definition of ... first defined here
+ "CFLAGS=-O2 -g -fcommon")))
+ (native-inputs
+ (list automake autoconf libtool pkg-config))
+ (inputs
+ (list cfitsio))
(home-page "https://www.astromatic.net/software/swarp")
(synopsis "FITS image resampling and co-addition")
(description
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 3/9] gnu: eye: Fix build.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
f1529d8e867762b9782b12bd77efe8383d68676d.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (eye): Fix build.
[source]: Swap to 'git-fetch
[arguments]: Add CPPFLAGS to pass build with GCC 10.
---
gnu/packages/astronomy.scm | 17 +++++++++++++----
1 file changed, 13 insertions(+), 4 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 17bc4ed7d7..326a9a170e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -579,12 +579,21 @@ (define-public eye
(version "1.4.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/eye/"
- "eye-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/eye")
+ (commit version)))
(sha256
- (base32 "092qhzcbrkcfidbx4bv9wz42w297n80jk7a6kwyi9a3fjfz81d7k"))))
+ (base32 "1j8rpgz3fjp6fw0qmxgfqycf3n01fzxds4w12vgyrhbnk658ia41"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list
+ ;; Address this link error:
+ ;; ld: ... multiple definition of ... first defined here
+ "CPPFLAGS=-O2 -g -fcommon")))
(home-page "https://www.astromatic.net/software/eye")
(synopsis "Small image feature detector using machine learning")
(description
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 4/9] gnu: missfits: Fix build.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
1e52f7155bcaf6a73a32c5d8b17d450d060abf82.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (missfits): Fix build.
[source]: Swap to 'git-fetch.
[arguments]: Add CPPFLAGS to pass build with GCC 10.
---
gnu/packages/astronomy.scm | 17 +++++++++++++----
1 file changed, 13 insertions(+), 4 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 326a9a170e..4c869fc295 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2653,12 +2653,21 @@ (define-public missfits
(version "2.8.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/missfits/"
- "missfits-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/missfits")
+ (commit version)))
(sha256
- (base32 "04jrd7fsvzr14vdmwgj2f6v97gdcfyjyz6jppml3ghr9xh12jxv5"))))
+ (base32 "12ndvrr3l5j7ph2i5f3qf0wqmv5ymsyjzxnnypqajsvliw72iprh"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list
+ ;; Address this link error:
+ ;; ld: ... multiple definition of ... first defined here
+ "CPPFLAGS=-O2 -g -fcommon")))
(home-page "https://www.astromatic.net/software/missfits")
(synopsis "FITS files Maintenance program")
(description
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 5/9] gnu: skymaker: Update to 3.10.5-0.1a69c47, fix build.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
c33c50105c07ebb54354c68152662d5dc91b02bb.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (skymaker): Update to 3.10.5-0.1a69c47, fix
build.
[source]: Swap to 'git-checkout and pin to the latest commit as upstream
version tag is not available.
[arguments]: Use G-expressions. #:configure-flags add CPPFLAGS to pass
build on GCC 10.
[native-inputs]: Add automake, autoconf, libtool, pkg-config.
---
gnu/packages/astronomy.scm | 57 ++++++++++++++++++++++----------------
1 file changed, 33 insertions(+), 24 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4c869fc295..b5d96c932f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -900,34 +900,43 @@ (define-public splash
(license license:gpl2+)))
(define-public skymaker
- (package
- (name "skymaker")
- (version "3.10.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/skymaker/"
- "skymaker-" version ".tar.gz"))
- (sha256
- (base32 "03zvx7c89plp9559niqv5532r233kza3ir992rg3nxjksqmrqvx1"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
+ ;; XXX: No version tag availalbe in GitHub.
+ ;; See: https://github.com/astromatic/skymaker/issues/3
+ (let ((commit "1a69c4716bdc9b5c6d4a917b0bc2dbd47635c459")
+ (revision "0"))
+ (package
+ (name "skymaker")
+ (version (git-version "3.10.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/skymaker")
+ (commit commit)))
+ (sha256
+ (base32 "1vin4vgvcmqmwjdchsxnap374559rksz55xmaliawnl3qpzxn1nk"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
(list
- (string-append
- "--with-fftw-libdir=" (assoc-ref %build-inputs "fftw") "/lib")
- (string-append
- "--with-fftw-incdir=" (assoc-ref %build-inputs "fftw") "/include"))))
- (inputs
- `(("fftw" ,fftwf)))
- (home-page "https://www.astromatic.net/software/skymaker")
- (synopsis "Astronomical image simulator")
- (description
- "SkyMaker is a program that simulates astronomical images. It accepts
+ #:configure-flags
+ #~(list
+ "CPPFLAGS=-O2 -g -fcommon"
+ (string-append
+ "--with-fftw-libdir=" #$(this-package-input "fftwf") "/lib")
+ (string-append
+ "--with-fftw-incdir=" #$(this-package-input "fftwf") "/include"))))
+ (native-inputs
+ (list automake autoconf libtool pkg-config))
+ (inputs (list fftwf))
+ (home-page "https://www.astromatic.net/software/skymaker")
+ (synopsis "Astronomical image simulator")
+ (description
+ "SkyMaker is a program that simulates astronomical images. It accepts
object lists in ASCII generated by the Stuff program to produce realistic
astronomical fields. SkyMaker is part of the EFIGI
(@url{https://www.astromatic.net/projects/efigi}) development project.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public stackistry
(package
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 6/9] gnu: stuff: Update to 1.26.0-0.9008dc0, fix build.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
c4f762e6151c246e60ce2c90fdba4bae91a356fc.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (stuff): Update to 1.26.0-0.9008dc0, fix build.
[source]: Swap to 'git-checkout.
[native-inputs]: Add automake, autoconf, libtool, pkg-config.
---
gnu/packages/astronomy.scm | 40 +++++++++++++++++++++++---------------
1 file changed, 24 insertions(+), 16 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b5d96c932f..310a6340f5 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1068,25 +1068,33 @@ (define-public stellarium
(license license:gpl2+)))
(define-public stuff
- (package
- (name "stuff")
- (version "1.26.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/stuff/"
- "stuff-" version ".tar.gz"))
- (sha256
- (base32 "1syibi3b86z9pikhicvkkmgxm916j732fdiw0agw0lq6z13fdcjm"))))
- (build-system gnu-build-system)
- (home-page "https://www.astromatic.net/software/stuff")
- (synopsis "Astronomical catalogue simulation")
- (description
- "Stuff is a program that simulates \"perfect\" astronomical catalogues.
+ ;; XXX: No version tag availalbe in GitHub.
+ ;; See: https://github.com/astromatic/stuff/issues/6
+ (let ((commit "9008dc022ef53331092da248cf0a794abd6783bf")
+ (revision "0"))
+ (package
+ (name "stuff")
+ (version (git-version "1.26.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/stuff")
+ (commit commit)))
+ (sha256
+ (base32 "004sry5lqqm7s9x4l3agysp3n63y3ga35x1rwwda4m6dc6zvla6b"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list automake autoconf libtool pkg-config))
+ (home-page "https://www.astromatic.net/software/stuff")
+ (synopsis "Astronomical catalogue simulation")
+ (description
+ "Stuff is a program that simulates \"perfect\" astronomical catalogues.
It generates object lists in ASCII which can read by the SkyMaker program to
produce realistic astronomical fields. Stuff is part of the EFIGI development
project.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public swarp
(package
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 7/9] gnu: xplanet: Use G-expressions.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
e4d227f5bd7a1abc084109dd43fe3be949bdaf1e.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (xplanet): Use G-expressions, improve
package style.
[inputs]: Remove labels.
---
gnu/packages/astronomy.scm | 39 +++++++++++++++++++-------------------
1 file changed, 20 insertions(+), 19 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 310a6340f5..b212f4614f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2720,28 +2720,29 @@ (define-public xplanet
"xplanet-1.3.1-libimage_gif.c.patch"
"xplanet-1.3.1-xpUtil-Add2017LeapSecond.cpp.patch"))))
(build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list
+ ;; no nasa jpl cspice support
+ "--without-cspice"
+ ;; Give correct path for pnm.h header to configure script
+ (string-append
+ "CPPFLAGS=-I" #$(this-package-input "netpbm") "/include/netpbm"))))
(native-inputs
(list pkg-config))
(inputs
- `(("libx11" ,libx11)
- ("libxscrnsaver" ,libxscrnsaver)
- ("libice" ,libice)
- ("freetype" ,freetype)
- ("pango" ,pango)
- ("giflib" ,giflib)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("netpbm" ,netpbm)
- ("zlib" ,zlib)))
- (arguments
- `(#:configure-flags
- (let ((netpbm (assoc-ref %build-inputs "netpbm")))
- (append (list
- ;; Give correct path for pnm.h header to configure script
- (string-append "CPPFLAGS=-I" netpbm "/include/netpbm")
- ;; no nasa jpl cspice support
- "--without-cspice" )))))
+ (list libx11
+ freetype
+ giflib
+ libice
+ libjpeg-turbo
+ libpng
+ libtiff
+ libxscrnsaver
+ netpbm
+ pango
+ zlib))
(home-page "https://xplanet.sourceforge.net/")
(synopsis "Planetary body renderer")
(description
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 9/9] gnu: celestia-gtk: Fix build.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
76b42eb0eea478c61da9215fc5b2e1b7fa1c078d.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (celestia-gtk): Fix build.
Use (package/inherit ...) over (inherit ...), see
[arguments]: Use G-expressions.
[inputs]: Swap to (modify-inputs ...) procedure. Add cairo, libxmu,
libtheora, pango-1.42.
---
gnu/packages/astronomy.scm | 21 ++++++++++++---------
1 file changed, 12 insertions(+), 9 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index af75d493f6..ca32ad8950 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1182,18 +1182,21 @@ (define-public celestia
accurately in real time at any rate desired.")
(license license:gpl2+)))
-
(define-public celestia-gtk
- (package
- (inherit celestia)
+ (package/inherit celestia
(name "celestia-gtk")
- (inputs
- (append (alist-delete "freeglut" (package-inputs celestia))
- `(("gtk2" ,gtk+-2)
- ("gtkglext" ,gtkglext))))
(arguments
- `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
- #:tests? #f))))
+ (list
+ #:configure-flags
+ #~(list "--enable-cairo"
+ "--enable-theora"
+ "--with-gtk"
+ (string-append "--with-lua=" #$(this-package-input "lua")))))
+ (inputs
+ (modify-inputs (package-inputs celestia)
+ (replace "freeglut" gtk+-2)
+ (prepend cairo gtkglext libxmu libtheora pango-1.42)))
+ (synopsis "GTK+ build for the Celestia package.")))
(define-public python-astropy
(package
--
2.40.1
S
S
Sharlatan Hellseher wrote on 25 Jun 2023 23:28
[PATCH 8/9] gnu: celestia: Update to 1.6.3.
(address . 64287@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
f7913c1c7391acfa38cdd72c882f90497f28c8d7.1687727967.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (celestia): Update to 1.6.3, improve
package style.
[build-system]: Swap to 'gnu-build-system as versioned tag does not
contain Cmake build files.
[arguments]: Use G-expressions, update configure-flags to be compatible
with autoconf.
[native-inputs]: Remove labels. Add autoconf, automake.
[inputs]: Remove labels. Remove eigen, fmt-7, glew.
---
gnu/packages/astronomy.scm | 91 ++++++++++++++++++++------------------
1 file changed, 48 insertions(+), 43 deletions(-)

Toggle diff (109 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b212f4614f..af75d493f6 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1129,54 +1129,59 @@ (define-public swarp
(license license:gpl3+)))
(define-public celestia
- (let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
- (package
- (name "celestia")
- (version (git-version "1.6.1" "815" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/celestiaproject/celestia")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "00xibg87l1arzifakgj7s828x9pszcgx7x7ij88a561ig49ryh78"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("perl" ,perl)
- ("libgit2" ,libgit2)
- ("pkg-config" ,pkg-config)
- ("libtool" ,libtool)
- ("gettext" ,gettext-minimal)))
- (inputs
- `(("glu" ,glu)
- ("glew" ,glew)
- ("libtheora" ,libtheora)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ;; maybe required?
- ("mesa" ,mesa)
- ;; optional: fmtlib, Eigen3;
- ("fmt" ,fmt-7)
- ("eigen" ,eigen)
- ;; glut: for glut interface
- ("freeglut" ,freeglut)))
- (propagated-inputs
- (list lua))
- (arguments
- `(#:configure-flags '("-DENABLE_GLUT=ON" "-DENABLE_QT=OFF")
- #:tests? #f)) ;no tests
- (home-page "https://celestia.space/")
- (synopsis "Real-time 3D visualization of space")
- (description
- "This simulation program lets you explore our universe in three
+ (package
+ (name "celestia")
+ (version "1.6.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/celestiaproject/celestia")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dzci5n7gcnm1vq916gsn9zddkhbzhbsakqxrpnmvzibsqznn6c8"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Make sure it detects the Lua's version packed in Guix.
+ ;; Review this part to support current default version of Lua in Guix.
+ (substitute* "configure.ac"
+ (("lua5.3") "lua-5.3"))))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "--with-glut"
+ (string-append "--with-lua=" #$(this-package-input "lua")))))
+ (native-inputs
+ (list autoconf
+ automake
+ gettext-minimal
+ libgit2
+ libtool
+ perl
+ pkg-config))
+ (inputs
+ (list freeglut
+ glu
+ libjpeg-turbo
+ libpng
+ libtheora
+ mesa))
+ (propagated-inputs
+ (list lua))
+ (home-page "https://celestia.space/")
+ (synopsis "Real-time 3D visualization of space")
+ (description
+ "This simulation program lets you explore our universe in three
dimensions. Celestia simulates many different types of celestial objects.
From planets and moons to star clusters and galaxies, you can visit every
object in the expandable database and view it from any point in space and
time. The position and movement of solar system objects is calculated
accurately in real time at any rate desired.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
+
(define-public celestia-gtk
(package
--
2.40.1
S
S
Sharlatan Hellseher wrote on 4 Jul 2023 15:07
(address . 64287@debbugs.gnu.org)
CAO+9K5rB46CQ95o3neqsAuGo1yj_8hShWST3azQHqm70bjx7Tg@mail.gmail.com
Hi Guix team!

A gentle ping on this and related issue.

Regards,
Oleg
Attachment: file
S
S
Sharlatan Hellseher wrote on 8 Jul 2023 20:56
(address . 64287@debbugs.gnu.org)(address . me@tobias.gr)
CAO+9K5pKx6DAKjZ6-LRHJMpXJfgKFpiF1G3wP3Vvzb6Se5+U0A@mail.gmail.com
Hi Tobias,

I see you merged updates to wcslib in (gnu packages astronomy), if you have
a chance to take a look at these 2 sets of patches which have updates and
build fix for the same module.

Thanks,
Oleg

On Tue, 4 Jul 2023, 14:07 Sharlatan Hellseher, <sharlatanus@gmail.com>
wrote:

Toggle quote (7 lines)
> Hi Guix team!
>
> A gentle ping on this and related issue.
>
> Regards,
> Oleg
>
Attachment: file
T
T
Tobias Geerinckx-Rice wrote on 8 Jul 2023 21:19
Re:
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 64287@debbugs.gnu.org)
87sf9ydxcm.fsf@nckx
Oleg,

Sure!

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCZKm26Q0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15D/AA/As3k3eKSLfD0dOWmugguC5R6jHGgyMDDxfFukye
s1wjAQCtnGEBpEGn+1e9nQFuu51akhth7NdhU7/4wRJZXseYDw==
=ynux
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 9 Jul 2023 10:30
(address . 64287-done@debbugs.gnu.org)
CAO+9K5rpNW00+TYaJXQgSVq3gr8=7hBnGNG8NWDHykm_hvYhgw@mail.gmail.com

Attachment: file
Closed
S
S
Sharlatan Hellseher wrote on 9 Jul 2023 10:41
(address . 64287@debbugs.gnu.org)(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
CAO+9K5qbAj_7nqi9Tf-FyuX5yU4hXYVJ3WA9a2yCkc13dVCTKQ@mail.gmail.com
Oops,

I sent close request too early, not all of the patches are merged yet.



On Sat, 8 Jul 2023, 19:56 Sharlatan Hellseher, <sharlatanus@gmail.com>
wrote:

Toggle quote (20 lines)
> Hi Tobias,
>
> I see you merged updates to wcslib in (gnu packages astronomy), if you
> have a chance to take a look at these 2 sets of patches which have updates
> and build fix for the same module.
>
> Thanks,
> Oleg
>
> On Tue, 4 Jul 2023, 14:07 Sharlatan Hellseher, <sharlatanus@gmail.com>
> wrote:
>
>> Hi Guix team!
>>
>> A gentle ping on this and related issue.
>>
>> Regards,
>> Oleg
>>
>
Attachment: file
A
A
Andreas Enge wrote on 24 Jul 2023 20:30
Re: Scheduled monthly update for (gnu packages astronomy)
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
ZL7DTJpcPB6fvlAf@jurong
Hello Oleg,

Am Mon, Jul 24, 2023 at 06:36:18PM +0100 schrieb Sharlatan Hellseher:
Toggle quote (3 lines)
> This issue may be closed https://issues.guix.gnu.org/64287as Tobias
> applied all of it's patches.

good, closing it with this email by cc-ing 64287-done@debbugs.gnu.org.

Toggle quote (3 lines)
> I'm not sure about the reason of splittingt them into smaller ones, it
> may be a question to him :-)

Well, it makes sense to separate package updates from package rewrites,
like going from old style to gexps. For instance if the latter induce
a lot of whitespace changes and the former just a version and hash
update, they are easier to review separately. Then ultimately these are
also matters of personal taste...

Toggle quote (3 lines)
> I'll rebase patches from https://issues.guix.gnu.org/64201to the
> current master branch and sent V2, hope they are look ok.

Great, hopefully QA will catch up soon so we can simply apply patches
with a green button.

Andreas
Closed
?