[PATCH core-updates] gnu: tzdata: Update to 2023c

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Andy Tai
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
051bf5390bf38d92602519cb4275f28a05622775.1686443945.git.atai@atai.org
* gnu/packages/base.scm (tzdata): Update to 2023c
---
gnu/packages/base.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d2f276c447..f203296f22 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1455,7 +1455,7 @@ (define-public tzdata
(name "tzdata")
;; This package should be kept in sync with python-pytz in (gnu packages
;; time).
- (version "2022a")
+ (version "2023c")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1463,7 +1463,7 @@ (define-public tzdata
version ".tar.gz"))
(sha256
(base32
- "0r0nhwpk9nyxj5kkvjy58nr5d85568m04dcb69c4y3zmykczyzzg"))))
+ "0p4nvp5bdxxdqh269nvvcfrpycbbfwm31al5whwbpsaa3dfhnl9z"))))
(build-system gnu-build-system)
(arguments
(list #:tests? #f
@@ -1531,7 +1531,7 @@ (define-public tzdata
version ".tar.gz"))
(sha256
(base32
- "1iysv8fdkm79k8wh8jizmjmq075q4qjhk090vxjy57my6dz5wmzq")))))
+ "1rqln88ki0jagi372nqyn7bs03rf2l33081sy2835mwsn4mpzla6")))))
(home-page "https://www.iana.org/time-zones")
(synopsis "Database of current and historical time zones")
(description "The Time Zone Database (often called tz or zoneinfo)

base-commit: 6fe9a004dba2d4ddf69ff6f1714af15ffaa7e62a
--
2.40.1
Andy Tai wrote 2 years ago
[PATCH v2] gnu: tzdata: Add version 2023c
(address . 64001@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
0a78e66621eeeab99bd2690f6506bdf7ff30541d.1686633880.git.atai@atai.org
* gnu/packages/base.scm (tzdata-next): Version 2023c as new variable
---
gnu/packages/base.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index d2f276c447..fa9fe5580f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1551,6 +1551,27 @@ (define-public tzdata
;;; package.
(define-public tzdata-for-tests tzdata)
+;; needed for Europe/Kyiv addition
+(define-public tzdata-next
+ (package/inherit tzdata
+ (version "2023c")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://data.iana.org/time-zones/releases/tzdata"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0p4nvp5bdxxdqh269nvvcfrpycbbfwm31al5whwbpsaa3dfhnl9z"))))
+ (inputs (list (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://data.iana.org/time-zones/releases/tzcode"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rqln88ki0jagi372nqyn7bs03rf2l33081sy2835mwsn4mpzla6")))))))
+
(define-public libiconv
(package
(name "libiconv")

base-commit: 6fe9a004dba2d4ddf69ff6f1714af15ffaa7e62a
--
2.40.1
Andy Tai wrote 2 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E_AYjGvuNAGVitU4s0RfkH1bRRCZ-jPW6GO22FNmZ-4QQ@mail.gmail.com
block 64084 by 64001, 64012

Thanks

Mate desktop 1.26 needs
itzdata-next, libxml2-next, python-libxml2-next, itstool-with-utf8-fix
Andreas Enge wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)
ZL4uNd3PZWoSgppI@jurong
Hello Andy,

Am Mon, Jun 26, 2023 at 12:09:41PM -0700 schrieb Andy Tai:
Toggle quote (4 lines)
> The state of them is that there are two prerequisites that have passed
> Guix QA check:
> https://issues.guix.gnu.org/64001

I had a quick look at this patch, but am a bit confused. If I read it
correctly, it updates tzdata (which causes a lot of rebuilds, and without
updating python-pytz as stipulated by a comment in the code of tzdata),
and then it creates a new variable tzdata-next which looks to be the same.

Would the good approach not be to update tzdata and python-pytz, and to
copy the old version into tzdata-for-tests?

It is quite possible I am misunderstanding something, and in any case I
would like to defer to someone more knowledgeable about the core packages.

Andreas
Andy Tai wrote 2 years ago
(name . Andreas Enge)(address . andreas@enge.fr)
CAJsg1E8VjPWpcmeXKs8mSOvL5Cs=BpfgD+XtS0pkW8YtEQ=Apw@mail.gmail.com
Hi, these patches have been merged by Mr. Song (iyzsong@envs.net) . He
worked to get these built without the two extra patches. Thanks

On Mon, Jul 24, 2023 at 12:54 AM Andreas Enge <andreas@enge.fr> wrote:

Toggle quote (22 lines)
> Hello Andy,
>
> Am Mon, Jun 26, 2023 at 12:09:41PM -0700 schrieb Andy Tai:
> > The state of them is that there are two prerequisites that have passed
> > Guix QA check:
> > https://issues.guix.gnu.org/64001
>
> I had a quick look at this patch, but am a bit confused. If I read it
> correctly, it updates tzdata (which causes a lot of rebuilds, and without
> updating python-pytz as stipulated by a comment in the code of tzdata),
> and then it creates a new variable tzdata-next which looks to be the same.
>
> Would the good approach not be to update tzdata and python-pytz, and to
> copy the old version into tzdata-for-tests?
>
> It is quite possible I am misunderstanding something, and in any case I
> would like to defer to someone more knowledgeable about the core packages.
>
> Andreas
>
>

--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2023 民國112年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Attachment: file
Andreas Enge wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)
ZL6ocM8zJy9XlsTd@jurong
Am Mon, Jul 24, 2023 at 09:28:38AM -0700 schrieb Andy Tai:
Toggle quote (3 lines)
> Hi, these patches have been merged by Mr. Song (iyzsong@envs.net) . He worked
> to get these built without the two extra patches. Thanks

So closing the bugs
if this was a misunderstanding, please feel free to reopen them or to
submit new patches.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64001@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64001
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help