(address . bug-guix@gnu.org)
Hello,
While trying to work with guix and add the ocaml-lsp-server for
ocaml@5.0 I think I faced a bug.
I did not find the root cause, but I think this is due to the fact of
using a combination of (inherit) and (package-with-ocaml5.0).
Here is a minimal example to reproduce the bug :
---
(use-modules
(gnu packages ocaml)
(guix build-system ocaml))
;ocaml-dune-build-info
(package-with-ocaml5.0 ocaml-dune-build-info)
---
Building the commented default version will create the expected package
in /gnu/store/...ocaml-dune-build-info
While building the ocaml5.0 version will build /gnu/store/...ocaml5.0-dune
I do not exactly know in which direction I should search to fix this
issue but there might be a bug in "package-with-ocaml5.0" function
Is this really a bug ? Or I did not use properly the
package-withocaml5.0 function.
Thanks
Benjamin