[PATCH] gnu: sbsigntools: Update to 0.9.5.

  • Done
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • Felix Lechner
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
Merged with
K
K
kiasoc5 wrote on 29 May 2023 23:53
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
782d12b0f1d53565166394065415862fba56bff1.1685397220.git.kiasoc5@disroot.org
This fixes a build failure with openssl-3.

* gnu/packages/efi.scm (sbsigntools): Update to 0.9.5.
[arguments]: Remove trailing #t's. Use Gexps. Use "this-package-input". Simplify lambdas.
[inputs]: Remove labels.
---
gnu/packages/efi.scm | 58 +++++++++++++++++++++-----------------------
1 file changed, 28 insertions(+), 30 deletions(-)

Toggle diff (96 lines)
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 75eb24bf86..50d52c4d65 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -30,6 +30,7 @@ (define-module (gnu packages efi)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -99,7 +100,7 @@ (define-public efi-analyzer
(define-public sbsigntools
(package
(name "sbsigntools")
- (version "0.9.4")
+ (version "0.9.5")
(source
(origin
(method git-fetch)
@@ -110,34 +111,31 @@ (define-public sbsigntools
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "1y76wy65y6k10mjl2dm5hb5ms475alr4s080xzj8y833x01xvf3m"))))
+ (base32 "060n6w0dx1mrilhdv482ncckanqz6pdv53piimiki0bm15d2fcp4"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-more-shebangs
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "lib/ccan.git/tools/create-ccan-tree"
- (("#!/bin/bash")
- (string-append "#!"
- (assoc-ref inputs "bash")
- "/bin/bash")))
- #t))
- (add-after 'unpack 'patch
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* '("configure.ac"
- "tests/Makefile.am")
- (("/usr/include/efi")
- (string-append (assoc-ref inputs "gnu-efi")
- "/include/efi"))
- (("/usr/lib/gnuefi")
- (string-append (assoc-ref inputs "gnu-efi")
- "/lib")))
- #t))
- (add-after 'unpack 'setenv
- (lambda _
- (setenv "CC" "gcc")
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-more-shebangs
+ (lambda _
+ (substitute* "lib/ccan.git/tools/create-ccan-tree"
+ (("#!/bin/bash")
+ (string-append "#!"
+ #$(this-package-native-input "bash")
+ "/bin/bash")))))
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* '("configure.ac"
+ "tests/Makefile.am")
+ (("/usr/include/efi")
+ (string-append #$(this-package-input "gnu-efi")
+ "/include/efi"))
+ (("/usr/lib/gnuefi")
+ (string-append #$(this-package-input "gnu-efi")
+ "/lib")))))
+ (add-after 'unpack 'setenv
+ (lambda _
+ (setenv "CC" "gcc"))))))
(native-inputs
(list autoconf
automake
@@ -146,9 +144,9 @@ (define-public sbsigntools
pkg-config
util-linux)) ; getopt
(inputs
- `(("gnu-efi" ,gnu-efi)
- ("libuuid" ,util-linux "lib")
- ("openssl" ,openssl)))
+ (list gnu-efi
+ `(,util-linux "lib") ; libuuid
+ openssl))
(synopsis "EFI signing tools")
(description "This package provides tools for signing EFI binaries.")
(home-page "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git/")

base-commit: b96b82bcd4bc24529941ff74a91432481f1a71b5
--
2.40.1
F
F
Felix Lechner wrote on 30 May 2023 06:05
Merging duplicates for / gnu: sbsigntools: Update to 0.9.5.
(address . control@debbugs.gnu.org)
CAFHYt56ufVcCe6nx+YCYHu_ja=CzKpb28q7LRN=pT33cPByJAw@mail.gmail.com
forcemerge 63793 63635
thanks
F
F
Felix Lechner wrote on 31 May 2023 16:49
Merged duplicate
(address . kiasoc5@disroot.org)
CAFHYt54K9X6YRGvt_x0cM1XCkB+ni_cCM17qv5e_GBMgzyfagw@mail.gmail.com
Hi,

There is a merged duplicate to this bug that may be hidden in Mumi.
The two bugs are Bug#63793 and Bug#63635. The linkage may be easier to
see in Debbugs.

Kind regards
Felix
J
J
Josselin Poiret wrote on 4 Jun 2023 11:41
Re: [bug#63793] [PATCH] gnu: sbsigntools: Update to 0.9.5.
(name . Felix Lechner)(address . felix.lechner@lease-up.com)
87bkhvef98.fsf@jpoiret.xyz
Hi,

kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (6 lines)
> This fixes a build failure with openssl-3.
>
> * gnu/packages/efi.scm (sbsigntools): Update to 0.9.5.
> [arguments]: Remove trailing #t's. Use Gexps. Use "this-package-input". Simplify lambdas.
> [inputs]: Remove labels.

Thanks for your patch! Pushed as
f72f3a909a41dce5dc4512c30d4cd0673bc6560f with the following best
practices modifications (importantly, note cc-for-target and
search-input-file for bash).

By the way, please enable forceinbodyfrom in git so that a pristine From
field is inserted into your patches, as your mail From list is being
rewritten to comply with your domain's DKIM.

Toggle diff (59 lines)
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 50d52c4d65..499745eba1 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -114,28 +114,29 @@ (define-public sbsigntools
(base32 "060n6w0dx1mrilhdv482ncckanqz6pdv53piimiki0bm15d2fcp4"))))
(build-system gnu-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-more-shebangs
- (lambda _
- (substitute* "lib/ccan.git/tools/create-ccan-tree"
- (("#!/bin/bash")
- (string-append "#!"
- #$(this-package-native-input "bash")
- "/bin/bash")))))
- (add-after 'unpack 'patch
- (lambda _
- (substitute* '("configure.ac"
- "tests/Makefile.am")
- (("/usr/include/efi")
- (string-append #$(this-package-input "gnu-efi")
- "/include/efi"))
- (("/usr/lib/gnuefi")
- (string-append #$(this-package-input "gnu-efi")
- "/lib")))))
- (add-after 'unpack 'setenv
- (lambda _
- (setenv "CC" "gcc"))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-more-shebangs
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (substitute* "lib/ccan.git/tools/create-ccan-tree"
+ (("#!/bin/bash")
+ (string-append "#!"
+ (search-input-file (or native-inputs inputs)
+ "/bin/bash"))))))
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* '("configure.ac"
+ "tests/Makefile.am")
+ (("/usr/include/efi")
+ (string-append #$(this-package-input "gnu-efi")
+ "/include/efi"))
+ (("/usr/lib/gnuefi")
+ (string-append #$(this-package-input "gnu-efi")
+ "/lib")))))
+ (add-after 'unpack 'setenv
+ (lambda _
+ (setenv "CC" #$(cc-for-target)))))))
(native-inputs
(list autoconf
automake

--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmR8XEMQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcairsBC/9TAKHkYADXuymzDyIZYJV4q3beSYubkAio
rVqG+az5cT1zMLh4mpIlU8fDwinnGvPdjepxlfikkO/9SDsuGkPFhORZ7sl0gX4F
4uA43g7R4YorR3z7WwrFEcd7PQUF1pIjt47HZ6tTLiQt2dC9hoWTWPlm8ga2zojk
NCGL28gxrHIiMlWHoKcwNTMPfwBbCDt5F54LpQlbUTYMFASWJ5l2JIZ2jIYxxT0N
RHm69xLgABvpio+0muqb245yl236bnfzqj246mefGlWGCmMtgfCuYNp2xQk+RZxG
zM/Yr9gEEAlMc6h+1WsJSv5vFs/xr5OK6W42uC6nG2GNMMgwg1EuRkLb3QCn9+tL
M9TlhXWiT6dRAfh88/7HytjV23va6zfBAR2ZueBSltN4gdTNsSUs+SwFPfD0WG1h
NzuqdCf6wlYWZFF9uevoVM4sPob2Xtu5wqjsY55PNiVXw0XJDNo9oh4IaSC6v7Yf
TghRMSeQplTMVOIMTdhMCKAkXalC4tc=
=cVIV
-----END PGP SIGNATURE-----

Closed
K
K
kiasoc5 wrote on 4 Jun 2023 15:54
(name . Felix Lechner)(address . felix.lechner@lease-up.com)
15c235c9-6454-bdc2-5e1e-a69dc6bcb6d3@disroot.org
Hi Josselin,

On 6/4/23 05:41, Josselin Poiret wrote:

Toggle quote (5 lines)
> Thanks for your patch! Pushed as
> f72f3a909a41dce5dc4512c30d4cd0673bc6560f with the following best
> practices modifications (importantly, note cc-for-target and
> search-input-file for bash).

Thanks for merging!

What is the difference between this

Toggle quote (7 lines)
> - (lambda _
> - (substitute* "lib/ccan.git/tools/create-ccan-tree"
> - (("#!/bin/bash")
> - (string-append "#!"
> - #$(this-package-native-input "bash")
> - "/bin/bash")))))

and this?

Toggle quote (7 lines)
> + (lambda* (#:key inputs native-inputs #:allow-other-keys)
> + (substitute* "lib/ccan.git/tools/create-ccan-tree"
> + (("#!/bin/bash")
> + (string-append "#!"
> + (search-input-file (or native-inputs inputs)
> + "/bin/bash"))))))

I meant to search for bash as a native input but I guess they are different.
Closed
J
J
Josselin Poiret wrote on 4 Jun 2023 17:06
(name . Felix Lechner)(address . felix.lechner@lease-up.com)
87fs77xo56.fsf@jpoiret.xyz
Hi kiasoc5,

kiasoc5 <kiasoc5@disroot.org> writes:

Toggle quote (20 lines)
> What is the difference between this
>
>> - (lambda _
>> - (substitute* "lib/ccan.git/tools/create-ccan-tree"
>> - (("#!/bin/bash")
>> - (string-append "#!"
>> - #$(this-package-native-input "bash")
>> - "/bin/bash")))))
>
> and this?
>
>> + (lambda* (#:key inputs native-inputs #:allow-other-keys)
>> + (substitute* "lib/ccan.git/tools/create-ccan-tree"
>> + (("#!/bin/bash")
>> + (string-append "#!"
>> + (search-input-file (or native-inputs inputs)
>> + "/bin/bash"))))))
>
> I meant to search for bash as a native input but I guess they are different.

In general, the first method doesn't compose well with package
transformations that replace inputs, since it will still refer to the
original bash input. The bottom one will always search for a /bin/bash
binary among all the inputs, so will pick up a new one if the input is
replaced. Also, in general, inside phases, if you're building natively,
native-inputs is always #f and inputs also contains the native inputs,
hence the need for that (or ...) form.

HTH,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmR8qIUQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaihC5C/wPOgI/Vkp+61KZdok7GlsdyyFDMETVceMQ
Qs9p8A3tFutz8opJj2lQnDX219jDe1039UkEBkQmy449CELcxTs9vEKCs5sXJiwc
hmIJWjLo/7VUNG+KcoaybQPzuyxgBFhN3Gzr/+Bdp8LaCMZ5HoiIEkVpcepPu7DV
odjceU+24yysWnB8JOQ8mldMDA7G0Ntn0w6JhZegFxksh26kc5ibo4ZKSPf/fUvy
GGkXWdB6RCOiGhfYFn7ua6WmfhjW73DmPCDIMxQK5s78uLBMS1c1eT422W/092/E
UEwLMODbzSJfpQUypJYFAw46lz8RPNagRN5t0YxEmtMbK47Gxz5kEMaME+YuCD/K
5RrylO/6qU6PjaVQkscYPUwh5kfgNZTQXJcWQIi5YZlz5Nn+lro7Sas7Zhhn3tAX
DMpxxzWGz4Sx0gcA4CZolBgHSCRpA9dQ4fRyK4pZ+yq7ebLt+XzdN8fZ4RLKqjB+
32qe9oYkGestM3siouDRCecuiDuX3I4=
=u3M8
-----END PGP SIGNATURE-----

Closed
?