[PATCH 0/2] gnu: sbsigntools: Update to 0.9.5.

  • Done
  • quality assurance status badge
Details
One participant
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
Merged with
F
F
Felix Lechner wrote on 22 May 2023 01:13
[PATCH 0/2] gnu: sbsigntools: Update to 0.9.5,
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
cover.1684710672.git.felix.lechner@lease-up.com
This patch series brings sbsigntools up the the latest coding standards.

Felix Lechner (2):
gnu: sbsigntools: Convert to gexp, new-style inputs.
gnu: sbsigntools: Update to 0.9.5.

gnu/packages/efi.scm | 58 +++++++++++++++++++++-----------------------
1 file changed, 28 insertions(+), 30 deletions(-)


base-commit: c5bc698e8922d78ed85989985cc2ceb034de2f23
--
2.40.1
F
F
Felix Lechner wrote on 22 May 2023 01:14
[PATCH 1/2] gnu: sbsigntools: Convert to gexp, new-style inputs.
(address . 63635@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
0862d94d5bd537e3ea02e268eff832d78aaba3be.1684710672.git.felix.lechner@lease-up.com
* gnu/packages/efi.scm (sbsigntools): Convert to gexp, new-style inputs.
---
gnu/packages/efi.scm | 54 +++++++++++++++++++++-----------------------
1 file changed, 26 insertions(+), 28 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 75eb24bf86..b3da555549 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -30,6 +30,7 @@ (define-module (gnu packages efi)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -113,31 +114,28 @@ (define-public sbsigntools
(base32 "1y76wy65y6k10mjl2dm5hb5ms475alr4s080xzj8y833x01xvf3m"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-more-shebangs
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "lib/ccan.git/tools/create-ccan-tree"
- (("#!/bin/bash")
- (string-append "#!"
- (assoc-ref inputs "bash")
- "/bin/bash")))
- #t))
- (add-after 'unpack 'patch
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* '("configure.ac"
- "tests/Makefile.am")
- (("/usr/include/efi")
- (string-append (assoc-ref inputs "gnu-efi")
- "/include/efi"))
- (("/usr/lib/gnuefi")
- (string-append (assoc-ref inputs "gnu-efi")
- "/lib")))
- #t))
- (add-after 'unpack 'setenv
- (lambda _
- (setenv "CC" "gcc")
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-more-shebangs
+ (lambda _
+ (substitute* "lib/ccan.git/tools/create-ccan-tree"
+ (("#!/bin/bash")
+ (string-append "#!" #$bash "/bin/bash")))
+ #t))
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* '("configure.ac"
+ "tests/Makefile.am")
+ (("/usr/include/efi")
+ (string-append #$gnu-efi "/include/efi"))
+ (("/usr/lib/gnuefi")
+ (string-append #$gnu-efi "/lib")))
+ #t))
+ (add-after 'unpack 'setenv
+ (lambda _
+ (setenv "CC" "gcc")
+ #t)))))
(native-inputs
(list autoconf
automake
@@ -146,9 +144,9 @@ (define-public sbsigntools
pkg-config
util-linux)) ; getopt
(inputs
- `(("gnu-efi" ,gnu-efi)
- ("libuuid" ,util-linux "lib")
- ("openssl" ,openssl)))
+ (list gnu-efi
+ (list util-linux "lib")
+ openssl))
(synopsis "EFI signing tools")
(description "This package provides tools for signing EFI binaries.")
(home-page "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git/")
--
2.40.1
F
F
Felix Lechner wrote on 22 May 2023 01:14
[PATCH 2/2] gnu: sbsigntools: Update to 0.9.5.
(address . 63635@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
84470637f1f8fd1310caf599ecd4da71860cc548.1684710672.git.felix.lechner@lease-up.com
Will cause the rebuilding of a single package, namely efitools@1.9.2.

The linter complains with this message:

sbsigntools@0.9.5: label 'util-linux' does not match package name
'util-linux:lib'

* gnu/packages/efi.scm (sbsigntools): Update to 0.9.5.
---
gnu/packages/efi.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index b3da555549..c897b8c57e 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -100,7 +100,7 @@ (define-public efi-analyzer
(define-public sbsigntools
(package
(name "sbsigntools")
- (version "0.9.4")
+ (version "0.9.5")
(source
(origin
(method git-fetch)
@@ -111,7 +111,7 @@ (define-public sbsigntools
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "1y76wy65y6k10mjl2dm5hb5ms475alr4s080xzj8y833x01xvf3m"))))
+ (base32 "060n6w0dx1mrilhdv482ncckanqz6pdv53piimiki0bm15d2fcp4"))))
(build-system gnu-build-system)
(arguments
(list
--
2.40.1
F
F
Felix Lechner wrote on 22 May 2023 01:16
(address . control@debbugs.gnu.org)
CAFHYt56+NJ1YCTyNi_CxkLD48T385k7=eaoRZ8N7qPV4XJdURA@mail.gmail.com
retitle 63635 [PATCH 0/2] gnu: sbsigntools: Update to 0.9.5.
thanks
F
F
Felix Lechner wrote on 30 May 2023 06:05
(address . control@debbugs.gnu.org)
CAFHYt56ufVcCe6nx+YCYHu_ja=CzKpb28q7LRN=pT33cPByJAw@mail.gmail.com
forcemerge 63793 63635
thanks
F
F
Felix Lechner wrote on 31 May 2023 16:49
Merged duplicate
(address . kiasoc5@disroot.org)
CAFHYt54K9X6YRGvt_x0cM1XCkB+ni_cCM17qv5e_GBMgzyfagw@mail.gmail.com
Hi,

There is a merged duplicate to this bug that may be hidden in Mumi.
The two bugs are Bug#63793 and Bug#63635. The linkage may be easier to
see in Debbugs.

Kind regards
Felix
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63635@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63635
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch