python-zope-exceptions: Build failure (in test_multiline_exception test) with Python 3.10

  • Done
  • quality assurance status badge
Details
2 participants
  • Ivan Vilata i Balaguer
  • jgart
Owner
unassigned
Submitted by
Ivan Vilata i Balaguer
Severity
normal
I
I
Ivan Vilata i Balaguer wrote on 22 May 2023 18:57
(address . bug-guix@gnu.org)
ZGue6MT2c38VL1lH@sax
Hi! Building `python-zope-exceptions` 4.4 fails in the version of Guix shown below:

```
$ LANG=C guix describe
Generation 56 May 02 2023 11:25:26 (current)
guix 3f8c489
branch: master
commit: 3f8c4899a9a67bb509a603bd21dcfcfab88c0e8e
```

It looks like a Python 3.10 issue fixed in a newer upstream version. This is
the final part of the build log:

```
starting phase `check'
Running zope.testrunner.layer.UnitTests tests:
Set up zope.testrunner.layer.UnitTests in 0.000 seconds.


Failure in test test_multiline_exception (zope.exceptions.tests.test_exceptionformatter.Test_format_exception)
Traceback (most recent call last):
File "/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/lib/python3.10/unittest/case.py", line 59, in testPartExecutor
yield
File "/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/lib/python3.10/unittest/case.py", line 591, in run
self._callTestMethod(testMethod)
File "/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/lib/python3.10/unittest/case.py", line 549, in _callTestMethod
method()
File "/gnu/store/yflssryyj355226m2nq5m4971s88cmpz-python-zope-exceptions-bootstrap-4.4/lib/python3.10/site-packages/zope/exceptions/tests/test_exceptionformatter.py", line 670, in test_multiline_exception
self.assertTrue(lines[1].endswith(' ^'))
File "/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/lib/python3.10/unittest/case.py", line 687, in assertTrue
raise self.failureException(msg)
AssertionError: False is not true
```

Looking at the failing line, it looks like the commit below fixed it for
Python 3.10 compatibility:

Probably version >= 4.5 of the package (which claims "Add official support for
Python 3.9 and 3.10." does work (I've been unable to figure out the proper
`--with-XXXX` incantation to assert that).

Thanks!

--
Ivan Vilata i Balaguer -- https://elvil.net/
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEHpvwBPZcchIQr6TuPezBBfXdI4IFAmRrnt8ACgkQPezBBfXd
I4KL4w//ZDZfOSAfDp8NvRyMl2EqhKCxK4aD3KHVGDjGIm8MAD62lmFWz2ZwIA2O
UAeWIowM+tEn58S7b58xW3KoKFhALbiUeNwsiT9nR/pg2abil56ygwNTLsBcSeT7
ExclW1RftJUXDCB/3QabmsZUYZQG/pQcriwzHQgyMVi1TLSwD3gbvk7hJk9nUS1W
L+dCqOy0Zj3jhWEoUR/NALNrbpDeDnoPfoiKBomnGQ1bk7qCjtywRq01Mk1eaTA1
8UxK78DIfNXyR43lCdVaxQcks7Oz078c0tfcxqrOrsicFOHGnYzfpQd8VfPcx+iW
9uX+yN/EA8mt1yjTUn3RZwwMjgoJ0uCtFw0DZNgOlCPtFRSN4OxcYYqnPsId3Oa4
CkI0//Z4O8b8Z3kWfIInJXdhL9EP3pdbN6XhIz9CQtvCXh1mme/Q5M5LW/3ya1Yi
Q7948EB2PDBJEEsf+gyApUK/7ZFGQaW2O5w9WWO9D/5R6azWBuFlXfeEBuZAzgz2
kkTBS8csw/tOp6r/khaLOtG3gUEWblq98fnzm4cC7puFLvnfz5JNSD54fITOPcC9
Fx/bbkKyci/HnyWsT3PbNoQe+8UcTcUs5C3G3xO7aRmN7CYj/UVtERAckYCvgC+r
bYu+zyEu8v82RqxDKBpzEUcaF1iMdtGiQhGlNDJ6EyhnnsyWSK8=
=hvaL
-----END PGP SIGNATURE-----


I
I
Ivan Vilata i Balaguer wrote on 22 May 2023 20:19
[PATCH] gnu: python-zope-exceptions: Update to 4.6, Python 3.10 compatible.
(address . 63649@debbugs.gnu.org)
981f6f2432fa584cd44503be9ce22228ae5f3dd0.1684779444.git.ivan@selidor.net
Versions 4.5 and 4.6 seem to be backwards-compatible with 4.5, and they add
official support for Python 3.9, 3.10 and 3.11.


* gnu/packages/python-web.scm (python-zope-exceptions): Update to 4.6.
---
gnu/packages/python-web.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b6ad489626..32c0de3f57 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2493,14 +2494,14 @@ (define-public python-zope-interface
(define-public python-zope-exceptions
(package
(name "python-zope-exceptions")
- (version "4.4")
+ (version "4.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "zope.exceptions" version))
(sha256
(base32
- "1nkgfwawswmyc6i0b8g3ymvja4mb507m8yhid8s4rbxq3dmqhwhd"))))
+ "1kc3hql2i35ys5alkj9csiaz2s9bx0rff585vnrrgvavqsj297b1"))))
(build-system python-build-system)
(arguments
'(#:phases

base-commit: dff1689bb37e5303868584d3f1d7a33cbcb7f51e
--
2.39.2


--
Ivan Vilata i Balaguer -- https://elvil.net/
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEHpvwBPZcchIQr6TuPezBBfXdI4IFAmRrsgkACgkQPezBBfXd
I4LIixAAonuZerMyHJfrTh1XIbdvaU5Al0TzC8lR3ylA0eFX2cempSzPxM3OZDH/
K82mQ89o8S/fL786yS8puuM8kTbi3OuAiCLdDFXXBoA/avpdA7QI82Zq52G3nA/B
jtFVlOqY1AHU6mT12HPTcDd4/aZcYy34VnsSI+56m7oh1V5b17Y1xZNm3Fxf0+s/
yYl1zveLM3v9YbHmO+XF9yjLeZSuXVmcDBE0IU5prl0ilQ2idiI8Ka3M5jSNRb3Q
YVrekiPGl//LOqEKtN1zkZlixR9OFOPtTUPoiuiWOVxbUYF/rypjIrFEtXV3pOe7
4IQVgOia3GmLUGZM/zEb00VEZE1/fU4vMSn7IlMva11oD/XhVMcNJVMS60UCRSQ4
8I980xwWDE7RGzGqi9mONhOEZzvDDxeXnqqWHR6sQ8o6CZOSHqIVE+VAOrrg0eI0
2qTxeyakOLVsrDlHSnBTXpclaimDmh8KfhRaPYCPjaecbicUSpcG/XDLO3BOGxiV
fSmFOmzj3zz8K816juHe82HrzdAyKBEV7DGFXz87SfVXRFIGz2or1uuBARhaP2uC
NIrB0ynSxqhJXUhoCFUjZT7jjbVhETTgStzrwzx93o942/Un2C4FN+I0Q9T7mEF3
hN0uGYFPTXGzEY9zIcFxte6HUwfqTAkGQ1+70L/DMpHxeV2/2CA=
=sTzf
-----END PGP SIGNATURE-----


J
Re: python-zope-exceptions: Build failure (in test_multiline_exception test) with Python 3.10
(address . control@debbugs.gnu.org)
ba384d0d3b5be7722ef434f8199f5c96@dismail.de
Hi Ivan,

Applied. Thanks!

all best,

jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63649@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63649
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch