[PATCH] gnu: Add emacs-framemove.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal
F
F
Fabio Natali wrote on 8 May 2023 15:05
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
36ef72b8f78a52274eec6e300996ad4f387c2462.1683550987.git.me@fabionatali.com
Hi, this tiny patch is to add FrameMove, an Emacs package that allows to move
focus across windows and frames. IIUC, it can be particularly useful to EXWM
users. The package is currently hosted on EmacsWiki at

* gnu/packages/emacs-xyz.scm (emacs-framemove): New variable.

Signed-off-by: Fabio Natali <me@fabionatali.com>
---
gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 050e6377a3..720cefae18 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -128,6 +128,7 @@
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32435,6 +32436,25 @@ (define-public emacs-windower
@end itemize")
(license license:gpl3+)))
+(define-public emacs-framemove
+ (package
+ (name "emacs-framemove")
+ (version "0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://www.emacswiki.org/emacs/download/framemove.el")
+ (sha256
+ (base32
+ "15fhhywr0y2bd10rp60qkdq521l8ag1is4ahjnd84hl2w0qn7gnw"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/framemove.el")
+ (synopsis "Directional frame selection routines")
+ (description "@code{emacs-framemove} is similar to the @code{windmove.el}
+library, but for frames. It provides a simple set of keystrokes to move the
+input/focus between windows.")
+ (license license:gpl3)))
+
(define-public emacs-flycheck-cpplint
(package
(name "emacs-flycheck-cpplint")

base-commit: 0e09e8ab1554a7dffd60101cb4e631b348e43c9c
--
2.39.2
N
N
Nicolas Goaziou wrote on 8 May 2023 18:15
(name . Fabio Natali)(address . me@fabionatali.com)(address . 63370@debbugs.gnu.org)
878rdyyf2t.fsf@nicolasgoaziou.fr
Hello,

Fabio Natali <me@fabionatali.com> writes:
Toggle quote (3 lines)
>
> * gnu/packages/emacs-xyz.scm (emacs-framemove): New variable.

Thank you.

Toggle quote (2 lines)
> Signed-off-by: Fabio Natali <me@fabionatali.com>

In Guix, you don't sign your own commits.

Toggle quote (2 lines)
This is an issue, because the URI is not stable. Please use GitHub

Toggle quote (3 lines)
> + (description "@code{emacs-framemove} is similar to the
> @code{windmove.el}

Nicpicks: @code{emacs-framemove} -> Framemove and @code{windmove.el} -> Windmove.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
F
F
Fabio Natali wrote on 8 May 2023 21:07
[PATCH] gnu: Add emacs-framemove.
(address . 63370@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
e6ca8758a64355ffbba64bc64885de3a18267072.1683572606.git.me@fabionatali.com
Updated patch, as per Nicolas' suggestions (hopefully I got everything right).

* gnu/packages/emacs-xyz.scm (emacs-framemove): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 050e6377a3..45c47fc5f5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -128,6 +128,7 @@
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32435,6 +32436,30 @@ (define-public emacs-windower
@end itemize")
(license license:gpl3+)))
+(define-public emacs-framemove
+ ;; Use the latest commit, as there are no tagged releases.
+ (let ((commit "0faa8a4937f398e4971fc877b1c294100506b645")
+ (revision "0"))
+ (package
+ (name "emacs-framemove")
+ (version (git-version "0.10" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacsmirror/framemove")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z4xqx1cvllil03pdwsybsj5v9w7ggdrak1kxa856ki5mj1ja3gl"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/framemove.el")
+ (synopsis "Directional frame selection routines")
+ (description "Framemove is similar to the Windmove library, but for
+frames. It provides a simple set of keystrokes to move the input/focus between
+windows.")
+ (license license:gpl3))))
+
(define-public emacs-flycheck-cpplint
(package
(name "emacs-flycheck-cpplint")

base-commit: 0e09e8ab1554a7dffd60101cb4e631b348e43c9c
--
2.39.2
F
F
Fabio Natali wrote on 8 May 2023 21:15
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 63370@debbugs.gnu.org)
87r0rqeitj.fsf@reckondigital.com
Hey Nicolas, thanks for getting back to me so quickly. An updated
version of the patch should be arriving in a minute.

On 2023-05-08, 18:15 +0200, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
Toggle quote (2 lines)
> In Guix, you don't sign your own commits.

Ooops, sorry. Fixed in the new patch.

Toggle quote (5 lines)
>
> This is an issue, because the URI is not stable. Please use GitHub
> repository instead: <https://github.com/emacsmirror/framemove>.

Fixed.

Toggle quote (5 lines)
>> + (description "@code{emacs-framemove} is similar to the
>> @code{windmove.el}
>
> Nicpicks: @code{emacs-framemove} -> Framemove and @code{windmove.el} -> Windmove.

This is also fixed.

Thanks Nicolas, should you spot anything else, I'm very glad to keep
working on it.

Cheers, Fabio.
F
F
Fabio Natali wrote on 10 May 2023 10:00
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 63370@debbugs.gnu.org)
87fs84ty35.fsf@reckondigital.com
On 2023-05-08, 20:15 +0100, Fabio Natali <me@fabionatali.com> wrote:
Toggle quote (3 lines)
> Hey Nicolas, thanks for getting back to me so quickly. An updated
> version of the patch should be arriving in a minute.

(Just to clarify, the patch ended up arriving a bit earlier than my
above comment, it's here: https://issues.guix.gnu.org/63370#2.)
N
N
Nicolas Goaziou wrote on 11 May 2023 23:59
(name . Fabio Natali)(address . me@fabionatali.com)(address . 63370-done@debbugs.gnu.org)
87o7mq34y4.fsf@nicolasgoaziou.fr
Hello,

Fabio Natali <me@fabionatali.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-framemove): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?