guix package -u failure on pyopengl-accelerate-3.1.5

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Lars-Dominik Braun
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
Blocked by

Debbugs page

Andy Tai wrote 2 years ago
(address . bug-guix@gnu.org)
CAJsg1E_t7d57dGwOSGusvWKb=Ziuxwha-8b06=9vN-JOVHr6GQ@mail.gmail.com
doing guix package -u with the guix post merge of core-updates (thus
using the main branch,

gux package -u fails with

| 'build' phase2023-04-28 12:02:50,512 Error: cannot execute signal listener
2023-04-28 12:02:50,512 [Errno 2] No such file or directory: 'python3.9'
\ 'build' phasebuilder for
`/gnu/store/9clhgrmqzlvfawmshalg16imh15sjsmy-python-pyopengl-accelerate-3.1.5.drv'
failed with exit code 1
build of /gnu/store/9clhgrmqzlvfawmshalg16imh15sjsmy-python-pyopengl-accelerate-3.1.5.drv
failed
View build log at
'/var/log/guix/drvs/9c/lhgrmqzlvfawmshalg16imh15sjsmy-python-pyopengl-accelerate-3.1.5.drv.bz2'.

last part of this bug log:

In file included from
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from src/vbo.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26:
note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
src/vbo.c:13032:25: warning: ‘PyUnicode_AsUnicode’ is deprecated
[-Wdeprecated-declarations]
13032 | (PyUnicode_GET_SIZE(**argname) !=
PyUnicode_GET_SIZE(key)) ? 1 :
| ^
In file included from
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from src/vbo.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:580:45:
note: declared here
580 | Py_DEPRECATED(3.3) PyAPI_FUNC(Py_UNICODE *) PyUnicode_AsUnicode(
| ^~~~~~~~~~~~~~~~~~~
src/vbo.c:13032:25: warning: ‘_PyUnicode_get_wstr_length’ is
deprecated [-Wdeprecated-declarations]
13032 | (PyUnicode_GET_SIZE(**argname) !=
PyUnicode_GET_SIZE(key)) ? 1 :
| ^
In file included from
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from src/vbo.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26:
note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
error: command '/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/gcc'
failed with exit code 1
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("-c" "import
setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open',
open)(__file__);code=f.read().replace('\\r\\n',
'\\n');f.close();exec(compile(code, __file__, 'exec'))" "build")
exit-status: 1 term-signal: #f stop-signal: #f>
phase `build' failed after 10.4 seconds
command "python" "-c" "import setuptools,
tokenize;__file__='setup.py';f=getattr(tokenize, 'open',
open)(__file__);code=f.read().replace('\\r\\n',
'\\n');f.close();exec(compile(code, __file__, 'exec'))" "build" failed
with status 1
Andy Tai wrote 2 years ago
Re: bug#63156: Acknowledgement (guix package -u failure on pyopengl-accelerate-3.1.5)
(address . 63156@debbugs.gnu.org)
CAJsg1E8PDrafXi8VuHB=AnbmncN7FRBZEah7WV3NRhWbmDs20A@mail.gmail.com
These may be the key error lines:

gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall
-fno-semantic-interposition -fPIC
-I/tmp/guix-build-python-pyopengl-accelerate-3.1.5.drv-0/PyOpenGL-accelerate-3.1.5/..
-I/tmp/guix-build-python-pyopengl-accelerate-3.1.5.drv-0/PyOpenGL-accelerate-3.1.5/src
-I/tmp/guix-build-python-pyopengl-accelerate-3.1.5.drv-0/PyOpenGL-accelerate-3.1.5
-I/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10
-c src/vbo.c -o build/temp.linux-x86_64-cpython-310/src/vbo.o
src/vbo.c: In function ‘__pyx_tp_dealloc_17OpenGL_accelerate_3vbo_VBO’:
src/vbo.c:11131:5: error: lvalue required as increment operand
11131 | ++Py_REFCNT(o);
| ^~
src/vbo.c:11133:5: error: lvalue required as decrement operand
11133 | --Py_REFCNT(o);
| ^~
src/vbo.c: In function ‘__pyx_tp_dealloc_17OpenGL_accelerate_3vbo_VBOOffset’:
src/vbo.c:11619:5: error: lvalue required as increment operand
11619 | ++Py_REFCNT(o);
| ^~
src/vbo.c:11621:5: error: lvalue required as decrement operand
11621 | --Py_REFCNT(o);
| ^~
Andy Tai wrote 2 years ago
(address . control@debbugs.gnu.org)
CAJsg1E-3TDR+_Rq695mB3Vv4Sw+6QL=CFgyP9jqHEb3L=4QRaw@mail.gmail.com
block 63156 by 63168
Lars-Dominik Braun wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 63156-done@debbugs.gnu.org)
ZFydKxhMr6B2lSvl@noor
Hi,

I discovered this issue independently and fixed it in commit 3d05d549184d5399d2949535cf5cad8b92b263dd.

Cheers,
Lars
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63156@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63156
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help