[PATCH] gnu: stalonetray: Update to 0.8.5.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 26 Apr 2023 02:11
(address . guix-patches@gnu.org)
20230426001152.71300-1-kiasoc5@disroot.org
The last update for stalonetray.scm was in 2016, and it only contains stalonetray. Could it be moved to xdisorg.scm?

* (stalonetray): Update to 0.8.5.
[source]: Switch to git reference from GitHub.
[arguments](phases): add phase to fix docbook root.
[inputs]: Add libxpm.
[native-inputs]: Add autoconf, autoconf, automake, libxslt, docbook-xsl.
[homepage]: Update.
---
gnu/packages/stalonetray.scm | 38 +++++++++++++++++++++++++++---------
1 file changed, 29 insertions(+), 9 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/stalonetray.scm b/gnu/packages/stalonetray.scm
index 65732313fe..37b5cdaae3 100644
--- a/gnu/packages/stalonetray.scm
+++ b/gnu/packages/stalonetray.scm
@@ -18,28 +18,48 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages stalonetray)
+ #:use-module (guix gexp)
#:use-module (guix packages)
- #:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages docbook)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
(define-public stalonetray
(package
(name "stalonetray")
- (version "0.8.3")
+ (version "0.8.5")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
(uri
- (string-append "mirror://sourceforge/stalonetray/stalonetray/stalonetray-"
- version "/stalonetray-" version ".tar.bz2"))
+ (git-reference
+ (url "https://github.com/kolbusa/stalonetray")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0k7xnpdb6dvx25d67v0crlr32cdnzykdsi9j889njiididc8lm1n"))))
- (inputs (list libx11))
+ (base32
+ "074wy1xppfycillbxq6fwrq87ik9glc95083df5vgm20mhzni7pz"))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-docbook-root
+ (lambda _
+ (substitute* "configure.ac"
+ (("AC_SUBST\\(DOCBOOK_ROOT\\)" all)
+ (string-append "DOCBOOK_ROOT="
+ #$(this-package-native-input "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ #$(package-version (this-package-native-input "docbook-xsl"))
+ "; " all))))))))
+ (inputs (list libx11 libxpm))
+ (native-inputs (list autoconf automake libxslt docbook-xsl))
(build-system gnu-build-system)
- (home-page "https://stalonetray.sourceforge.net")
+ (home-page "https://kolbusa.github.io/stalonetray")
(synopsis "Standalone freedesktop.org and KDE systray implementation")
(description
"Stalonetray is a stand-alone freedesktop.org and KDE system

base-commit: 8093c6ba21c51efe901ba98ce698c545bf13dcd0
--
2.40.0
E
E
Efraim Flashner wrote on 1 May 2023 16:15
(name . kiasoc5)(address . kiasoc5@disroot.org)
ZE/Jfxz2AnBWavh8@3900XT
On Tue, Apr 25, 2023 at 08:11:52PM -0400, kiasoc5 wrote:
Toggle quote (2 lines)
> The last update for stalonetray.scm was in 2016, and it only contains stalonetray. Could it be moved to xdisorg.scm?

That's fine with me.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmRPyXwACgkQQarn3Mo9
g1Gh8A/6A9u1mQbzyEkN2gq+MJxeZ+mmbE0t/8l/evK0ELrlupqhjXDS7H9AMZnQ
O6r+MwlITfvD/oYuhj0I33iZgS3k0kFvnswQ+lh8u7sEZu/35qUSTa+h/ObI9xFH
WCYKwLppwEtc230XH5Z9Bt7IzWFoK8JFN1+i7Sj+evnXtsrxwiD08vBXmOH1icMr
H9FXr22eSFrOuCHTxCfqzkPnbQn/wvTzP+RV/oSKCNCX5IRAiP3Q/BmbUWUejhX9
ZvdMk1B/sH3tS6yeoiD8PoEKZ8x/q0ed40jr3Jxso7KOwlpAa9sGtNsOq02yqT4w
bupJRNY1VaCgQscp+lBwtzG9c6XoGKu9Nn3D+q914EtSSBbzaTNUP2Yl9KU6LVQ/
gvJiQIVHuPXW9v9B63WhmoxlvPXRN060X1CBQmCA4ypQG9TP743v4FN85uZ95NKy
YLXm7a58tLIwV8mASAAMf0xqdetmmzZVupXQzeAwnVVn68M//XvDQMzrycKUECWJ
/Vn1+ln4vkU4QoFaT4g5cdv2P1K2wZ/7WLfW5N1+S/f9TRAVZXhRRrKlaEa/OHSh
zQlAoeoeRLftWo7N+CWmH/09E0tJx28pG0dP0tD1fTB6URw0QprQhYLtwhNdSvjt
H9+Z5W2kUkul3fPSk0nwG7m42uEbSJETIvTAVWcW2LUrDO9vNZU=
=zq94
-----END PGP SIGNATURE-----


K
K
kiasoc5 wrote on 6 Jun 2023 01:18
[PATCH] * gnu: Move stalonetray to (gnu packages xdisorg).
(address . 63080@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
c9d79f9e004ee2ef8dd7d676a8a5d1615b2907ab.1686007100.git.kiasoc5@disroot.org

* gnu/packages/stalonetray.scm (stalonetray): Move from here…
* gnu/packages/xdisorg.scm (stalonetray): …to here.
* gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
---
gnu/local.mk | 1 -
gnu/packages/stalonetray.scm | 69 ------------------------------------
gnu/packages/xdisorg.scm | 41 +++++++++++++++++++++
3 files changed, 41 insertions(+), 70 deletions(-)
delete mode 100644 gnu/packages/stalonetray.scm

Toggle diff (151 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index f9afb433e6..69b7d511a0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -586,7 +586,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/squirrel.scm \
%D%/packages/ssh.scm \
%D%/packages/sssd.scm \
- %D%/packages/stalonetray.scm \
%D%/packages/statistics.scm \
%D%/packages/stb.scm \
%D%/packages/stenography.scm \
diff --git a/gnu/packages/stalonetray.scm b/gnu/packages/stalonetray.scm
deleted file mode 100644
index a9d842a99e..0000000000
--- a/gnu/packages/stalonetray.scm
+++ /dev/null
@@ -1,69 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages stalonetray)
- #:use-module (guix gexp)
- #:use-module (guix packages)
- #:use-module (guix git-download)
- #:use-module (guix build-system gnu)
- #:use-module ((guix licenses) #:select (gpl2+))
- #:use-module (gnu packages autotools)
- #:use-module (gnu packages docbook)
- #:use-module (gnu packages xml)
- #:use-module (gnu packages xorg))
-
-(define-public stalonetray
- (package
- (name "stalonetray")
- (version "0.8.5")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/kolbusa/stalonetray")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "074wy1xppfycillbxq6fwrq87ik9glc95083df5vgm20mhzni7pz"))))
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'fix-docbook-root
- (lambda _
- (substitute* "configure.ac"
- (("AC_SUBST\\(DOCBOOK_ROOT\\)" all)
- (string-append "DOCBOOK_ROOT="
- #$(this-package-native-input "docbook-xsl")
- "/xml/xsl/docbook-xsl-"
- #$(package-version (this-package-native-input "docbook-xsl"))
- "; " all))))))))
- (inputs (list libx11 libxpm))
- (native-inputs (list autoconf automake docbook-xsl libxslt))
- (build-system gnu-build-system)
- (home-page "https://kolbusa.github.io/stalonetray")
- (synopsis "Standalone freedesktop.org and KDE systray implementation")
- (description
- "Stalonetray is a stand-alone freedesktop.org and KDE system
-tray (notification area) for X Window System/X11 (e.g. X.Org or XFree86). It
-has full XEMBED support and minimal dependencies: an X11 lib only. Stalonetray
-works with virtually any EWMH-compliant window manager.")
- (license gpl2+)))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index b8671d1cf6..615ac32aa0 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -102,6 +102,7 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
#:use-module (gnu packages datastructures)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
@@ -2002,6 +2003,46 @@ (define-public tint2
actions, a built-in clock, a battery monitor and a system tray.")
(license license:gpl2)))
+(define-public stalonetray
+ (package
+ (name "stalonetray")
+ (version "0.8.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/kolbusa/stalonetray")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "074wy1xppfycillbxq6fwrq87ik9glc95083df5vgm20mhzni7pz"))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-docbook-root
+ (lambda _
+ (substitute* "configure.ac"
+ (("AC_SUBST\\(DOCBOOK_ROOT\\)" all)
+ (string-append "DOCBOOK_ROOT="
+ #$(this-package-native-input "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ #$(package-version (this-package-native-input "docbook-xsl"))
+ "; " all))))))))
+ (inputs (list libx11 libxpm))
+ (native-inputs (list autoconf automake docbook-xsl libxslt))
+ (build-system gnu-build-system)
+ (home-page "https://kolbusa.github.io/stalonetray")
+ (synopsis "Standalone freedesktop.org and KDE systray implementation")
+ (description
+ "Stalonetray is a stand-alone freedesktop.org and KDE system
+tray (notification area) for X Window System/X11 (e.g. X.Org or XFree86). It
+has full XEMBED support and minimal dependencies: an X11 lib only. Stalonetray
+works with virtually any EWMH-compliant window manager.")
+ (license license:gpl2+)))
+
(define-public tofi
(package
(name "tofi")

base-commit: f598f5b870462afbb5a5770c1b16071bca63fc52
prerequisite-patch-id: 45ae29dd8297f83231b66d1fc3f357b903f7a080
--
2.40.1
L
L
Ludovic Courtès wrote on 15 Aug 2023 23:23
Re: bug#63080: [PATCH] gnu: stalonetray: Update to 0.8.5.
(name . kiasoc5)(address . kiasoc5@disroot.org)
87wmxw6lv3.fsf@gnu.org
Hi,

kiasoc5 <kiasoc5@disroot.org> skribis:

Toggle quote (9 lines)
> The last update for stalonetray.scm was in 2016, and it only contains stalonetray. Could it be moved to xdisorg.scm?
>
> * (stalonetray): Update to 0.8.5.
> [source]: Switch to git reference from GitHub.
> [arguments](phases): add phase to fix docbook root.
> [inputs]: Add libxpm.
> [native-inputs]: Add autoconf, autoconf, automake, libxslt, docbook-xsl.
> [homepage]: Update.

[...]

Toggle quote (6 lines)
>
> * gnu/packages/stalonetray.scm (stalonetray): Move from here…
> * gnu/packages/xdisorg.scm (stalonetray): …to here.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.

Finally applied, thanks!

Ludo’.
Closed
?