[PATCH] gnu: python-lazr-restfulclient: Add missing dependency

  • Done
  • quality assurance status badge
Details
3 participants
  • Ivan Vilata i Balaguer
  • jgart
  • Tom Willemse
Owner
unassigned
Submitted by
Tom Willemse
Severity
normal
T
T
Tom Willemse wrote on 18 Apr 2023 10:12
(address . guix-patches@gnu.org)(name . Tom Willemse)(address . tom@ryuslash.org)
20230418081223.351951-1-tom@ryuslash.org
* gnu/packages/python-web.scm (python-lazr-restfulclient): Add missing
dependency: python-six
---
Trying to rebuild my guix home config I ran into the following error:

starting phase `sanity-check'
validating 'lazr.restfulclient' /gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages
...checking requirements: ERROR: lazr.restfulclient==0.14.4 DistributionNotFound(Requirement.parse('six'), {'lazr.restfulclient'})
error: in phase 'sanity-check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages") exit-status: 1 term-signal: #f stop-signal: #f>
phase `sanity-check' failed after 0.2 seconds
command "python" "/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages" failed with status 1

From what I understand from the text it indicates that the requirements.txt of
the lazr restfulclient project specifies a dependency on six, but that package
hasn't been installed in the environment. Adding this dependency fixes the issue
for me.

gnu/packages/python-web.scm | 22 ++++++++++------------
1 file changed, 10 insertions(+), 12 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d84b5efdf9..051346c66a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -127,21 +127,19 @@ (define-public python-lazr-restfulclient
(package
(name "python-lazr-restfulclient")
(version "0.14.4")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "lazr.restfulclient" version))
- (sha256
- (base32 "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "lazr.restfulclient" version))
+ (sha256
+ (base32
+ "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
(build-system python-build-system)
;; Disable the test suite to avoid the lazr.authentication requirement,
;; which requires the ancient 'oauth', a Python 2 only library.
- (arguments (list #:tests? #f))
- (propagated-inputs
- (list python-distro
- python-httplib2
- python-oauthlib
- python-wadllib))
+ (arguments
+ (list #:tests? #f))
+ (propagated-inputs (list python-distro python-httplib2 python-oauthlib
+ python-wadllib python-six))
(home-page "https://launchpad.net/lazr.restfulclient")
(synopsis "Web client Python library extending wadlib")
(description "This package provides a programmable client library that

base-commit: 79b2221ce43b8026eae6461a9269466cae946cac
--
2.40.0
T
T
Tom Willemse wrote on 16 May 2023 22:31
(address . guix-patches@gnu.org)
87ilcsf27h.fsf@ryuslash.org
Hello!

Tom Willemse <tom@ryuslash.org> writes:

Toggle quote (62 lines)
> * gnu/packages/python-web.scm (python-lazr-restfulclient): Add missing
> dependency: python-six
> ---
> Trying to rebuild my guix home config I ran into the following error:
>
> starting phase `sanity-check'
> validating 'lazr.restfulclient' /gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages
> ...checking requirements: ERROR: lazr.restfulclient==0.14.4 DistributionNotFound(Requirement.parse('six'), {'lazr.restfulclient'})
> error: in phase 'sanity-check': uncaught exception:
> %exception #<&invoke-error program: "python" arguments: ("/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages") exit-status: 1 term-signal: #f stop-signal: #f>
> phase `sanity-check' failed after 0.2 seconds
> command "python" "/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages" failed with status 1
>
> From what I understand from the text it indicates that the requirements.txt of
> the lazr restfulclient project specifies a dependency on six, but that package
> hasn't been installed in the environment. Adding this dependency fixes the issue
> for me.
>
> gnu/packages/python-web.scm | 22 ++++++++++------------
> 1 file changed, 10 insertions(+), 12 deletions(-)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index d84b5efdf9..051346c66a 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -127,21 +127,19 @@ (define-public python-lazr-restfulclient
> (package
> (name "python-lazr-restfulclient")
> (version "0.14.4")
> - (source
> - (origin
> - (method url-fetch)
> - (uri (pypi-uri "lazr.restfulclient" version))
> - (sha256
> - (base32 "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "lazr.restfulclient" version))
> + (sha256
> + (base32
> + "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
> (build-system python-build-system)
> ;; Disable the test suite to avoid the lazr.authentication requirement,
> ;; which requires the ancient 'oauth', a Python 2 only library.
> - (arguments (list #:tests? #f))
> - (propagated-inputs
> - (list python-distro
> - python-httplib2
> - python-oauthlib
> - python-wadllib))
> + (arguments
> + (list #:tests? #f))
> + (propagated-inputs (list python-distro python-httplib2 python-oauthlib
> + python-wadllib python-six))
> (home-page "https://launchpad.net/lazr.restfulclient")
> (synopsis "Web client Python library extending wadlib")
> (description "This package provides a programmable client library that
>
> base-commit: 79b2221ce43b8026eae6461a9269466cae946cac
> --
> 2.40.0

Apologies if this is the wrong way to go about it to add some people to
the CC, but it was pointed out to me that I should have included the
area owners in the first place.

If you would be so kind as to have a look, this issue is preventing me
from upgrading my guix installation because one of the packages I
install uses Bazaar to get the source, which is actually aliased to
Breezy, which requires the package in this patch.
I
I
Ivan Vilata i Balaguer wrote on 22 May 2023 20:38
[PATCH v2] gnu: python-lazr-restfulclient: Add missing dependencies.
(address . 62922@debbugs.gnu.org)
a070a7aa7e2cafd0a4d63b4f9335ed296ae76b39.1684780475.git.ivan@selidor.net

* gnu/packages/python-web.scm (python-lazr-restfulclient): Add missing
dependencies.
[propagated-inputs] Add python-pyparsing and python-six.
---
The original patch from Tom Willemse still issued a DistributionNotFound error
on pyparsing. This alternative version adds both dependencies (without extra
reformatting). Thanks Tom for the initiative!

gnu/packages/python-web.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b6ad489626..262309032f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -143,6 +144,8 @@ (define-public python-lazr-restfulclient
(list python-distro
python-httplib2
python-oauthlib
+ python-pyparsing
+ python-six
python-wadllib))
(home-page "https://launchpad.net/lazr.restfulclient")
(synopsis "Web client Python library extending wadlib")

base-commit: dff1689bb37e5303868584d3f1d7a33cbcb7f51e
--
2.39.2


--
Ivan Vilata i Balaguer -- https://elvil.net/
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEHpvwBPZcchIQr6TuPezBBfXdI4IFAmRrto4ACgkQPezBBfXd
I4Kcig/9EGWIsOC9OtfNnaFLLEd5Rb0X6QKCr/nk3XWjpsM0fAdyIejQkrWfrIRv
zWe0W6wMLw1BanbOen3s8/9oN3DD0sb7uvF6FuLFtcWPOpUit9HIaI89Q9nXiXcR
/FhcGAK4u6VxJenUSsKf5hFR0quAQ3jPe9PJrv/tVN8wJhGBW9O/1ES/wsNGBKDR
+VHRaUdfuizofSIncBuD4wJjihsGJ2bnMJn0cC7bq/9gCXsDaGJv/L7sSRD2GQlN
SuC7QSv/WBrPIZYxp7JFdYLtNihvirdpBUkkOwF6AYpTF92RDlsWm7HTFTeMBhsP
hXFdVT89Vd9ZrDfX521Di0IOFtXLrUViTaTcbDGKblJSn9C2GSdx+exa+qhzIv05
G0Ll9D+f6zLpm/oHGVXR8aRbC73wptDIQ1UsGsIxks/4zPbH6sYyJJKe8PzB3P52
ruQn1VxH91NxcHE9218hiIelQUhZ5kXGhIaDj5MDYm8eya+eFmbVgken/ETBm2U8
Ttm3Io5DFfhZaCFQfzRF1DJmeF8NJiiMvMgz8YqaXMWE1bCh52P2PVfnhr7b46Jk
LJCSwhiWjNc0JUrZuwSVG8L3aNkUOoZpMa+GUujCw9lT2VKN3J7X3GprA/3TYfU7
h9nDyz/fcr+nNvjrAyl/Naxask/vjyA/Q4a2W9VwQ+EcqElCqjc=
=WpN9
-----END PGP SIGNATURE-----


I
I
Ivan Vilata i Balaguer wrote on 23 May 2023 09:27
(name . Ivan Vilata i Balaguer)(address . ivan@selidor.net)(address . 62922@debbugs.gnu.org)
ZGxq3e22XbUlfeMx@sax
An equivalent patch was commited by jgart:
87d75d915152b150c3800d7011b04b4d11cd339c.

This issue can be closed now, thanks!


Ivan Vilata i Balaguer (2023-05-22 20:38:17 +0200) wrote:

Toggle quote (39 lines)
>
> * gnu/packages/python-web.scm (python-lazr-restfulclient): Add missing
> dependencies.
> [propagated-inputs] Add python-pyparsing and python-six.
> ---
> The original patch from Tom Willemse still issued a DistributionNotFound error
> on pyparsing. This alternative version adds both dependencies (without extra
> reformatting). Thanks Tom for the initiative!
>
> gnu/packages/python-web.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index b6ad489626..262309032f 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -59,6 +59,7 @@
> ;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
> ;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
> ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
> +;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -143,6 +144,8 @@ (define-public python-lazr-restfulclient
> (list python-distro
> python-httplib2
> python-oauthlib
> + python-pyparsing
> + python-six
> python-wadllib))
> (home-page "https://launchpad.net/lazr.restfulclient")
> (synopsis "Web client Python library extending wadlib")
>
> base-commit: dff1689bb37e5303868584d3f1d7a33cbcb7f51e
> --
> 2.39.2

--
Ivan Vilata i Balaguer -- https://elvil.net/
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEHpvwBPZcchIQr6TuPezBBfXdI4IFAmRsat0ACgkQPezBBfXd
I4JWBhAAiG/rIZ3ceL1xj5dKldBF0pXvgzRE7ca6AZ3cHcFwYMC1sP6or6o1R1v/
9/w1E6twFY0Ee0VDifyJouvkFdjtO0hM40opZKd3lWZk96LQLQopRvtLL9FTgefl
+i+WfOQqY8oWYjSomKBcqPmCmBbOuIW7pDd3CSuKjCHZ5RvhGzao2exOAQnzmrbB
BZ32+r25GIVlRcgQXYsCkO7ZCYsoU5yu2hbhCVkIgd+TjHN+OXJ286L7nqFUt2Fy
1ljLMfpejwIW1yin/B8wNnrgJ50PJcfW9g2/mHZ1r4BypMzay72TGZ66nI+vmHEA
1q6j1ko+9SNOp0kn4faCYxucwIAqt+DjiZ7arIJclxvyQExUnNSb0o9XUkqHr6pt
WDovNjs/DwjNtxOuSVc6x1QES/iP0fhVKL2YrWe80c75CEhDFuOMu/xVq63E7hte
hd1g79vqYUpIl2zhPN5zzbioYc+hB/k4OswYVVxuzfN2XudkGLYclFcPnZf8DN6D
hrytekltflDE32TbW1DYW8BdBRdfYZXFeqkToVGk/tPqQq9qz6CxtrQRyDXPAWZl
gy6aaL8mWOnUfG1la51GbevMqUVgSfmYqzGSUQmcl38ATqrtmMMs8MOi5MeM33XC
VDSE4/8tP5wLim0P4hyaUkuRc0uy6vEOhyLjtQXWFkcdxQYSux4=
=VoOq
-----END PGP SIGNATURE-----


J
(address . 62922-done@debbugs.gnu.org)
6131e4923ed6150df591df6c6acce729f6da8d8f@dismail.de

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62922@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62922
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch