On Tue, 11 Apr 2023, Stephen Paul Weber wrote:
Works for me (guix c1262edba9118af6507dc47ce6ad61ffdec02384):
```
$ guix import pypi -r gruut
Starting download of /tmp/guix-file.glzbrJ
….4.tar.gz 72KiB 1.1MiB/s 00:00 ???????????????????? 100.0%
Starting download of /tmp/guix-file.IZKz4B
….13.0.tar.gz 99KiB 2.0MiB/s 00:00 ???????????????????? 100.0%
Starting download of /tmp/guix-file.EVbIBD
…-2.0.0.tar.gz 14.5MiB 4.4MiB/s 00:03 ???????????????????? 100.0%
guix import: warning: Cannot guess requirements from source archive: no requires.txt file found.
Starting download of /tmp/guix-file.vlMVNT
….1.0.tar.gz 8KiB 5.6MiB/s 00:00 ???????????????????? 100.0%
Starting download of /tmp/guix-file.jDheDU
…py3-none-any.whl 8KiB 3.0MiB/s 00:00 ???????????????????? 100.0%
guix import: warning: Failed to extract file: jsonlines-3.1.0.dist-info/METADATA from wheel.
Starting download of /tmp/guix-file.EPOrXf
….5.12.tar.gz 280KiB 3.3MiB/s 00:00 ???????????????????? 100.0%
Starting download of /tmp/guix-file.tOdRgu
…-py3-none-any.whl 122KiB 2.1MiB/s 00:00 ???????????????????? 100.0%
guix import: warning: Failed to extract file: num2words-0.5.12.dist-info/METADATA from wheel.
Starting download of /tmp/guix-file.sgNV9f
…e-0.9.9.tar.gz 430KiB 3.0MiB/s 00:00 ???????????????????? 100.0%
Starting download of /tmp/guix-file.ihTx8n
…cp310-macosx_10_9_x86_64.whl 180KiB 2.9MiB/s 00:00 ???????????????????? 100.0%
guix import: warning: Failed to extract file: python_crfsuite-0.9.9.dist-info/METADATA from wheel.
guix import: warning: Cannot guess requirements from source archive: no requires.txt file found.
(define-public python-crfsuite
(package
(name "python-crfsuite")
(version "0.9.9")
(source (origin
(method url-fetch)
(uri (pypi-uri "python-crfsuite" version))
(sha256
(base32
"0vd7ndi9q4hc336bbgg3ccln4l7xskxzrdw6z5b6fijmd4fjd9na"))))
(build-system python-build-system)
(synopsis "Python binding for CRFsuite")
(description "Python binding for CRFsuite")
(license license:expat)))
(define-public python-num2words
(package
(name "python-num2words")
(version "0.5.12")
(source (origin
(method url-fetch)
(uri (pypi-uri "num2words" version))
(sha256
(base32
"120938q7h6syn16ybf0pmcxz0fqbm4f2plyr3lxal184107hnz3y"))))
(build-system python-build-system)
(propagated-inputs (list python-docopt))
(synopsis "Modules to convert numbers to words. Easily extensible.")
(description "Modules to convert numbers to words. Easily extensible.")
(license #f)))
(define-public python-jsonlines
(package
(name "python-jsonlines")
(version "3.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "jsonlines" version))
(sha256
(base32
"0zy3llabmxsq559s73x1c84xlch3dcz9wql1xfq1by4nim4cny95"))))
(build-system python-build-system)
(propagated-inputs (list python-attrs))
(synopsis "Library with helpers for the jsonlines file format")
(description "Library with helpers for the jsonlines file format")
(license license:bsd-3)))
(define-public python-gruut-lang-en
(package
(name "python-gruut-lang-en")
(version "2.0.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "gruut_lang_en" version))
(sha256
(base32
"0lhy2z6y98djmg229jzd3ylay3jwg1s3js20l1zais7bvnvg63w9"))))
(build-system python-build-system)
(synopsis "English language files for gruut tokenizer/phonemizer")
(description "English language files for gruut tokenizer/phonemizer")
(license #f)))
(define-public python-gruut-ipa
(package
(name "python-gruut-ipa")
(version "0.13.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "gruut-ipa" version))
(sha256
(base32
"0vn6pvqm3aqijynnnbyc0wv165s3ylvfbm6k2jmikqa6kywnwxvi"))))
(build-system python-build-system)
(synopsis
"Library for manipulating pronunciations using the International Phonetic Alphabet (IPA)")
(description
"Library for manipulating pronunciations using the International Phonetic
Alphabet (IPA)")
(license #f)))
(define-public python-gruut
(package
(name "python-gruut")
(version "2.3.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "gruut" version))
(sha256
(base32
"1mqvvpaxwp42zink9h1nj0zjr9rs589rhghfrdhspxp4d3xdc43p"))))
(build-system python-build-system)
(propagated-inputs (list python-babel
python-crfsuite
python-dateparser
python-gruut-ipa
python-gruut-lang-en
python-jsonlines
python-networkx
python-num2words
python-numpy))
(synopsis
"A tokenizer, text cleaner, and phonemizer for many human languages.")
(description
"This package provides a tokenizer, text cleaner, and phonemizer for many human
languages.")
(license #f)))
```