Network is unreachable only for recursive pypi import
(address . bug-guix@gnu.org)
The following package import fails when importing the dependency, but
succeeds when directly importing that dependency. I can also manually
download the tar without issue.
Toggle snippet (8 lines)
$ guix describe
Generation 38 Mar 21 2023 13:38:52 (current)
guix 38b64d4
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 38b64d47ed3dfaeb63b859e7a8834e477ffed3a1
Toggle snippet (46 lines)
$ guix import pypi -r cdlib
Starting download of /tmp/guix-file.oeSQon
From https://files.pythonhosted.org/packages/eb/6d/97167dce848b65023a272e2ffd04b2e462612efdb3538d16e2b8b2221a15/cdlib-0.2.6.tar.gz...
….6.tar.gz 191KiB 41.0MiB/s 00:00 ???????????????????? 100.0%
Starting download of /tmp/guix-file.H0dsHq
From https://files.pythonhosted.org/packages/56/37/80bdc21fbb88d87bca352cdf1ea0b9e2492737dd5775f32a04ea242f842e/cdlib-0.2.6-py3-none-any.whl...
…3-none-any.whl 223KiB 74.0MiB/s 00:00 ???????????????????? 100.0%
Starting download of /tmp/guix-file.xReGb4
From https://files.pythonhosted.org/packages/49/01/21337857631a97ab551bb2e3b5691ed6b1b9586011aa6a5355b9694a37fa/demon-2.0.6.tar.gz...
In procedure connect: Network is unreachable
Starting download of /tmp/guix-file.xReGb4
From https://web.archive.org/web/20230321140958/https://files.pythonhosted.org/packages/49/01/21337857631a97ab551bb2e3b5691ed6b1b9586011aa6a5355b9694a37fa/demon-2.0.6.tar.gz...
In procedure connect*: Connection timed out
Trying to use Disarchive to assemble /tmp/guix-file.xReGb4...
could not find its Disarchive specification
failed to download "/tmp/guix-file.xReGb4" from
"https://files.pythonhosted.org/packages/49/01/21337857631a97ab551bb2e3b5691ed6b1b9586011aa6a5355b9694a37fa/demon-2.0.6.tar.gz"
Backtrace:
10 (primitive-load "/home/ec2-user/.config/guix/current/bi…")
In guix/ui.scm:
2300:7 9 (run-guix . _)
2263:10 8 (run-guix-command _ . _)
In guix/scripts/import.scm:
89:11 7 (guix-import . _)
In ice-9/boot-9.scm:
1752:10 6 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/import/pypi.scm:
97:21 5 (_)
In guix/import/utils.scm:
638:3 4 (recursive-import _ #:repo->guix-package _ #:guix-name . #)
600:31 3 (topological-sort _ #<procedure 7faf595b7270 at guix/i…> …)
In srfi/srfi-1.scm:
586:17 2 (map1 (("demon" #f) ("nf1" #f) ("eva-lcd" #f) ("b…" …) …))
In guix/import/utils.scm:
630:33 1 (lookup-node "demon" #f)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Wrong number of values returned to continuation (expected 2)
Toggle snippet (25 lines)
$ guix import pypi demon
Starting download of /tmp/guix-file.MOR39A
From https://files.pythonhosted.org/packages/49/01/21337857631a97ab551bb2e3b5691ed6b1b9586011aa6a5355b9694a37fa/demon-2.0.6.tar.gz...
….6.tar.gz 7KiB 17.3MiB/s 00:00 ???????????????????? 100.0%
Starting download of /tmp/guix-file.RuwPtL
From https://files.pythonhosted.org/packages/96/85/5f9146e3f8d7324d8741cd3bea9b99926d5ee75571b9610c661b1bbd06f5/demon-2.0.6-py3-none-any.whl...
…3-none-any.whl 7KiB 17.6MiB/s 00:00 ???????????????????? 100.0%
(package
(name "python-demon")
(version "2.0.6")
(source (origin
(method url-fetch)
(uri (pypi-uri "demon" version))
(sha256
(base32
"0nd370yjfb3jirmxd0wa03c75dl7jac4xfsq1rvp5483mxddirb0"))))
(build-system python-build-system)
(propagated-inputs (list python-networkx python-tqdm))
(home-page "https://github.com/GiulioRossetti/DEMON")
(synopsis "Community Discovery algorithm")
(description "Community Discovery algorithm")
(license license:bsd-2))