[PATCH core-updates] gnu: autogen: Fix build on i686.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Felix Lechner
  • Kaelyn Takata
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal
K
K
Kaelyn Takata wrote on 10 Apr 2023 20:33
[PATCH] gnu: autogen: Fix build on i686.
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
bdef0240f232f5612ad84433a11c7a4ad0a31bda.1681151588.git.kaelyn.alexi@protonmail.com
* gnu/packages/autogen.scm (autogen): Fix build on i686.
---
gnu/packages/autogen.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index 9751e11a64..f9575b0dc9 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,10 +44,15 @@ (define-public autogen
(base32 "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq"))
(modules '((guix build utils)))
(snippet
- ;; Address '-Werror=format-overflow' error.
- '(substitute* "getdefs/getdefs.c"
- (("def_bf\\[[[:space:]]*MAXNAMELEN[[:space:]]*\\]")
- "def_bf[MAXNAMELEN + 10]")))))
+ '(begin
+ ;; Address '-Werror=format-overflow' error.
+ (substitute* "getdefs/getdefs.c"
+ (("def_bf\\[[[:space:]]*MAXNAMELEN[[:space:]]*\\]")
+ "def_bf[MAXNAMELEN + 10]"))
+ ;; Address '-Werror=format-truncation' error on i686.
+ (substitute* "autoopts/usage.c"
+ (("vfmt\\[sizeof\\(vfmtfmt\\)\\]")
+ "vfmt[sizeof(vfmtfmt) + 6]"))))))
(build-system gnu-build-system)
(native-inputs (list pkg-config which))
(inputs (list guile-3.0 perl)) ; for doc generator mdoc

base-commit: ae5d3525348de562b84fc9faccf09fd6e06ab3df
--
2.39.2
K
K
Kaelyn wrote on 10 Apr 2023 20:57
[PATCH core-updates] gnu: autogen: Fix build on i686.
(name . 62758@debbugs.gnu.org)(address . 62758@debbugs.gnu.org)
C5A6U3b9qvGbUilAST1-Tlzg_4eP2X4K9pfMuDf8-ymMUbZEym-SSOta3zfgh3bjR-1Rzwo2-cKkdaYqHlgZXwB9uAJj8UTU2MHu1r42J_I=@protonmail.com
Sorry, I messed up a little bit on the subject line of this patch. It is for core-updates, but forgot to update the subject prefix.
F
F
Felix Lechner wrote on 10 Apr 2023 21:23
fix bug title
(address . control@debbugs.gnu.org)
CAFHYt54TvCyUJvQHrBU=JBa7yps=3q+LbczT0xRbE-mYKf9xtg@mail.gmail.com
retitle 62758 [PATCH core-updates] gnu: autogen: Fix build on i686.
thanks!
A
A
Andreas Enge wrote on 11 Apr 2023 13:58
Re: Fix for librsvg 2.40 on core-updates
(name . Kaelyn)(address . kaelyn.alexi@protonmail.com)
ZDVLZY1TJbqBjh2L@jurong
Am Mon, Apr 10, 2023 at 07:00:16PM +0000 schrieb Kaelyn:
Toggle quote (2 lines)
> I just mailed https://issues.guix.gnu.org/62758to add a snippet to fix the build error. I used a similar approach as the existing snippet for fixing a format overflow error. (I also forgot to set the subject prefix to "PATCH core-updates" on the git send-mail command line.).

Thanks a lot, this looks like a good fix. I have just pushed it.

Andreas
Closed
?