(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
* gnu/packages/gnome.scm (librsvg-2.40): Fix test failure with Pango 1.50.
---
gnu/packages/gnome.scm | 6 ++++++
1 file changed, 6 insertions(+)
Toggle diff (19 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e81882b181..fe5860e93f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3725,6 +3725,12 @@ (define-public librsvg-2.40
(("gdk_pixbuf_cache_file = .*$")
"gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
#t))
+ (add-before 'check 'fix-test-with-pango-1.50
+ (lambda _
+ ;; Changes between pango 1.48 and 1.50 caused the text to be one
+ ;; pixel lower in the output image compared to the reference.
+ (substitute* "tests/fixtures/reftests/bugs/587721-text-transform.svg"
+ (("660\\.9") "659.9"))))
(add-before 'check 'remove-failing-tests
(lambda _
(with-directory-excursion "tests/fixtures/reftests"
base-commit: cebcf3533ab83233121434254a6ae7b8c35cfa1f
--
2.39.2