[PATCH core-updates] gnu: librsvg-2.40: Fix test failure with Pango 1.50.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Kaelyn Takata
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal
K
K
Kaelyn Takata wrote on 3 Apr 2023 18:37
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
096346acd405f2df58ecf32f3b4fb687790f9a03.1680539830.git.kaelyn.alexi@protonmail.com
* gnu/packages/gnome.scm (librsvg-2.40): Fix test failure with Pango 1.50.
---
gnu/packages/gnome.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e81882b181..fe5860e93f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3725,6 +3725,12 @@ (define-public librsvg-2.40
(("gdk_pixbuf_cache_file = .*$")
"gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
#t))
+ (add-before 'check 'fix-test-with-pango-1.50
+ (lambda _
+ ;; Changes between pango 1.48 and 1.50 caused the text to be one
+ ;; pixel lower in the output image compared to the reference.
+ (substitute* "tests/fixtures/reftests/bugs/587721-text-transform.svg"
+ (("660\\.9") "659.9"))))
(add-before 'check 'remove-failing-tests
(lambda _
(with-directory-excursion "tests/fixtures/reftests"

base-commit: cebcf3533ab83233121434254a6ae7b8c35cfa1f
--
2.39.2
A
A
Andreas Enge wrote on 8 Apr 2023 11:52
Re: Fix for librsvg 2.40 on core-updates
(name . Kaelyn)(address . kaelyn.alexi@protonmail.com)
ZDE5XTWVO7lJshkJ@jurong
Hello,

Am Fri, Apr 07, 2023 at 04:53:15PM +0000 schrieb Kaelyn:
Toggle quote (2 lines)
> On core-updates, librsvg-2.40 fails to compile due to a single failing test (I've confirmed the failure on x86_64 and i686, though the package is only used/needed on non-x86_64 systems for gtk+ and others; it also affects wine and wine-staging on x86_64 as they are 32-bit packages). I was able to track down the test failure to a text rendering difference between Pango 1.48 and 1.50, which led to the text being one pixel line higher between the reference and output images. On Monday I submitted https://issues.guix.gnu.org/62646which adds a phase to librsvg-2.40 to adjust the output Y coordinate of the SVG transformation matrix by one for the failing test so that it passes with Pango 1.50.

thanks a lot, I added a copyright line for you and pushed.

Wine still fails to build due to autogen not building on i686:
libtool: compile: gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I../autoopts -DPKGDATADIR=\"/gnu/store/6i60j0fxdsg4qwymas4ymfqlv1azidnc-autogen-5.18.16/share/autogen\" -g -O2 -Wno-format-contains-nul -fno-strict-aliasing -Wall -Werror -Wcast-align -Wmissing-prototypes -Wpointer-arith -Wshadow -Wstrict-prototypes -Wwrite-strings -Wstrict-aliasing=3 -Wextra -Wno-cast-qual -g -O2 -Wno-format-contains-nul -fno-strict-aliasing -c libopts.c -fPIC -DPIC -o .libs/libopts_la-libopts.o
In file included from libopts.c:48:
usage.c: In function ‘prt_extd_usage.isra’:
usage.c:736:38: error: ‘s ’ directive output may be truncated writing 2 bytes into a region of size between 0 and 9 [-Werror=format-truncation=]
736 | snprintf(vfmt, sizeof(vfmt), vfmtfmt, (unsigned int)nmlen + 4);
| ^~~~~~~
usage.c:736:9: note: ‘snprintf’ output between 9 and 18 bytes into a destination of size 12
736 | snprintf(vfmt, sizeof(vfmt), vfmtfmt, (unsigned int)nmlen + 4);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Just in case you wish to continue investigating :)

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62646@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62646
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch