(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
Allow running more than one mcron instance.
Follow-up to https://issues.guix.gnu.org/62169.
* gnu/services/mcron.scm (mcron-configuration)[instance-name]: New field.
(shepherd-schedule-action): Implement instance-name support.
* doc/guix.texi (Scheduled Job Execution): Update it.
---
doc/guix.texi | 26 ++++++++++++++++++++++++++
gnu/services/mcron.scm | 16 +++++++++++++---
2 files changed, 39 insertions(+), 3 deletions(-)
Toggle diff (96 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 3e335306f1..0f735489d5 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -19376,6 +19376,10 @@ Scheduled Job Execution
@item @code{mcron} (default: @code{mcron}) (type: file-like)
The mcron package to use.
+@item @code{instance} (type: maybe-symbol)
+Set the shepherd service name to @code{mcron-@var{instance}}. This is
+useful when you want to have more than one mcron instance.
+
@item @code{jobs} (default: @code{()}) (type: list-of-gexps)
This is a list of gexps (@pxref{G-Expressions}), where each gexp
corresponds to an mcron job specification (@pxref{Syntax, mcron job
@@ -19400,6 +19404,28 @@ Scheduled Job Execution
@end deftp
@c %end of fragment
+Occasionally, it is desirable to run another mcron instance to separate
+some of the jobs from the main mcron instance for clarity purposes, or if
+the jobs are very chatty and frequent. (for example, a heartbeat check
+every 30 seconds)
+
+The example below shows how an extra mcron service can be defined.
+@lisp
+(use (guix)
+ (guix records)
+ (gnu services)
+ (gnu services mcron))
+
+(define secondary-mcron-service-type
+ (service-type
+ (inherit mcron-service-type)
+ (name 'mcron-secondary)
+ (default-value
+ (mcron-configuration
+ (instance 'secondary)
+ (log-file "/var/log/mcron-secondary.log")))))
+@end lisp
+
@node Log Rotation
@subsection Log Rotation
diff --git a/gnu/services/mcron.scm b/gnu/services/mcron.scm
index 2ef5980e09..c949f1aebc 100644
--- a/gnu/services/mcron.scm
+++ b/gnu/services/mcron.scm
@@ -27,6 +27,7 @@ (define-module (gnu services mcron)
#:use-module (guix records)
#:use-module (guix gexp)
#:use-module (srfi srfi-1)
+ #:use-module (ice-9 format)
#:use-module (ice-9 match)
#:use-module (ice-9 vlist)
#:export (mcron-configuration
@@ -59,12 +60,18 @@ (define list-of-gexps?
(list-of gexp?))
(define-maybe/no-serialization string)
+(define-maybe/no-serialization symbol)
(define-configuration/no-serialization mcron-configuration
(mcron
(file-like mcron)
"The mcron package to use.")
+ (instance
+ maybe-symbol
+ "Set the shepherd service name to @code{mcron-@var{instance}}.
+This is useful when you want to have more than one mcron instance.")
+
(jobs
(list-of-gexps '())
"This is a list of gexps (@pxref{G-Expressions}), where each gexp
@@ -158,12 +165,15 @@ (define (shepherd-schedule-action mcron files)
(define (mcron-shepherd-services config)
(match-record config <mcron-configuration>
- (mcron jobs log? log-file log-format date-format)
+ (mcron jobs log? log-file log-format date-format instance)
(if (eq? jobs '())
'() ;nothing to do
- (let ((files (job-files mcron jobs)))
+ (let ((files (job-files mcron jobs))
+ (service-name
+ (string->symbol
+ (format #f "mcron~@[-~a~]" (maybe-value instance)))))
(list (shepherd-service
- (provision '(mcron))
+ (provision (list service-name))
(requirement '(user-processes))
(modules `((srfi srfi-1)
(srfi srfi-26)
--
2.39.1