[PATCH 0/3] services: mcron: Make log-file and date-format configurable.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 13 Mar 2023 20:02
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1678734029.git.mirai@makinata.eu
Tested with 'make check-system TESTS=mcron'.

Bruno Victal (3):
services: mcron: Restyle mcron-configuration.
services: mcron: Use match-record.
services: mcron: Add log-file and date-format fields.

doc/guix.texi | 8 +++-
gnu/services/mcron.scm | 104 +++++++++++++++++++++++++----------------
2 files changed, 71 insertions(+), 41 deletions(-)

--
2.39.1
B
B
Bruno Victal wrote on 13 Mar 2023 20:30
[PATCH 2/3] services: mcron: Use match-record.
(address . 62169@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
691ab538c6a9ea4d62b9113416114d12ddca0d54.1678735825.git.mirai@makinata.eu
* gnu/services/mcron.scm (mcron-shepherd-services): Use match-record.
---
gnu/services/mcron.scm | 68 ++++++++++++++++++++----------------------
1 file changed, 33 insertions(+), 35 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/services/mcron.scm b/gnu/services/mcron.scm
index 6ee333f253..9f3afecf62 100644
--- a/gnu/services/mcron.scm
+++ b/gnu/services/mcron.scm
@@ -143,41 +143,39 @@ (define (shepherd-schedule-action mcron files)
(display line)
(loop)))))))))
-(define mcron-shepherd-services
- (match-lambda
- (($ <mcron-configuration> mcron ()) ;nothing to do!
- '())
- (($ <mcron-configuration> mcron jobs log? log-format)
- (let ((files (job-files mcron jobs)))
- (list (shepherd-service
- (provision '(mcron))
- (requirement '(user-processes))
- (modules `((srfi srfi-1)
- (srfi srfi-26)
- (ice-9 popen) ;for the 'schedule' action
- (ice-9 rdelim)
- (ice-9 match)
- ,@%default-modules))
- (start #~(make-forkexec-constructor
- (list (string-append #$mcron "/bin/mcron")
- #$@(if log?
- #~("--log" "--log-format" #$log-format)
- #~())
- #$@files)
-
- ;; Disable auto-compilation of the job files and set a
- ;; sane value for 'PATH'.
- #:environment-variables
- (cons* "GUILE_AUTO_COMPILE=0"
- "PATH=/run/current-system/profile/bin"
- (remove (cut string-prefix? "PATH=" <>)
- (environ)))
-
- #:log-file "/var/log/mcron.log"))
- (stop #~(make-kill-destructor))
-
- (actions
- (list (shepherd-schedule-action mcron files)))))))))
+(define (mcron-shepherd-services config)
+ (match-record config <mcron-configuration> (mcron jobs log? log-format)
+ (if (eq? jobs '())
+ '() ; nothing to do
+ (let ((files (job-files mcron jobs)))
+ (list (shepherd-service
+ (provision '(mcron))
+ (requirement '(user-processes))
+ (modules `((srfi srfi-1)
+ (srfi srfi-26)
+ (ice-9 popen) ;for the 'schedule' action
+ (ice-9 rdelim)
+ (ice-9 match)
+ ,@%default-modules))
+ (start #~(make-forkexec-constructor
+ (list (string-append #$mcron "/bin/mcron")
+ #$@(if log?
+ #~("--log" "--log-format" #$log-format)
+ #~())
+ #$@files)
+
+ ;; Disable auto-compilation of the job files and
+ ;; set a sane value for 'PATH'.
+ #:environment-variables
+ (cons* "GUILE_AUTO_COMPILE=0"
+ "PATH=/run/current-system/profile/bin"
+ (remove (cut string-prefix? "PATH=" <>)
+ (environ)))
+
+ #:log-file "/var/log/mcron.log"))
+ (stop #~(make-kill-destructor))
+ (actions
+ (list (shepherd-schedule-action mcron files)))))))))
(define mcron-service-type
(service-type (name 'mcron)
--
2.39.1
B
B
Bruno Victal wrote on 13 Mar 2023 20:30
[PATCH 1/3] services: mcron: Restyle mcron-configuration.
(address . 62169@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
fb081be4b450a9c6b4104025475d73af1aebbe8d.1678735825.git.mirai@makinata.eu
* doc/guix.texi (Scheduled Job Execution): Sync doc with source.
* gnu/services/mcron.scm (mcron-configuration): Restyle.
[log-format]: Fix incorrectly formatted text.
---
doc/guix.texi | 2 +-
gnu/services/mcron.scm | 15 +++++++++++----
2 files changed, 12 insertions(+), 5 deletions(-)

Toggle diff (49 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 39932d5aad..45d96b8fbb 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -19349,7 +19349,7 @@ Scheduled Job Execution
@item @code{log-format} (default: @code{"~1@@*~a ~a: ~a~%"}) (type: string)
@code{(ice-9 format)} format string for log messages. The default value
-produces messages like "@samp{@var{pid} @var{name}: @var{message}"}
+produces messages like @samp{@var{pid} @var{name}: @var{message}}
(@pxref{Invoking mcron, Invoking,, mcron,GNU@tie{}mcron}). Each message
is also prefixed by a timestamp by GNU Shepherd.
diff --git a/gnu/services/mcron.scm b/gnu/services/mcron.scm
index 52332d6123..6ee333f253 100644
--- a/gnu/services/mcron.scm
+++ b/gnu/services/mcron.scm
@@ -56,18 +56,25 @@ (define list-of-gexps?
(list-of gexp?))
(define-configuration/no-serialization mcron-configuration
- (mcron (file-like mcron) "The mcron package to use.")
+ (mcron
+ (file-like mcron)
+ "The mcron package to use.")
+
(jobs
(list-of-gexps '())
"This is a list of gexps (@pxref{G-Expressions}), where each gexp
corresponds to an mcron job specification (@pxref{Syntax, mcron job
specifications,, mcron, GNU@tie{}mcron}).")
- (log? (boolean #t) "Log messages to standard output.")
+
+ (log?
+ (boolean #t)
+ "Log messages to standard output.")
+
(log-format
(string "~1@*~a ~a: ~a~%")
"@code{(ice-9 format)} format string for log messages. The default value
-produces messages like \"@samp{@var{pid} @var{name}:
-@var{message}\"} (@pxref{Invoking mcron, Invoking,, mcron, GNU@tie{}mcron}).
+produces messages like @samp{@var{pid} @var{name}: @var{message}}
+(@pxref{Invoking mcron, Invoking,, mcron, GNU@tie{}mcron}).
Each message is also prefixed by a timestamp by GNU Shepherd."))
(define (job-files mcron jobs)
--
2.39.1
B
B
Bruno Victal wrote on 13 Mar 2023 20:30
[PATCH 3/3] services: mcron: Add log-file and date-format fields.
(address . 62169@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
93b9d69cf03ecb9933072b0911c1b291b4788bd6.1678735825.git.mirai@makinata.eu
* doc/guix.texi (Scheduled Job Execution): Document it.
* gnu/services/mcron.scm (mcron-configuration)[log-file, date-format]: New field.
(mcron-shepherd-services): Add log-file and date-format support.
Use file-append instead of string-append.
---
doc/guix.texi | 6 ++++++
gnu/services/mcron.scm | 31 +++++++++++++++++++++++++------
2 files changed, 31 insertions(+), 6 deletions(-)

Toggle diff (116 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 45d96b8fbb..6d47d36d22 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -19347,12 +19347,18 @@ Scheduled Job Execution
@item @code{log?} (default: @code{#t}) (type: boolean)
Log messages to standard output.
+@item @code{log-file} (default: @code{"/var/log/mcron.log"}) (type: string)
+Log file location.
+
@item @code{log-format} (default: @code{"~1@@*~a ~a: ~a~%"}) (type: string)
@code{(ice-9 format)} format string for log messages. The default value
produces messages like @samp{@var{pid} @var{name}: @var{message}}
(@pxref{Invoking mcron, Invoking,, mcron,GNU@tie{}mcron}). Each message
is also prefixed by a timestamp by GNU Shepherd.
+@item @code{date-format} (type: maybe-string)
+@code{(srfi srfi-19)} format string for date.
+
@end table
@end deftp
@c %end of fragment
diff --git a/gnu/services/mcron.scm b/gnu/services/mcron.scm
index 9f3afecf62..dac213358c 100644
--- a/gnu/services/mcron.scm
+++ b/gnu/services/mcron.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,7 +34,9 @@ (define-module (gnu services mcron)
mcron-configuration-mcron
mcron-configuration-jobs
mcron-configuration-log?
+ mcron-configuration-log-file
mcron-configuration-log-format
+ mcron-configuration-date-format
mcron-service-type))
@@ -55,6 +58,8 @@ (define-module (gnu services mcron)
(define list-of-gexps?
(list-of gexp?))
+(define-maybe/no-serialization string)
+
(define-configuration/no-serialization mcron-configuration
(mcron
(file-like mcron)
@@ -70,12 +75,20 @@ (define-configuration/no-serialization mcron-configuration
(boolean #t)
"Log messages to standard output.")
+ (log-file
+ (string "/var/log/mcron.log")
+ "Log file location.")
+
(log-format
(string "~1@*~a ~a: ~a~%")
"@code{(ice-9 format)} format string for log messages. The default value
produces messages like @samp{@var{pid} @var{name}: @var{message}}
(@pxref{Invoking mcron, Invoking,, mcron, GNU@tie{}mcron}).
-Each message is also prefixed by a timestamp by GNU Shepherd."))
+Each message is also prefixed by a timestamp by GNU Shepherd.")
+
+ (date-format
+ maybe-string
+ "@code{(srfi srfi-19)} format string for date."))
(define (job-files mcron jobs)
"Return a list of file-like object for JOBS, a list of gexps."
@@ -144,7 +157,9 @@ (define (shepherd-schedule-action mcron files)
(loop)))))))))
(define (mcron-shepherd-services config)
- (match-record config <mcron-configuration> (mcron jobs log? log-format)
+ (match-record config <mcron-configuration> (mcron jobs
+ log? log-file log-format
+ date-format)
(if (eq? jobs '())
'() ; nothing to do
(let ((files (job-files mcron jobs)))
@@ -158,10 +173,14 @@ (define (mcron-shepherd-services config)
(ice-9 match)
,@%default-modules))
(start #~(make-forkexec-constructor
- (list (string-append #$mcron "/bin/mcron")
+ (list #$(file-append mcron "/bin/mcron")
#$@(if log?
- #~("--log" "--log-format" #$log-format)
- #~())
+ `("--log" "--log-format" ,log-format
+ ,@(if (maybe-value-set? date-format)
+ (list "--date-format"
+ date-format)
+ '()))
+ '())
#$@files)
;; Disable auto-compilation of the job files and
@@ -172,7 +191,7 @@ (define (mcron-shepherd-services config)
(remove (cut string-prefix? "PATH=" <>)
(environ)))
- #:log-file "/var/log/mcron.log"))
+ #:log-file #$log-file))
(stop #~(make-kill-destructor))
(actions
(list (shepherd-schedule-action mcron files)))))))))
--
2.39.1
M
M
Maxim Cournoyer wrote on 21 Mar 2023 19:45
Re: bug#62169: [PATCH 0/3] services: mcron: Make log-file and date-format configurable.
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 62169@debbugs.gnu.org)
87bkkmndub.fsf_-_@gmail.com
Hello,

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (5 lines)
> * doc/guix.texi (Scheduled Job Execution): Document it.
> * gnu/services/mcron.scm (mcron-configuration)[log-file, date-format]: New field.
> (mcron-shepherd-services): Add log-file and date-format support.
> Use file-append instead of string-append.

I've installed the first 2 patches, but was wondering about the use case
for having a configurable log-file for mcron? It seems it'd be very
niche to me, so perhaps it's not necessary?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 21 Mar 2023 19:51
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 62169-done@debbugs.gnu.org)
877cvandk0.fsf_-_@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (13 lines)
> Hello,
>
> Bruno Victal <mirai@makinata.eu> writes:
>
>> * doc/guix.texi (Scheduled Job Execution): Document it.
>> * gnu/services/mcron.scm (mcron-configuration)[log-file, date-format]: New field.
>> (mcron-shepherd-services): Add log-file and date-format support.
>> Use file-append instead of string-append.
>
> I've installed the first 2 patches, but was wondering about the use case
> for having a configurable log-file for mcron? It seems it'd be very
> niche to me, so perhaps it's not necessary?

Thanks for confirming the use case on #guix (see:

Installed that one as well.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62169@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62169
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch