[PATCH 0/3] Update psmisc to 23.6.

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • Tobias Geerinckx-Rice
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 21 Mar 2023 18:04
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1679417884.git.mirai@makinata.eu
This patch-series modernizes the package definition with G-Expressions
and updates it to 23.6.

Along the way, the patch from #34828 [1] was integrated into
this series with some minor touchups, after resolving the merge-conflicts.




Bruno Victal (2):
gnu: psmisc: Use G-Expressions.
gnu: psmisc: Update to 23.6.

mikadoZero (1):
gnu: psmisc: Make description more informative.

gnu/packages/linux.scm | 29 ++++++++++++++++++-----------
1 file changed, 18 insertions(+), 11 deletions(-)

--
2.39.1
B
B
Bruno Victal wrote on 21 Mar 2023 18:11
[PATCH 3/3] gnu: psmisc: Update to 23.6.
(address . 62348@debbugs.gnu.org)
d5005c72a941ae369faadfb908fac7fed539da06.1679418658.git.mirai@makinata.eu
* gnu/packages/linux.scm (psmisc): Update to 23.6.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8ecbf32bf8..dfd9748a67 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2020,14 +2020,14 @@ (define-public powerstat
(define-public psmisc
(package
(name "psmisc")
- (version "23.5")
+ (version "23.6")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/psmisc/psmisc/psmisc-"
version ".tar.xz"))
(sha256
- (base32 "12z5786dnf37n8wvv73wdcqp3nvsqzhwdk3ajna0mag4yz1fqdyw"))))
+ (base32 "0al2138z0m2bqrviv3zw2i2km4v8xg5wrw867li4jk4s2l3dwz95"))))
(build-system gnu-build-system)
(arguments
(list
--
2.39.1
B
B
Bruno Victal wrote on 21 Mar 2023 18:11
[PATCH 1/3] gnu: psmisc: Make description more informative.
(address . 62348@debbugs.gnu.org)
40a8417b0c696509da522c9b5c072f004c0615f0.1679418658.git.mirai@makinata.eu
From: mikadoZero <mikadozero@yandex.com>

The text for the description is taken from the psmisc readme.

* gnu/packages/linux.scm (psmisc)[description]: Make description more informative.

Co-authored-by: Bruno Victal <mirai@makinata.eu>
---
gnu/packages/linux.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ef05e77ec8..14e6f46a39 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;; Copyright © 2019, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Stefan Stefanovi? <stefanx2ovic@gmail.com>
;;; Copyright © 2019-2022 Brice Waegeneire <brice@waegenei.re>
@@ -2039,9 +2040,15 @@ (define-public psmisc
(home-page "https://gitlab.com/psmisc/psmisc")
(synopsis "Small utilities that use the proc file system")
(description
- "This PSmisc package is a set of some small useful utilities that
-use the proc file system. We're not about changing the world, but
-providing the system administrator with some help in common tasks.")
+ "A package of small utilities that use the proc file-system.
+@itemize @bullet
+@item @command{fuser} - Identifies processes using files or sockets
+@item @command{killall} - kills processes by name, e.g. @samp{killall -HUP @var{name}}
+@item @command{prtstat} - prints statistics of a process
+@item @command{pslog} - prints log path(s) of a process
+@item @command{pstree} - shows the currently running processes as a tree
+@item @command{peekfd} - shows the data travelling over a file descriptor
+@end itemize")
(license license:gpl2+)))
(define-public util-linux
--
2.39.1
B
B
Bruno Victal wrote on 21 Mar 2023 18:11
[PATCH 2/3] gnu: psmisc: Use G-Expressions.
(address . 62348@debbugs.gnu.org)
be8f7e79ba114f8affd20a26aec7d9862cb554c6.1679418658.git.mirai@makinata.eu
* gnu/packages/linux.scm (psmisc): Use G-Expressions.
---
gnu/packages/linux.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 14e6f46a39..8ecbf32bf8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2030,12 +2030,12 @@ (define-public psmisc
(base32 "12z5786dnf37n8wvv73wdcqp3nvsqzhwdk3ajna0mag4yz1fqdyw"))))
(build-system gnu-build-system)
(arguments
- `(,@(if (%current-target-system)
- '(#:configure-flags
- (list
- "ac_cv_func_malloc_0_nonnull=yes"
- "ac_cv_func_realloc_0_nonnull=yes"))
- '())))
+ (list
+ #:configure-flags
+ (if (%current-target-system)
+ #~(list "ac_cv_func_malloc_0_nonnull=yes"
+ "ac_cv_func_realloc_0_nonnull=yes")
+ #~'())))
(inputs (list ncurses))
(home-page "https://gitlab.com/psmisc/psmisc")
(synopsis "Small utilities that use the proc file system")
--
2.39.1
N
N
Nicolas Goaziou wrote on 21 Mar 2023 18:20
Re: [bug#62348] [PATCH 1/3] gnu: psmisc: Make description more informative.
(name . Bruno Victal)(address . mirai@makinata.eu)
87v8iu10nk.fsf@nicolasgoaziou.fr
Hello,

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (7 lines)
> From: mikadoZero <mikadozero@yandex.com>
>
> The text for the description is taken from the psmisc readme.
>
> * gnu/packages/linux.scm (psmisc)[description]: Make description more
> informative.

Thanks.

Toggle quote (2 lines)
> + "A package of small utilities that use the proc file-system.

This should be a complete sentence, e.g.,

Psmisc is a set of small utilities…

Toggle quote (9 lines)
> +@itemize @bullet
> +@item @command{fuser} - Identifies processes using files or sockets
> +@item @command{killall} - kills processes by name, e.g. @samp{killall -HUP @var{name}}
> +@item @command{prtstat} - prints statistics of a process
> +@item @command{pslog} - prints log path(s) of a process
> +@item @command{pstree} - shows the currently running processes as a tree
> +@item @command{peekfd} - shows the data travelling over a file descriptor
> +@end itemize")

I suggest to remove the dashes, and probably add semicolons at the end
of all but last item:

@item @command{fuser} identifies processes using files or sockets;

I suggest to add a comma after "e.g.", so Texinfo cannot consider it to
be the end of a sentence:

@item @command{killall} kills processes by name, e.g., @samp{killall -HUP @var{name}};

Actually, I even wonder if providing an example if worth being in
a generic description. I probably belongs to a user manual:

@item @command{killall} kills processes by name;

Regards,
--
Nicolas Goaziou
B
B
Bruno Victal wrote on 21 Mar 2023 20:23
[PATCH v2 3/3] gnu: psmisc: Update to 23.6.
(address . 62348@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
f06e8204567ff9fba6fc953c607659591f6b962c.1679426568.git.mirai@makinata.eu
* gnu/packages/linux.scm (psmisc): Update to 23.6.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ffaf9aadf4..8912bfd091 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2020,14 +2020,14 @@ (define-public powerstat
(define-public psmisc
(package
(name "psmisc")
- (version "23.5")
+ (version "23.6")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/psmisc/psmisc/psmisc-"
version ".tar.xz"))
(sha256
- (base32 "12z5786dnf37n8wvv73wdcqp3nvsqzhwdk3ajna0mag4yz1fqdyw"))))
+ (base32 "0al2138z0m2bqrviv3zw2i2km4v8xg5wrw867li4jk4s2l3dwz95"))))
(build-system gnu-build-system)
(arguments
(list
--
2.39.1
B
B
Bruno Victal wrote on 21 Mar 2023 20:23
[PATCH v2 2/3] gnu: psmisc: Use G-Expressions.
(address . 62348@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
032924f0bc197ffe46a068d3047736da76a74200.1679426568.git.mirai@makinata.eu
* gnu/packages/linux.scm (psmisc): Use G-Expressions.
---
gnu/packages/linux.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d1d1e10741..ffaf9aadf4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2030,12 +2030,12 @@ (define-public psmisc
(base32 "12z5786dnf37n8wvv73wdcqp3nvsqzhwdk3ajna0mag4yz1fqdyw"))))
(build-system gnu-build-system)
(arguments
- `(,@(if (%current-target-system)
- '(#:configure-flags
- (list
- "ac_cv_func_malloc_0_nonnull=yes"
- "ac_cv_func_realloc_0_nonnull=yes"))
- '())))
+ (list
+ #:configure-flags
+ (if (%current-target-system)
+ #~(list "ac_cv_func_malloc_0_nonnull=yes"
+ "ac_cv_func_realloc_0_nonnull=yes")
+ #~'())))
(inputs (list ncurses))
(home-page "https://gitlab.com/psmisc/psmisc")
(synopsis "Small utilities that use the proc file system")
--
2.39.1
B
B
Bruno Victal wrote on 21 Mar 2023 20:23
[PATCH v2 1/3] gnu: psmisc: Make description more informative.
(address . 62348@debbugs.gnu.org)
3c73c4ee9c2ad8dafabbaacdb757596986511071.1679426568.git.mirai@makinata.eu
From: mikadoZero <mikadozero@yandex.com>

The text for the description is taken from the psmisc readme.

* gnu/packages/linux.scm (psmisc)[description]: Make description more informative.

Co-authored-by: Bruno Victal <mirai@makinata.eu>
---
gnu/packages/linux.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ef05e77ec8..d1d1e10741 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;; Copyright © 2019, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Stefan Stefanovi? <stefanx2ovic@gmail.com>
;;; Copyright © 2019-2022 Brice Waegeneire <brice@waegenei.re>
@@ -2039,9 +2040,15 @@ (define-public psmisc
(home-page "https://gitlab.com/psmisc/psmisc")
(synopsis "Small utilities that use the proc file system")
(description
- "This PSmisc package is a set of some small useful utilities that
-use the proc file system. We're not about changing the world, but
-providing the system administrator with some help in common tasks.")
+ "psmisc is a set of small utilities that use the proc file-system.
+@itemize @bullet
+@item @command{fuser} identifies processes using files or sockets;
+@item @command{killall} kills processes by name;
+@item @command{prtstat} prints statistics of a process;
+@item @command{pslog} prints log path(s) of a process;
+@item @command{pstree} shows the currently running processes as a tree;
+@item @command{peekfd} shows the data travelling over a file descriptor
+@end itemize")
(license license:gpl2+)))
(define-public util-linux
--
2.39.1
B
B
Bruno Victal wrote on 24 Aug 2023 18:52
[PATCH v3 0/3] Improve psmisc description & update.
(address . 62348@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1692895660.git.mirai@makinata.eu
Notable changes since v2:
* Use '@table @command' for description.


Bruno Victal (2):
gnu: psmisc: Use G-Expressions.
gnu: psmisc: Update to 23.6.

mikadoZero (1):
gnu: psmisc: Make description more informative.

gnu/packages/linux.scm | 34 +++++++++++++++++++++++-----------
1 file changed, 23 insertions(+), 11 deletions(-)


base-commit: 738b0e4ccc2bac3d77bb29dd6d51026d887d6b16
--
2.41.0
B
B
Bruno Victal wrote on 24 Aug 2023 18:54
[PATCH v3 1/3] gnu: psmisc: Make description more informative.
(address . 62348@debbugs.gnu.org)
4f696f7a94c29c88ae92470c512e64f4d576a1f9.1692896057.git.mirai@makinata.eu
From: mikadoZero <mikadozero@yandex.com>

The text for the description is taken from the psmisc readme.

* gnu/packages/linux.scm (psmisc)[description]: Make description more informative.

Co-authored-by: Bruno Victal <mirai@makinata.eu>
---
gnu/packages/linux.scm | 18 +++++++++++++++---
1 file changed, 15 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ca223aea37..4c5d2fc4c7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2070,9 +2070,21 @@ (define-public psmisc
(home-page "https://gitlab.com/psmisc/psmisc")
(synopsis "Small utilities that use the proc file system")
(description
- "This PSmisc package is a set of some small useful utilities that
-use the proc file system. We're not about changing the world, but
-providing the system administrator with some help in common tasks.")
+ "psmisc is a set of small utilities that use the proc file-system.
+@table @command
+@item fuser
+Identifies processes using files or sockets.
+@item killall
+Kills processes by name.
+@item prtstat
+Prints statistics of a process.
+@item pslog
+Prints log path(s) of a process.
+@item pstree
+Shows the currently running processes as a tree.
+@item peekfd
+Shows the data travelling over a file descriptor.
+@end table")
(license license:gpl2+)))
(define-public util-linux

base-commit: 738b0e4ccc2bac3d77bb29dd6d51026d887d6b16
--
2.40.1
B
B
Bruno Victal wrote on 24 Aug 2023 18:54
[PATCH v3 2/3] gnu: psmisc: Use G-Expressions.
(address . 62348@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
ea17cdea7e5ed7c79151cd76df489cf7eb0aa60c.1692896057.git.mirai@makinata.eu
* gnu/packages/linux.scm (psmisc): Use G-Expressions.
---
gnu/packages/linux.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4c5d2fc4c7..3bd5624730 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2060,12 +2060,12 @@ (define-public psmisc
(base32 "12z5786dnf37n8wvv73wdcqp3nvsqzhwdk3ajna0mag4yz1fqdyw"))))
(build-system gnu-build-system)
(arguments
- `(,@(if (%current-target-system)
- '(#:configure-flags
- (list
- "ac_cv_func_malloc_0_nonnull=yes"
- "ac_cv_func_realloc_0_nonnull=yes"))
- '())))
+ (list
+ #:configure-flags
+ (if (%current-target-system)
+ #~(list "ac_cv_func_malloc_0_nonnull=yes"
+ "ac_cv_func_realloc_0_nonnull=yes")
+ #~'())))
(inputs (list ncurses))
(home-page "https://gitlab.com/psmisc/psmisc")
(synopsis "Small utilities that use the proc file system")
--
2.40.1
B
B
Bruno Victal wrote on 24 Aug 2023 18:54
[PATCH v3 3/3] gnu: psmisc: Update to 23.6.
(address . 62348@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
f74d7b6785a13e94b807729cefb87ae341c83f52.1692896057.git.mirai@makinata.eu
* gnu/packages/linux.scm (psmisc): Update to 23.6.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3bd5624730..011313df4f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2050,14 +2050,14 @@ (define-public powerstat
(define-public psmisc
(package
(name "psmisc")
- (version "23.5")
+ (version "23.6")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/psmisc/psmisc/psmisc-"
version ".tar.xz"))
(sha256
- (base32 "12z5786dnf37n8wvv73wdcqp3nvsqzhwdk3ajna0mag4yz1fqdyw"))))
+ (base32 "0al2138z0m2bqrviv3zw2i2km4v8xg5wrw867li4jk4s2l3dwz95"))))
(build-system gnu-build-system)
(arguments
(list
--
2.40.1
T
T
Tobias Geerinckx-Rice wrote on 16 Sep 2023 15:43
Re: [PATCH] Update psmisc to 23.6.
718fbf66254c89368203edfb7efebb7a@tobias.gr
Hi mikadoZero & Bruno,

I pushed #62348 patches 1 & 2 to master as
32b4f59433df620ab8f4b9a6c523f8ef9500d75d et al. I fixed a minor typo
(‘file-system’) and added a full stop.

The update patch (3/3) went to core-updates as
725b2528a65edf7425762b99330ab1c9bd33bc86.

Thanks!

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
Closed
?