This patch is for bug#34828. It makes the description for psmisc
more informative.
This is one of my first patches submitted to Guix. Feedback is
appreciated.
Passed:
`guix lint psmisc`
`guix build --rounds=4 psmisc`
------------
From 95f47eadb05de56a542d1be8f630e5ec4aa81485 Mon Sep 17 00:00:00 2001
* gnu/packages/linux.scm (psmisc):
The content for the description is taken from the psmisc readme.
---
gnu/packages/linux.scm | 19 ++++++++++++++++---
1 file changed, 16 insertions(+), 3 deletions(-)
Toggle diff (39 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 311bc6fa5..5365aa97d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -602,9 +603,21 @@ at login. Local and dynamic reconfiguration are its key features.")
(synopsis
"Small utilities that use the proc file system")
(description
- "This PSmisc package is a set of some small useful utilities that
-use the proc file system. We're not about changing the world, but
-providing the system administrator with some help in common tasks.")
+ "A package of small utilities that use the proc file-system.
+@itemize @bullet
+@item
+fuser - Identifies processes using files or sockets
+@item
+killall - kills processes by name, e.g. killall -HUP named
+@item
+prtstat - prints statistics of a process
+@item
+pslog - prints log path(s) of a process
+@item
+pstree - shows the currently running processes as a tree
+@item
+peekfd - shows the data travelling over a file descriptor
+@end itemize")
(license license:gpl2+)))
(define-public util-linux
--
2.21.0