[PATCH] gnu: add pcsc-cyberjack

  • Done
  • quality assurance status badge
Details
3 participants
  • Arvid Krein
  • ???
  • Bruno Victal
Owner
unassigned
Submitted by
Arvid Krein
Severity
normal
A
A
Arvid Krein wrote on 20 Mar 2023 11:28
(address . guix-patches@gnu.org)
fab4c4c9-2bb9-0fa2-9050-75ba632b3d8e@zedat.fu-berlin.de
* gnu/packages/security-token.scm (pcsc-cyberjack): New variable.
---
 gnu/packages/security-token.scm | 34 +++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/security-token.scm
b/gnu/packages/security-token.scm
index a7f5e3acf9..521f6f226b 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -967,3 +967,37 @@ (define-public cardpeek
 It also has limited support for Mifare Classic compatible cards
(Thalys card)")
     (license license:gpl3+)
     (home-page "http://pannetrat.com/Cardpeek")))
+
+(define-public pcsc-cyberjack
+  (package
+    (name "pcsc-cyberjack")
+    (version "3.99.5final.sp15")
+    (synopsis "PC/SC driver for cyberJack chipcard readers")
+    (home-page "http://www.reiner-sct.com/")
+    (description
+     "REINER SCT cyberJack USB chipcard reader user space driver
+ This package includes the IFD driver for the cyberJack contactless
+ (RFID) and contact USB chipcard reader.")
+    (license license:lgpl2.1+)
+    (native-inputs (list pkg-config))
+    (inputs (list pcsc-lite libusb))
+    (outputs '("out" "tools"))
+    (source (origin
+              (method url-fetch)
+              (uri
+
"https://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP15/pcsc-cyberjack_3.99.5final.SP15.tar.bz2")
+              (sha256
+               (base32
+ "0yj6plgb245r218v6lgdabb3422hxyrw8rrpf5b8fwah4j1w5dxc"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:configure-flags #~(list (string-append "--with-usbdropdir="
+                                                    (ungexp output "out")
+ "/pcsc/drivers")
+                                     (string-append "--bindir="
+                                                    (ungexp output "tools")
+                                                    "/bin"))
+           #:phases '(modify-phases %standard-phases
+                       (add-after 'install 'install-tools
+                         (lambda _
+                           (invoke "make" "-C" "tools/cjflash"
"install"))))))))

base-commit: 3a2200e1ad2049ad7e25295e6b4e013f74dd84e2
--
2.39.2
B
B
Bruno Victal wrote on 20 Mar 2023 19:44
(name . Arvid Krein)(address . arvidkrein@zedat.fu-berlin.de)(address . 62293@debbugs.gnu.org)
581f51f5-aecc-13db-a499-af8a9e485d39@makinata.eu
Hi Arvid,

On 2023-03-20 10:28, Arvid Krein wrote:
Toggle quote (11 lines)
> +(define-public pcsc-cyberjack
> +  (package
> +    (name "pcsc-cyberjack")
> +    (version "3.99.5final.sp15")
> +    (synopsis "PC/SC driver for cyberJack chipcard readers")
> +    (home-page "http://www.reiner-sct.com/")
> +    (description
> +     "REINER SCT cyberJack USB chipcard reader user space driver
> + This package includes the IFD driver for the cyberJack contactless
> + (RFID) and contact USB chipcard reader.")

How about “This package includes the IFD driver for the cyberJack contactless (RFID) and contact USB chipcard readers.”

Toggle quote (7 lines)
> +    (source (origin
> +              (method url-fetch)
> +              (uri
> + "https://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP15/pcsc-cyberjack_3.99.5final.SP15.tar.bz2")> +              (sha256
> +               (base32
> + "0yj6plgb245r218v6lgdabb3422hxyrw8rrpf5b8fwah4j1w5dxc"))))

How about indenting this as:

(source
(origin
(method url-fetch)
(uri ...)
(sha256
(base32 ...))))

Toggle quote (12 lines)
> +    (arguments
> +     (list #:configure-flags #~(list (string-append "--with-usbdropdir="
> +                                                    (ungexp output "out")
> + "/pcsc/drivers")
> +                                     (string-append "--bindir="
> +                                                    (ungexp output "tools")
> +                                                    "/bin"))
> +           #:phases '(modify-phases %standard-phases
> +                       (add-after 'install 'install-tools
> +                         (lambda _
> +                           (invoke "make" "-C" "tools/cjflash" "install"))))))))

Do this:

(arguments
(list
#:configure-flags
#~(list (string-append "--with-usbdropdir=" #$output "/pcsc/drivers")
(string-append "--bindir=" #$output:tools "/bin"))
#:phases
#~(modify-phases %standard-phases
... )))


Also, please reorder the package fields into something like:

(define-public ...
(package
(name ...)
(version ...)
(source ...)
(build-system ...)
(arguments ...)
(native-inputs ...)
(inputs ...)
(outputs ...)
(synopsis ...)
(description ...)
(home-page ...)
(license ...)))


Cheers,
Bruno
A
A
Arvid Krein wrote on 21 Mar 2023 12:26
[PATCH v1] gnu: add pcsc-cyberjack
(address . 62293@debbugs.gnu.org)
ef17a984-c7ed-e0de-5277-bf6c00944b7b@zedat.fu-berlin.de
* gnu/packages/security-token.scm (pcsc-cyberjack): New variable.
---
 gnu/packages/security-token.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/security-token.scm
b/gnu/packages/security-token.scm
index a7f5e3acf9..e139c9a1cf 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -967,3 +967,34 @@ (define-public cardpeek
 It also has limited support for Mifare Classic compatible cards
(Thalys card)")
     (license license:gpl3+)
     (home-page "http://pannetrat.com/Cardpeek")))
+
+(define-public pcsc-cyberjack
+  (package
+    (name "pcsc-cyberjack")
+    (version "3.99.5final.sp15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+
"https://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP15/pcsc-cyberjack_3.99.5final.SP15.tar.bz2")
+       (sha256
+        (base32
+ "0yj6plgb245r218v6lgdabb3422hxyrw8rrpf5b8fwah4j1w5dxc"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list (string-append "--with-usbdropdir=" #$output "/pcsc/drivers")
+              (string-append "--bindir=" #$output:tools "/bin"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'install-tools
+            (lambda _ (invoke "make" "-C" "tools/cjflash" "install"))))))
+    (native-inputs (list pkg-config))
+    (inputs (list pcsc-lite libusb))
+    (outputs '("out" "tools"))
+    (synopsis "PC/SC driver for cyberJack chipcard readers")
+    (description
+     "This package includes the IFD driver for the cyberJack
contactless (RFID) and contact USB chipcard readers.")
+    (home-page "http://www.reiner-sct.com/")
+    (license license:lgpl2.1+)))

base-commit: 3a2200e1ad2049ad7e25295e6b4e013f74dd84e2
--
2.39.2
A
A
Arvid Krein wrote on 22 Mar 2023 15:26
[PATCH v2] gnu: add cyberjack-pcsc
(address . 62293@debbugs.gnu.org)
422b81a4-a9ca-2973-f897-5ea381b26bf3@zedat.fu-berlin.de
Hello Bruno,

I thought a while about package naming and now think that cyberjack-pcsc
might be a better package name. The package is not part of pcsc but
rather contains pcsc drivers for cyberjack so I would think
cyberjack-pcsc is more appropriate. I am not sure about this though and
would be happy about feedback. In general this aligns better with how I
think guix package names are chosen.

Greetings,

Arvid

* gnu/packages/security-token.scm (cyberjack-pcsc): New variable.
---
 gnu/packages/security-token.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/security-token.scm
b/gnu/packages/security-token.scm
index 3cf585480e..11ec681cdc 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -1025,3 +1025,34 @@ (define-public cardpeek
 It also has limited support for Mifare Classic compatible cards
(Thalys card)")
     (license license:gpl3+)
     (home-page "http://pannetrat.com/Cardpeek")))
+
+(define-public cyberjack-pcsc
+  (package
+    (name "cyberjack-pcsc")
+    (version "3.99.5final.sp15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+
"https://support.reiner-sct.de/downloads/LINUX/V3.99.5_SP15/pcsc-cyberjack_3.99.5f
inal.SP15.tar.bz2")
+       (sha256
+        (base32
+ "0yj6plgb245r218v6lgdabb3422hxyrw8rrpf5b8fwah4j1w5dxc"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list (string-append "--with-usbdropdir=" #$output "/pcsc/drivers")
+              (string-append "--bindir=" #$output:tools "/bin"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'install-tools
+            (lambda _ (invoke "make" "-C" "tools/cjflash" "install"))))))
+    (native-inputs (list pkg-config))
+    (inputs (list pcsc-lite libusb))
+    (outputs '("out" "tools"))
+    (synopsis "PC/SC driver for cyberJack chipcard readers")
+    (description
+     "This package includes the IFD driver for the cyberJack
contactless (RFID) and contac
t USB chipcard readers.")
+    (home-page "http://www.reiner-sct.com/")
+    (license license:lgpl2.1+)))

base-commit: 4f8a13b9fbfd0efcb94ee8da46b09c6dbe84ac4b
--
2.39.2
A
A
Arvid Krein wrote on 2 Jun 2023 16:45
Done: Patch was pushed as commit a7d9cd742c3149bb014db95f88d1158d590bc124
(address . 62293-done@debbugs.gnu.org)
ac0e384b-f524-24c7-d702-eb9c790dc224@zedat.fu-berlin.de
This Patch was merged in commit a7d9cd742c3149bb014db95f88d1158d590bc124
so I am marking it as done.

Greetings,
Arvid
Closed
?
Re: bug#62293: [PATCH] gnu: add pcsc-cyberjack
(name . Arvid Krein)(address . arvidkrein@zedat.fu-berlin.de)(address . 62293-done@debbugs.gnu.org)
87bkhyt86e.fsf_-_@envs.net
Arvid Krein <arvidkrein@zedat.fu-berlin.de> writes:

Toggle quote (5 lines)
> Hello Bruno,
>
> I thought a while about package naming and now think that
> cyberjack-pcsc might be a better package name.

Hello, I pushed it as 'pcsc-cyberjack', as it's a driver/extension to
pcsc. Note that Archlinux also has it:


Thank you!
Closed
?