[PATCH] Add xfishtank and xpenguins

  • Done
  • quality assurance status badge
Details
5 participants
  • Clément Lassieur
  • Greg Hogan
  • Nicolas Goaziou
  • Sarthak Shah
  • Steve George
Owner
unassigned
Submitted by
Sarthak Shah
Severity
normal
S
S
Sarthak Shah wrote on 18 Mar 2023 17:27
(address . guix-patches@gnu.org)
CADBZEV=J2uCKptpyweZLh8=vXrKtg9=PHwwH4wdOMCfr4D51rg@mail.gmail.com
Hi Guix,
This patch adds xfishtank and xpenguins to toys.scm which are programs
similar to xsnow by the same author.

* gnu/packages/toys.scm (xpenguins): New variable.
* gnu/packages/toys.scm (xfishtank): New variable.
---
gnu/packages/toys.scm | 64 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 64 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 8967c0c25b..16adf6d92a 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -397,6 +397,70 @@ (define-public xsnow
and various scenery elements.")
(license license:gpl3+)))

+(define-public xpenguins
+ (package
+ (name "xpenguins")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-install-path
+ (lambda _
+ ;; Install program to bin instead of games.
+ (substitute* "src/Makefile.in"
+ (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+ (string-append prefix "bin")))
+ #t)))))
+ (inputs
+ (list gtk+ libx11 libxpm libxt libxml2))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://www.ratrabbit.nl/ratrabbit/xpenguins/index.html")
+ (synopsis "Let penguins take over your desktop!")
+ (description "@code{Xpenguins} is a vintage application for Unix
systems, showing penguins running, flying, falling etc. on the desktop,
using windows as run paths.")
+ (license license:gpl3+)))
+
+(define-public xfishtank
+ (package
+ (name "xfishtank")
+ (version "3.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ratrabbit.nl/downloads/xfishtank/xfishtank-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0jbx41kdpgm3nrnrvfy9znkipd8xq0jj5plavcsjkhkva8ybc0ax"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-install-path
+ (lambda _
+ ;; Install program to bin instead of games.
+ (substitute* "src/Makefile.in"
+ (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+ (string-append prefix "bin")))
+ #t)))))
+ (inputs
+ (list gtk+ libx11 libxpm libxt libxml2))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://www.ratrabbit.nl/ratrabbit/xfishtank")
+ (synopsis "Let fishes swim over your desktop!")
+ (description "@code{Xfishtank} is a well-known vintage application for
Unix systems, based on the X11 protocol. It shows fishes swimming over the
desktop.")
+ (license license:gpl3+)))
+
(define-public nyancat
(package
(name "nyancat")
--
2.39.1
Attachment: file
G
G
Greg Hogan wrote on 16 May 2023 20:26
(name . Sarthak Shah)(address . shahsarthakw@gmail.com)(address . 62262@debbugs.gnu.org)
CA+3U0ZmD0MybHG0w=L22YWm2tsdGW5c_BewHSqjhAPC1Dds1Bg@mail.gmail.com
On Sat, Mar 18, 2023 at 12:28?PM Sarthak Shah <shahsarthakw@gmail.com> wrote:
Toggle quote (4 lines)
>
> Hi Guix,
> This patch adds xfishtank and xpenguins to toys.scm which are programs similar to xsnow by the same author.

The packages build and run as expected. This single patch should be
separated into a patch per package.

Toggle quote (38 lines)
> * gnu/packages/toys.scm (xpenguins): New variable.
> * gnu/packages/toys.scm (xfishtank): New variable.
> ---
> gnu/packages/toys.scm | 64 +++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 64 insertions(+)
>
> diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
> index 8967c0c25b..16adf6d92a 100644
> --- a/gnu/packages/toys.scm
> +++ b/gnu/packages/toys.scm
> @@ -397,6 +397,70 @@ (define-public xsnow
> and various scenery elements.")
> (license license:gpl3+)))
>
> +(define-public xpenguins
> + (package
> + (name "xpenguins")
> + (version "3.2.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
> + version ".tar.gz"))
> + (sha256
> + (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
> + (build-system gnu-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (add-before 'configure 'fix-install-path
> + (lambda _
> + ;; Install program to bin instead of games.
> + (substitute* "src/Makefile.in"
> + (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
> + (string-append prefix "bin")))
> + #t)))))

It was my understanding that there is no need to return true. Same below.

Toggle quote (6 lines)
> + (inputs
> + (list gtk+ libx11 libxpm libxt libxml2))
> + (native-inputs
> + (list pkg-config))
> + (home-page "https://www.ratrabbit.nl/ratrabbit/xpenguins/index.html")

I am getting redirected and the new URL looks to be

Toggle quote (4 lines)
> + (synopsis "Let penguins take over your desktop!")
> + (description "@code{Xpenguins} is a vintage application for Unix systems, showing penguins running, flying, falling etc. on the desktop, using windows as run paths.")
> + (license license:gpl3+)))

I am finding gpl2+ in xpenguins-3.2.1/COPYING

Toggle quote (30 lines)
> +
> +(define-public xfishtank
> + (package
> + (name "xfishtank")
> + (version "3.1.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://ratrabbit.nl/downloads/xfishtank/xfishtank-"
> + version ".tar.gz"))
> + (sha256
> + (base32 "0jbx41kdpgm3nrnrvfy9znkipd8xq0jj5plavcsjkhkva8ybc0ax"))))
> + (build-system gnu-build-system)
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (add-before 'configure 'fix-install-path
> + (lambda _
> + ;; Install program to bin instead of games.
> + (substitute* "src/Makefile.in"
> + (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
> + (string-append prefix "bin")))
> + #t)))))
> + (inputs
> + (list gtk+ libx11 libxpm libxt libxml2))
> + (native-inputs
> + (list pkg-config))
> + (home-page "https://www.ratrabbit.nl/ratrabbit/xfishtank")

Same issue with redirection, with the new URL

Toggle quote (4 lines)
> + (synopsis "Let fishes swim over your desktop!")
> + (description "@code{Xfishtank} is a well-known vintage application for Unix systems, based on the X11 protocol. It shows fishes swimming over the desktop.")
> + (license license:gpl3+)))

COPYING is gpl3 but the files are MIT licensed.

Toggle quote (7 lines)
> +
> (define-public nyancat
> (package
> (name "nyancat")
> --
> 2.39.1
>
G
G
Greg Hogan wrote on 30 Jan 19:55 +0100
[PATCH v2 0/2] Add xpenguins and xfishtank.
(address . 62262@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1706640427.git.code@greghogan.com
Updated per my review in May, 2023.

Also, the home-page URLs have been updated.

Sarthak Shah (2):
gnu: Add xpenguins.
gnu: Add xfishtank.

gnu/packages/toys.scm | 65 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)


base-commit: ce519c56d6cdc7d471a22f34935ff4f76a4c0a03
--
2.43.0
G
G
Greg Hogan wrote on 30 Jan 19:55 +0100
[PATCH v2 1/2] gnu: Add xpenguins.
(address . 62262@debbugs.gnu.org)(name . Sarthak Shah)(address . shahsarthakw@gmail.com)
f42ff8c87a91fabf3fe953e570f370a728e1067c.1706640937.git.code@greghogan.com
From: Sarthak Shah <shahsarthakw@gmail.com>

* gnu/packages/toys.scm (xpenguins): New variable.

Change-Id: I6262092da4d51abaca1d6f01ec2e3f27baca7a01
---
gnu/packages/toys.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index c058e70dac..6fdc931ae6 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Sarthak Shah <shahsarthakw@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -399,6 +400,39 @@ (define-public xsnow
and various scenery elements.")
(license license:gpl3+)))
+(define-public xpenguins
+ (package
+ (name "xpenguins")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-install-path
+ (lambda _
+ ;; Install program to bin instead of games.
+ (substitute* "src/Makefile.in"
+ (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+ (string-append prefix "bin"))))))))
+ (inputs
+ (list gtk+ libx11 libxpm libxt libxml2))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://www.ratrabbit.nl/ratrabbit/software/xpenguins/index.html")
+ (synopsis "Let penguins take over your desktop!")
+ (description "@code{Xpenguins} is a vintage application for Unix systems,
+showing penguins running, flying, falling etc. on the desktop, using windows as
+run paths.")
+ (license license:gpl2+)))
+
(define-public nyancat
(package
(name "nyancat")
--
2.43.0
G
G
Greg Hogan wrote on 30 Jan 19:55 +0100
[PATCH v2 2/2] gnu: Add xfishtank.
(address . 62262@debbugs.gnu.org)(name . Sarthak Shah)(address . shahsarthakw@gmail.com)
7acc286f1f6989627668cd4babfe1402f52d34f4.1706640937.git.code@greghogan.com
From: Sarthak Shah <shahsarthakw@gmail.com>

* gnu/packages/toys.scm (xfishtank): New variable.

Change-Id: I490fba2d9ded274266d6376adf67c39bf5c9744a
---
gnu/packages/toys.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 6fdc931ae6..caefce0c68 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -433,6 +433,38 @@ (define-public xpenguins
run paths.")
(license license:gpl2+)))
+(define-public xfishtank
+ (package
+ (name "xfishtank")
+ (version "3.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ratrabbit.nl/downloads/xfishtank/xfishtank-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0jbx41kdpgm3nrnrvfy9znkipd8xq0jj5plavcsjkhkva8ybc0ax"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-install-path
+ (lambda _
+ ;; Install program to bin instead of games.
+ (substitute* "src/Makefile.in"
+ (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+ (string-append prefix "bin"))))))))
+ (inputs
+ (list gtk+ libx11 libxpm libxt libxml2))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://www.ratrabbit.nl/ratrabbit/software/xfishtank/index.html")
+ (synopsis "Let fish swim over your desktop!")
+ (description "@code{Xfishtank} is a well-known vintage application for Unix
+systems, based on the X11 protocol. It shows fish swimming over the desktop.")
+ (license (list license:expat license:gpl3+))))
+
(define-public nyancat
(package
(name "nyancat")
--
2.43.0
S
S
Steve George wrote on 17 Feb 18:12 +0100
[PATCH v3 0/2] Add xfishtank and xpenguins
(address . 62262@debbugs.gnu.org)
cover.1708189137.git.steve@futurile.net
Review:
* Updated xfishtank to latest upstream 3.2.1
* Added Reviewed-by commit trailers (Greg / Steve)
* Applied patches, test installed, linted
* Re-roll to trigger QA build

Sarthak Shah (2):
gnu: Add xpenguins.
gnu: Add xfishtank.


gnu/packages/toys.scm | 69 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 69 insertions(+)


base-commit: 06014750338159a03a6374d7ebdd783c210b3715
--
2.41.0
S
S
Steve George wrote on 17 Feb 18:12 +0100
[PATCH v3 1/2] gnu: Add xpenguins.
(address . 62262@debbugs.gnu.org)
24cac34682dd1fc1599dfd9ba7c8d53f366c634c.1708189137.git.steve@futurile.net
From: Sarthak Shah <shahsarthakw@gmail.com>

* gnu/packages/toys.scm (xpenguins): New variable.

Reviewed-by: Greg Hogan <code@greghogan.com>
Reviewed-by: Steve George <steve@futurile.net>

Change-Id: I6262092da4d51abaca1d6f01ec2e3f27baca7a01
---
gnu/packages/toys.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index c058e70dac9..6fdc931ae66 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Sarthak Shah <shahsarthakw@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -399,6 +400,39 @@ (define-public xsnow
and various scenery elements.")
(license license:gpl3+)))
+(define-public xpenguins
+ (package
+ (name "xpenguins")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-install-path
+ (lambda _
+ ;; Install program to bin instead of games.
+ (substitute* "src/Makefile.in"
+ (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+ (string-append prefix "bin"))))))))
+ (inputs
+ (list gtk+ libx11 libxpm libxt libxml2))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://www.ratrabbit.nl/ratrabbit/software/xpenguins/index.html")
+ (synopsis "Let penguins take over your desktop!")
+ (description "@code{Xpenguins} is a vintage application for Unix systems,
+showing penguins running, flying, falling etc. on the desktop, using windows as
+run paths.")
+ (license license:gpl2+)))
+
(define-public nyancat
(package
(name "nyancat")
--
2.41.0
S
S
Steve George wrote on 17 Feb 18:12 +0100
[PATCH v3 2/2] gnu: Add xfishtank.
(address . 62262@debbugs.gnu.org)
4cf6c8c0f00983e872f89836c3764dd35efae462.1708189137.git.steve@futurile.net
From: Sarthak Shah <shahsarthakw@gmail.com>

* gnu/packages/toys.scm (xfishtank): New variable.

Reviewed-by: Greg Hogan <code@greghogan.com>
Reviewed-by: Steve George <steve@futurile.net>

Change-Id: I490fba2d9ded274266d6376adf67c39bf5c9744a
---
gnu/packages/toys.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 6fdc931ae66..072b6200dad 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -433,6 +433,41 @@ (define-public xpenguins
run paths.")
(license license:gpl2+)))
+(define-public xfishtank
+ (package
+ (name "xfishtank")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.ratrabbit.nl/downloads/xfishtank/xfishtank-"
+ version "~pre1.tar.gz"))
+ ;; version has ~pre1 in it. Guix store does not allow tilde
+ ;; in file names. Save it in the Store using a hyphen
+ (file-name (string-append name "-" version "-pre1.tar.gz"))
+ (sha256
+ (base32 "16i9diawkmar6dhx5xn0mflr2h585gamab6137hvxzgaczx55lwp"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-install-path
+ (lambda _
+ ;; Install program to bin instead of games.
+ (substitute* "src/Makefile.in"
+ (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+ (string-append prefix "bin"))))))))
+ (inputs
+ (list gtk+ libx11 libxpm libxt libxml2))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://www.ratrabbit.nl/ratrabbit/software/xfishtank/index.html")
+ (synopsis "Let fish swim over your desktop!")
+ (description "@code{Xfishtank} is a well-known vintage application for Unix
+systems, that uses the X11 protocol. It shows fish swimming over the desktop.")
+ (license (list license:expat license:gpl3+))))
+
(define-public nyancat
(package
(name "nyancat")
--
2.41.0
S
S
Steve George wrote on 18 Feb 13:25 +0100
Set usertag reviewed-looks-good
(address . 62262@debbugs.gnu.org)
ZdH3Tdb09KUldZ02@t25sg
usertag 62262 reviewed-looks-good
quit
C
C
Clément Lassieur wrote on 20 Feb 01:07 +0100
(name . Steve George)(address . steve@futurile.net)(address . 62262@debbugs.gnu.org)
871q98knh0.fsf@lassieur.org
Hi Steve,

My understanding is that you should write

user guix

before the usertag line, so that it is associated with the 'guix' user.


On Sun, Feb 18 2024, Steve George wrote:

Toggle quote (3 lines)
> usertag 62262 reviewed-looks-good
> quit

Cheers

Clément
N
N
Nicolas Goaziou wrote on 22 Feb 20:48 +0100
Re: [bug#62262] [PATCH v3 0/2] Add xfishtank and xpenguins
(name . Steve George)(address . steve@futurile.net)(address . 62262-done@debbugs.gnu.org)
874je0e0vz.fsf@nicolasgoaziou.fr
Hello,

Steve George <steve@futurile.net> writes:

Toggle quote (5 lines)
> * Updated xfishtank to latest upstream 3.2.1
> * Added Reviewed-by commit trailers (Greg / Steve)
> * Applied patches, test installed, linted
> * Re-roll to trigger QA build

I slightly tweaked the descriptions and applied your patches.

Thank you!

Regards,
--
Nicolas Goaziou
Closed
?