Hi Guix,
This patch adds xfishtank and xpenguins to toys.scm which are programs similar to xsnow by the same author.

* gnu/packages/toys.scm (xpenguins): New variable.
* gnu/packages/toys.scm (xfishtank): New variable.
---
 gnu/packages/toys.scm | 64 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 64 insertions(+)

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 8967c0c25b..16adf6d92a 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -397,6 +397,70 @@ (define-public xsnow
 and various scenery elements.")
     (license license:gpl3+)))
 
+(define-public xpenguins
+  (package
+    (name "xpenguins")
+    (version "3.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-install-path
+           (lambda _
+             ;; Install program to bin instead of games.
+             (substitute* "src/Makefile.in"
+               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+                (string-append prefix "bin")))
+             #t)))))
+    (inputs
+     (list gtk+ libx11 libxpm libxt libxml2))
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://www.ratrabbit.nl/ratrabbit/xpenguins/index.html")
+    (synopsis "Let penguins take over your desktop!")
+    (description "@code{Xpenguins} is a vintage application for Unix systems, showing penguins running, flying, falling etc. on the desktop, using windows as run paths.")
+    (license license:gpl3+)))
+
+(define-public xfishtank
+  (package
+    (name "xfishtank")
+    (version "3.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+              "https://ratrabbit.nl/downloads/xfishtank/xfishtank-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "0jbx41kdpgm3nrnrvfy9znkipd8xq0jj5plavcsjkhkva8ybc0ax"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-install-path
+           (lambda _
+             ;; Install program to bin instead of games.
+             (substitute* "src/Makefile.in"
+               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+                (string-append prefix "bin")))
+             #t)))))
+    (inputs
+     (list gtk+ libx11 libxpm libxt libxml2))
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://www.ratrabbit.nl/ratrabbit/xfishtank")
+    (synopsis "Let fishes swim over your desktop!")
+    (description "@code{Xfishtank} is a well-known vintage application for Unix systems, based on the X11 protocol. It shows fishes swimming over the desktop.")
+    (license license:gpl3+)))
+
 (define-public nyancat
   (package
     (name "nyancat")
--
2.39.1