[PATCH 0/1] gnu: Add atftp.

  • Done
  • quality assurance status badge
Details
3 participants
  • Felix Lechner
  • Ludovic Courtès
  • Sergey Trofimov
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 13 Mar 2023 05:41
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
cover.1678682353.git.felix.lechner@lease-up.com
Hi,

I am not sure whether the mirror:// URL is right. It works, but there are two
lint warnings:

gnu/packages/networking.scm:2946:15: atftp@0.8.0: URI https://www.gnu.org/software/atftp/not reachable: 404 ("Not Found")
gnu/packages/networking.scm:2921:12: atftp@0.8.0: source not archived on Software Heritage and missing from the Disarchive database

Kind regards,
Felix Lechner

* * *

Felix Lechner (1):
gnu: Add atftp.

gnu/packages/networking.scm | 41 +++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)


base-commit: 9584b1daa687d1212550841d1c5f62e7ffa44ffc
--
2.39.1
F
F
Felix Lechner wrote on 13 Mar 2023 05:42
[PATCH 1/1] gnu: Add atftp.
(address . 62156@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
09a2e5dc2e5e0f9cf65816ee6631fb617b5e8896.1678682353.git.felix.lechner@lease-up.com
* gnu/packages/networking.scm (atftp): New variable.
---
gnu/packages/networking.scm | 41 +++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b6cbd8e80a..bae7848632 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2914,6 +2914,47 @@ (define-public speedtest-cli
speedtest.net.")
(license license:asl2.0)))
+(define-public atftp
+ (package
+ (name "atftp")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05pk6x70wsad1fjnx4l2a7f859dn5ifqwng582mrw3v7qy4s0anz"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ (invoke "autoreconf" "-vif"))))))
+ (native-inputs
+ (list autoconf
+ automake
+ perl
+ pkg-config))
+ (inputs (list
+ pcre2
+ procps
+ readline
+ tcp-wrappers))
+ (home-page "https://www.gnu.org/software/atftp/")
+ (synopsis "Advanced TFTP server and client")
+ (description
+ "Multi-threaded TFTP server that implements all options, including all
+extensions, as specified in RFC 1350, RFC 2090, RFC 2347, RFC 2348, RFC 2349
+and RFC7440. Atftpd also supports a multicast protocol known as mtftp, which
+was defined in the PXE specification.
+
+The server is socket activated by default but supports being started from
+inetd(8) as well as in daemon mode.")
+ (license license:gpl2)))
+
(define-public tftp-hpa
(package
(name "tftp-hpa")
--
2.39.1
F
F
Felix Lechner wrote on 20 Mar 2023 00:03
[PATCH v2] gnu: Add atftp.
(address . 62156@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
b423186f49dfdfff336d4ff8058fe7190c132a73.1679266763.git.felix.lechner@lease-up.com
* gnu/packages/networking.scm (atftp): New variable.

The new URL still produces a lint warning. A user on IRC surmised that
sf.net may filter by user agent:

atftp@0.8.0: URI https://git.code.sf.net/p/atftp/codenot reachable:
404 ("Not Found")

The same user states that Git makes this request:

GET /p/atftp/code/info/refs?service=git-upload-pack HTTP/1.1

Thanks to Josselin Poiret and Bruno Victal for their generous and detailed
reviews of this item!
---
gnu/packages/networking.scm | 43 +++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3fac05c411..7f843214fb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2916,6 +2916,49 @@ (define-public speedtest-cli
speedtest.net.")
(license license:asl2.0)))
+(define-public atftp
+ (package
+ (name "atftp")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/atftp/code")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "019qrh2wpvr577ksvs3s82q6kiqm5i6869aj7qba326b59lhkxrc"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ (invoke "autoreconf" "-vif"))))))
+ (native-inputs
+ (list autoconf
+ automake
+ perl
+ pkg-config))
+ (inputs
+ (list pcre2
+ procps
+ readline
+ tcp-wrappers))
+ (home-page "https://sourceforge.net/projects/atftp/")
+ (synopsis "Advanced TFTP server and client")
+ (description
+ "Multi-threaded TFTP server that implements all options, including all
+extensions, as specified in RFC 1350, RFC 2090, RFC 2347, RFC 2348, RFC 2349
+and RFC7440. Atftpd also supports a multicast protocol known as mtftp, which
+was defined in the PXE specification.
+
+The server is socket activated by default but supports being started from
+inetd(8) as well as in daemon mode.")
+ (license license:gpl2+)))
+
(define-public tftp-hpa
(package
(name "tftp-hpa")

base-commit: f9702aa9fdfded5c62da43197f8cea5eeba30803
--
2.39.1
S
F
F
Felix Lechner wrote on 20 Mar 2023 17:57
[PATCH v3 1/2] gnu: Add atftp.
(address . 62156@debbugs.gnu.org)
b423186f49dfdfff336d4ff8058fe7190c132a73.1679331429.git.felix.lechner@lease-up.com
* gnu/packages/networking.scm (atftp): New variable.

Thanks to Josselin Poiret and Bruno Victal for their generous and detailed
reviews of this item!
---
gnu/packages/networking.scm | 43 +++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3fac05c411..7f843214fb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2916,6 +2916,49 @@ (define-public speedtest-cli
speedtest.net.")
(license license:asl2.0)))
+(define-public atftp
+ (package
+ (name "atftp")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/atftp/code")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "019qrh2wpvr577ksvs3s82q6kiqm5i6869aj7qba326b59lhkxrc"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ (invoke "autoreconf" "-vif"))))))
+ (native-inputs
+ (list autoconf
+ automake
+ perl
+ pkg-config))
+ (inputs
+ (list pcre2
+ procps
+ readline
+ tcp-wrappers))
+ (home-page "https://sourceforge.net/projects/atftp/")
+ (synopsis "Advanced TFTP server and client")
+ (description
+ "Multi-threaded TFTP server that implements all options, including all
+extensions, as specified in RFC 1350, RFC 2090, RFC 2347, RFC 2348, RFC 2349
+and RFC7440. Atftpd also supports a multicast protocol known as mtftp, which
+was defined in the PXE specification.
+
+The server is socket activated by default but supports being started from
+inetd(8) as well as in daemon mode.")
+ (license license:gpl2+)))
+
(define-public tftp-hpa
(package
(name "tftp-hpa")

base-commit: f9702aa9fdfded5c62da43197f8cea5eeba30803
--
2.39.1
F
F
Felix Lechner wrote on 20 Mar 2023 17:57
[PATCH v3 2/2] lint: Append "/info/refs" to git-reference-url.
(address . 62156@debbugs.gnu.org)
fb004d22cf46a6eddecca4ac01c7d54cf5da649e.1679331429.git.felix.lechner@lease-up.com
For the atftp package added in the preceeding commit, lint produced this
warning:

gnu/packages/networking.scm:2924:5: atftp@0.8.0:
404 ("Not Found")

Thanks to Sergey Trofimov for suggesting a fix! [1]


It was implemented here, and the warning disappeared.

* guix/lint.scm (check-source): Append "/info/refs" to git-reference-url.

Co-authored-by: Sergey Trofimov <sarg@sarg.org.ru>
---
guix/lint.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index a1a27873d9..394d68c472 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -1224,7 +1224,9 @@ (define (warnings-for-uris uris)
'())))
((git-reference? (origin-uri origin))
(warnings-for-uris
- (list (string->uri (git-reference-url (origin-uri origin))))))
+ (list (string->uri (string-append
+ (git-reference-url (origin-uri origin))
+ "/info/refs")))))
((or (svn-reference? (origin-uri origin))
(svn-multi-reference? (origin-uri origin)))
(let ((uri (svn-reference-uri-with-userinfo (origin-uri origin))))
--
2.39.1
F
F
Felix Lechner wrote on 21 Mar 2023 05:25
[PATCH v4 1/2] gnu: Add atftp.
(address . 62156@debbugs.gnu.org)
b423186f49dfdfff336d4ff8058fe7190c132a73.1679372740.git.felix.lechner@lease-up.com
* gnu/packages/networking.scm (atftp): New variable.

Thanks to Josselin Poiret and Bruno Victal for their generous and detailed
reviews of this item!
---
gnu/packages/networking.scm | 43 +++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3fac05c411..7f843214fb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2916,6 +2916,49 @@ (define-public speedtest-cli
speedtest.net.")
(license license:asl2.0)))
+(define-public atftp
+ (package
+ (name "atftp")
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/atftp/code")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "019qrh2wpvr577ksvs3s82q6kiqm5i6869aj7qba326b59lhkxrc"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ (invoke "autoreconf" "-vif"))))))
+ (native-inputs
+ (list autoconf
+ automake
+ perl
+ pkg-config))
+ (inputs
+ (list pcre2
+ procps
+ readline
+ tcp-wrappers))
+ (home-page "https://sourceforge.net/projects/atftp/")
+ (synopsis "Advanced TFTP server and client")
+ (description
+ "Multi-threaded TFTP server that implements all options, including all
+extensions, as specified in RFC 1350, RFC 2090, RFC 2347, RFC 2348, RFC 2349
+and RFC7440. Atftpd also supports a multicast protocol known as mtftp, which
+was defined in the PXE specification.
+
+The server is socket activated by default but supports being started from
+inetd(8) as well as in daemon mode.")
+ (license license:gpl2+)))
+
(define-public tftp-hpa
(package
(name "tftp-hpa")

base-commit: f9702aa9fdfded5c62da43197f8cea5eeba30803
--
2.39.1
F
F
Felix Lechner wrote on 21 Mar 2023 05:25
[PATCH v4 2/2] lint: Append "/info/refs" to git-reference-url.
(address . 62156@debbugs.gnu.org)
52c5a50ef62af8c4331415aac52759362c89766d.1679372740.git.felix.lechner@lease-up.com
For the atftp package added in the preceeding commit, lint produced this
warning:

gnu/packages/networking.scm:2924:5: atftp@0.8.0:
404 ("Not Found")

Thanks to Sergey Trofimov for suggesting a fix! [1]


It was implemented here, and the warning disappeared.

* guix/lint.scm (check-source): Append "/info/refs" to git-reference-url.

Co-authored-by: Sergey Trofimov <sarg@sarg.org.ru>
---
guix/lint.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/guix/lint.scm b/guix/lint.scm
index a1a27873d9..8d0887739d 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -1224,7 +1224,14 @@ (define (warnings-for-uris uris)
'())))
((git-reference? (origin-uri origin))
(warnings-for-uris
- (list (string->uri (git-reference-url (origin-uri origin))))))
+ ;; for atftp, lint produced a warning:
+ ;; gnu/packages/networking.scm:2924:5: atftp@0.8.0:
+ ;; URI https://git.code.sf.net/p/atftp/code not reachable:
+ ;; 404 ("Not Found")
+ ;; fix from here: https://issues.guix.gnu.org/62156#3
+ (list (string->uri (string-append
+ (git-reference-url (origin-uri origin))
+ "/info/refs")))))
((or (svn-reference? (origin-uri origin))
(svn-multi-reference? (origin-uri origin)))
(let ((uri (svn-reference-uri-with-userinfo (origin-uri origin))))
--
2.39.1
L
L
Ludovic Courtès wrote on 27 Mar 2023 18:49
Re: bug#62156: [PATCH 0/1] gnu: Add atftp.
(name . Felix Lechner)(address . felix.lechner@lease-up.com)
87pm8uf8c0.fsf_-_@gnu.org
Hi,

Felix Lechner <felix.lechner@lease-up.com> skribis:

Toggle quote (5 lines)
> * gnu/packages/networking.scm (atftp): New variable.
>
> Thanks to Josselin Poiret and Bruno Victal for their generous and detailed
> reviews of this item!

I tweaked the description (to start with a full sentence) and passed it
through ‘guix style’.

Toggle quote (17 lines)
> For the atftp package added in the preceeding commit, lint produced this
> warning:
>
> gnu/packages/networking.scm:2924:5: atftp@0.8.0:
> URI https://git.code.sf.net/p/atftp/code not reachable:
> 404 ("Not Found")
>
> Thanks to Sergey Trofimov for suggesting a fix! [1]
>
> [1] https://issues.guix.gnu.org/62156#3
>
> It was implemented here, and the warning disappeared.
>
> * guix/lint.scm (check-source): Append "/info/refs" to git-reference-url.
>
> Co-authored-by: Sergey Trofimov <sarg@sarg.org.ru>

Nice. I adjusted ‘tests/lint.scm’ accordingly.

Applied both; thank you, and thanks to the reviewers!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 62156@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62156
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch