[PATCH 0/8] fix some packages cross-compile

  • Done
  • quality assurance status badge
Details
2 participants
  • Z572
  • Efraim Flashner
Owner
unassigned
Submitted by
Z572
Severity
normal
Z
(address . guix-patches@gnu.org)
tencent_28F759357FC83A91E5B5254BB5D29B3AA908@qq.com
Hello, guix.

This patchset fix some package cross-compile.

Zheng Junjie (8):
gnu: xcb-util-wm: fix riscv64 cross-compile.
gnu: libxv: fix riscv64 cross-compile.
gnu: libxtst: fix riscv64 cross-compile.
gnu: mtdev: fix riscv64 cross-compile.
gnu: gobject-introspection: fix riscv64 cross-compile.
gnu: gsettings-desktop-schemas: fix cross-compile.
gnu: libotf: fix cross-compile.
gnu: librsvg-2.40: fix cross-compile.

gnu/packages/fontutils.scm | 17 ++++++++++-
gnu/packages/glib.scm | 5 +++-
gnu/packages/gnome.scm | 7 +++--
gnu/packages/xdisorg.scm | 20 +++++++++++--
gnu/packages/xorg.scm | 59 ++++++++++++++++++++++++++++++++++----
5 files changed, 95 insertions(+), 13 deletions(-)


base-commit: c0e9ddfa290056f137ee21a53be6be4fbb8586ea
--
2.39.1
Z
[PATCH 1/8] gnu: xcb-util-wm: fix riscv64 cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_6EA2DCBF84AB367D1323D53CEBE82F530705@qq.com
* gnu/packages/xorg.scm (xcb-util-wm): fix riscv64 cross-compile.
[arguments]: add update-config-scripts phases when target is riscv64.
[native-inputs]: add CONFIG when target is riscv64.
---
gnu/packages/xorg.scm | 20 ++++++++++++++++++--
1 file changed, 18 insertions(+), 2 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index a43809e3cb..32be732eef 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5792,11 +5792,27 @@ (define-public xcb-util-wm
"0gra7hfyxajic4mjd63cpqvd20si53j1q3rbdlkqkahfciwq3gr8"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '("--disable-static")
+ ,@(if (target-riscv64?)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.guess and config.sub.
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))))
+ '())))
(propagated-inputs
(list libxcb))
(native-inputs
- (list m4 pkg-config))
+ (append (if (target-riscv64?)
+ (list config)
+ '())
+ (list m4 pkg-config)))
(home-page "https://cgit.freedesktop.org/xcb/util-wm/")
(synopsis "Client and window-manager helpers for ICCCM and EWMH")
(description
--
2.39.1
Z
[PATCH 3/8] gnu: libxtst: fix riscv64 cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_4654A90F590F7F003AE6E5E02507B5629B08@qq.com
* gnu/packages/xorg.scm(libxtst): fix riscv64 cross-compile
[arguments]: when target is riscv64, add phase to update config.{guess,sub}
[native-inputs]: when target is riscv64, add config.
---
gnu/packages/xorg.scm | 19 +++++++++++++++++--
1 file changed, 17 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2b6f9fa369..2cc1523e3e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4658,13 +4658,28 @@ (define-public libxtst
"012jpyj7xfm653a9jcfqbzxyywdmwb2b5wr1dwylx14f3f54jma6"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '("--disable-static")
+ ,@(if (and (%current-target-system)
+ (target-riscv64?))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config
+ (lambda* (#:key native-inputs #:allow-other-keys)
+ (install-file
+ (search-input-file native-inputs "/bin/config.sub") ".")
+ (install-file
+ (search-input-file native-inputs "/bin/config.guess") ".")))))
+ '())))
(propagated-inputs
(list libxi xorgproto))
(inputs
(list libx11))
(native-inputs
- (list pkg-config))
+ `(,@(if (and (%current-target-system)
+ (target-riscv64?))
+ (list config)
+ '())
+ ,pkg-config))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg library for Xtest and Record extensions")
(description
--
2.39.1
Z
[PATCH 5/8] gnu: gobject-introspection: fix riscv64 cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_1F134AC46A83360F52EBB21CFEDE74A2CB09@qq.com
* gnu/packages/glib.scm(gobject-introspection): fix riscv64 cross-compile
[native-inputs]: when (%current-target-system) is true, add python.
---
gnu/packages/glib.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index f85d5e3225..319a0ca2c1 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -573,7 +573,10 @@ (define gobject-introspection
"/_giscanner"))))
#~()))))
(native-inputs
- `(("glib" ,glib "bin")
+ `(,@(if (%current-target-system)
+ `(("python" ,python))
+ '())
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)
("bison" ,bison)
("flex" ,flex)))
--
2.39.1
Z
[PATCH 4/8] gnu: mtdev: fix riscv64 cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_EE34E5AE2576B5BE9B4AA9CE596C7F7E3A08@qq.com
* gnu/packages/xdisorg.scm(mtdev): fix riscv64 cross-compile
[arguments]: when target is riscv64, add phase to update config.{guess,sub}.
[native-inputs]: when target is riscv64, add config.
---
gnu/packages/xdisorg.scm | 20 ++++++++++++++++++--
1 file changed, 18 insertions(+), 2 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 2ebeb4e013..21bc368538 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -41,7 +41,7 @@
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021, 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
@@ -763,7 +763,23 @@ (define-public mtdev
(base32
"1q700h9dqcm3zl6c3gj0qxxjcx6ibw2c51wjijydhwdcm26v5mqm"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--disable-static")))
+ (arguments `(#:configure-flags '("--disable-static")
+ ,@(if (target-riscv64?)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.guess and config.sub.
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "./config-aux"))
+ '("config.guess" "config.sub"))))))
+ '())))
+ (native-inputs (if (target-riscv64?)
+ (list config)
+ '()))
(home-page "http://bitmath.org/code/mtdev/")
(synopsis "Multitouch protocol translation library")
(description "Mtdev is a stand-alone library which transforms all
--
2.39.1
Z
[PATCH 2/8] gnu: libxv: fix riscv64 cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_D9FD5F8E4E40795F8974EDC666486A6E9606@qq.com
* gnu/packages/xorg.scm(libxv): fix riscv64 cross-compile
[arguments]: when target is riscv64, add phase to update config.{guess,sub}
[native-inputs]: when target is riscv64, add config.
---
gnu/packages/xorg.scm | 20 ++++++++++++++++++--
1 file changed, 18 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 32be732eef..2b6f9fa369 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4696,13 +4696,29 @@ (define-public libxv
"125hn06bd3d8y97hm2pbf5j55gg4r2hpd3ifad651i4sr7m16v6j"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '(,@(malloc0-flags) "--disable-static")))
+ `(#:configure-flags '(,@(malloc0-flags) "--disable-static")
+ ,@(if (target-riscv64?)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.guess and config.sub.
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))))
+ '())))
(propagated-inputs
(list xorgproto))
(inputs
(list libxext libx11))
(native-inputs
- (list pkg-config))
+ (append (if (target-riscv64?)
+ (list config)
+ '())
+ (list pkg-config)))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg XVideo Extension library")
(description "Library for the X Video Extension to the X11 protocol.")
--
2.39.1
Z
[PATCH 6/8] gnu: gsettings-desktop-schemas: fix cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_3EF2EB12B4DA83CDA954C7ACB1BF161DCF07@qq.com
* gnu/packages/gnome.scm(gsettings-desktop-schemas): fix cross-compile.
[inputs]: add gobject-introspection.
---
gnu/packages/gnome.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4698b883af..1c818b01b4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2755,7 +2755,7 @@ (define-public gsettings-desktop-schemas
"/share/backgrounds/gnome"))
;; Do not reference fonts, that may not exist.
(("'Source Code Pro 10'") "'Monospace 11'")))))))
- (inputs (list glib gnome-backgrounds))
+ (inputs (list glib gnome-backgrounds gobject-introspection))
(native-inputs (list gettext-minimal
`(,glib "bin") ;glib-compile-schemas, etc.
gobject-introspection
--
2.39.1
Z
[PATCH 7/8] gnu: libotf: fix cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_7AFC01EB8C947B94A8D4526FDAA4B665DD0A@qq.com
* gnu/packages/fontutils.scm(libotf): fix cross-compile.
[native-inputs]:
add freetype, when cross-compile, add libtool, autoconf automake.
[arguments]: when cross-compile, add phase to fix rpl_malloc undefined reference
---
gnu/packages/fontutils.scm | 17 ++++++++++++++++-
1 file changed, 16 insertions(+), 1 deletion(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 72621cc006..d451f5e504 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -1392,7 +1392,22 @@ (define-public libotf
(base32 "0sq6g3xaxw388akws6qrllp3kp2sxgk2dv4j79k6mm52rnihrnv8"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config))
+ (append (if (%current-target-system)
+ (list libtool
+ autoconf automake)
+ '())
+ (list pkg-config freetype)))
+ (arguments (if (%current-target-system)
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-rpl_malloc
+ (lambda _
+ (substitute* "configure.ac"
+ (("AC_FUNC_MALLOC")
+ ""))
+ (invoke "sh" "autogen.sh")))))
+ '()))
(propagated-inputs
(list freetype))
(home-page "https://www.nongnu.org/m17n/")
--
2.39.1
Z
[PATCH 8/8] gnu: librsvg-2.40: fix cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_98593D7FD93A4FE5EC253EB5F89B62A9AA08@qq.com
* gnu/packages/gnome.scm(librsvg-2.40): fix cross-compile.
[native-inputs]: add gdk-pixbuf.
[inputs]: add gobject-introspection.
---
gnu/packages/gnome.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1c818b01b4..3705909742 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3793,11 +3793,12 @@ (define-public librsvg-2.40
"bugs/340047.svg"
"bugs/749415.svg"))))))))
(native-inputs
- (list pkg-config
+ (list gdk-pixbuf
+ pkg-config
`(,glib "bin") ; glib-mkenums, etc.
gobject-introspection)) ; g-ir-compiler, etc.
(inputs
- (list pango libcroco libxml2))
+ (list pango libcroco libxml2 gobject-introspection))
(propagated-inputs
;; librsvg-2.0.pc refers to all of that.
(list cairo gdk-pixbuf glib))
--
2.39.1
Z
[PATCH] gnu: libxtst: fix riscv64 cross-compile.
(address . 61865@debbugs.gnu.org)
tencent_1FB884A0367A1335153AABE7EF4147A17C05@qq.com
* gnu/packages/xorg.scm(libxtst): fix riscv64 cross-compile
[arguments]: when target is riscv64, add phase to update config.{guess,sub}
[native-inputs]: when target is riscv64, add config.
---
gnu/packages/xorg.scm | 21 ++++++++++++++++++---
1 file changed, 18 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 55c9b53e1d..7d5e7c6f9c 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4509,13 +4509,28 @@ (define-public libxtst
"012jpyj7xfm653a9jcfqbzxyywdmwb2b5wr1dwylx14f3f54jma6"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '("--disable-static")
+ ,@(if (target-riscv64?)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "."))
+ '("config.guess" "config.sub"))))))
+ '())))
(propagated-inputs
(list libxi xorgproto))
(inputs
- (list libx11))
+ (list libx11))
(native-inputs
- (list pkg-config))
+ `(,@(if (target-riscv64?)
+ (list config)
+ '())
+ ,pkg-config))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg library for Xtest and Record extensions")
(description
--
2.39.2
E
E
Efraim Flashner wrote on 4 Jun 2023 14:19
(name . Z572)(address . 873216071@qq.com)(address . 61865@debbugs.gnu.org)
ZHyBYeuLPyFeYdij@3900XT
This patch I changed (target-riscv64?) to
(and (target-riscv64?)
(%current-target-system))

This way it only occurs when cross compiling.

On Thu, Mar 30, 2023 at 10:46:03PM +0800, Z572 via Guix-patches via wrote:
Toggle quote (50 lines)
> * gnu/packages/xorg.scm(libxtst): fix riscv64 cross-compile
> [arguments]: when target is riscv64, add phase to update config.{guess,sub}
> [native-inputs]: when target is riscv64, add config.
> ---
> gnu/packages/xorg.scm | 21 ++++++++++++++++++---
> 1 file changed, 18 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
> index 55c9b53e1d..7d5e7c6f9c 100644
> --- a/gnu/packages/xorg.scm
> +++ b/gnu/packages/xorg.scm
> @@ -4509,13 +4509,28 @@ (define-public libxtst
> "012jpyj7xfm653a9jcfqbzxyywdmwb2b5wr1dwylx14f3f54jma6"))))
> (build-system gnu-build-system)
> (arguments
> - '(#:configure-flags '("--disable-static")))
> + `(#:configure-flags '("--disable-static")
> + ,@(if (target-riscv64?)
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'update-config
> + (lambda* (#:key native-inputs inputs #:allow-other-keys)
> + (for-each (lambda (file)
> + (install-file
> + (search-input-file
> + (or native-inputs inputs)
> + (string-append "/bin/" file)) "."))
> + '("config.guess" "config.sub"))))))
> + '())))
> (propagated-inputs
> (list libxi xorgproto))
> (inputs
> - (list libx11))
> + (list libx11))
> (native-inputs
> - (list pkg-config))
> + `(,@(if (target-riscv64?)
> + (list config)
> + '())
> + ,pkg-config))
> (home-page "https://www.x.org/wiki/")
> (synopsis "Xorg library for Xtest and Record extensions")
> (description
> --
> 2.39.2
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR8gV4ACgkQQarn3Mo9
g1HaOBAAkep3yfyT51y0Jp4sh1iagtn6WALE8lhtC1aOedyKj0prn0HM2YAVgPaS
gCk508van7yDyetXtZOdTwVrNaAyZ/9dZ/sNpIszF9rac6bU8JPaGwFad4xpctnQ
KGrrZKEDKY2+G0f4qC6BYeCcXGW8cUohyfkJ9SOHq6yOTdCjUJVXjfAPb5H9Tfoe
b8QOA8NPZi2ppd2dPz+xp+/3YDA/p4G0GbQ2L61aheO0dW0WuP6tuHA0SYZkkh/2
UcfLf7fpxRLWNQgl5AGXYtnCO/RZc7P3m5kOIDhF3tzQ3xzurWskBUQ2RMw0hSmk
HMLU81Mm2Nowlo35YBrq5Ipl/4ri2gNFp9mSZdVyYtcSqa29KlxuYSo9XKLNERpm
A9KbcTo0muWj+xXGi6xXrzvu383bxApXL3Hjc5UZ8Tua615QtEXI33ra8MiNsWzO
Q35vMZpq46vjdE+xYGuJvhGMVu1/AJ04sDHlztez0hfkLmCXG2zywMIXTpgTjYMy
O/z24siaBGfQSS9zPTwKytxLwJjl8ttM4vd/oojTbxUv7X5swseu3gt9cdzUR9sk
AcJTypBvAuWgVgw6ZA9szF1ANVVL6LMsQE74o4tAh9jMVXJxS7QQrYfPuQtMYnTa
T8H/yghFw1X1ZGKuPD75FRbPaJ3TLsxsEK7F3Jiw8j4hilUw7YA=
=DhkY
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 4 Jun 2023 14:19
Re: [bug#61865] [PATCH 2/8] gnu: libxv: fix riscv64 cross-compile.
(name . Z572)(address . 873216071@qq.com)(address . 61865@debbugs.gnu.org)
ZHyBaLY23OTdabMu@3900XT
This patch is no longer necessary after updating libxv to a newer
version.

On Tue, Feb 28, 2023 at 04:33:34PM +0800, Z572 via Guix-patches via wrote:
Toggle quote (50 lines)
> * gnu/packages/xorg.scm(libxv): fix riscv64 cross-compile
> [arguments]: when target is riscv64, add phase to update config.{guess,sub}
> [native-inputs]: when target is riscv64, add config.
> ---
> gnu/packages/xorg.scm | 20 ++++++++++++++++++--
> 1 file changed, 18 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
> index 32be732eef..2b6f9fa369 100644
> --- a/gnu/packages/xorg.scm
> +++ b/gnu/packages/xorg.scm
> @@ -4696,13 +4696,29 @@ (define-public libxv
> "125hn06bd3d8y97hm2pbf5j55gg4r2hpd3ifad651i4sr7m16v6j"))))
> (build-system gnu-build-system)
> (arguments
> - `(#:configure-flags '(,@(malloc0-flags) "--disable-static")))
> + `(#:configure-flags '(,@(malloc0-flags) "--disable-static")
> + ,@(if (target-riscv64?)
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'update-config-scripts
> + (lambda* (#:key inputs native-inputs #:allow-other-keys)
> + ;; Replace outdated config.guess and config.sub.
> + (for-each (lambda (file)
> + (install-file
> + (search-input-file
> + (or native-inputs inputs)
> + (string-append "/bin/" file)) "."))
> + '("config.guess" "config.sub"))))))
> + '())))
> (propagated-inputs
> (list xorgproto))
> (inputs
> (list libxext libx11))
> (native-inputs
> - (list pkg-config))
> + (append (if (target-riscv64?)
> + (list config)
> + '())
> + (list pkg-config)))
> (home-page "https://www.x.org/wiki/")
> (synopsis "Xorg XVideo Extension library")
> (description "Library for the X Video Extension to the X11 protocol.")
> --
> 2.39.1
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR8gWgACgkQQarn3Mo9
g1FQgw//T2ESeo1qUKR1xBk9IdGp4ovQb9dGQM0xUehu8Cb5KZz/mHEw8waV3dFX
XSnbd9PLr9F4gl+xMD4FS/XNDVwKui2ZTIQRBI51ichI3VhlqAKSiiBn5gEIZ3hA
L0WFX3yKtHG3nXNgYvDKXOZr6f5AkFu2Q4fz2VW/Girqsmm982OJbz341sCsffyU
06SNDZvpl9+Txw9Yx4CSQUohcaDU/0r0jVif4sSsWnLvW8g4AkbEOJ40QAFvjMxG
Abj/6mZT5cng+4HrPhqPL7dy9iP5Fl9IyJ+G1SC/b4tbvQLB3WJS5SzTtQLkoOOK
2MieV7lErKCzcjrtYCNCbRWOF8brMs6/hIB4gP0f9PNORHUWge25MzIIArHRE1Yr
6YoxtKdKQcpmOS3udQseSSAbDf+3BKx0+dirJvVUfgqaGZwJMgO2X085Hl9tKgS2
nLZG8pnCPV1FUftU3ByFq1hKN77CgbXdOIWB+0o/ZdzmMOq1Sm9R0FnBuduYh/+v
4kf0gtPcyHXh9O40BVFrdto+HQK348OtOtr2KqUIKaTsStGaT/h1AHPJQuXb/2b9
1XE2WjpWn88xSYKuPHFMFCAFlSnlnnXnWMNP3pwMidr98aUgKOWjWPrVytZ0NyMs
H1aDG9pr90bFW8th6PYoWjb9EsZJpyA48N91XvbDlR5TJIJrk7Q=
=ovAF
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 4 Jun 2023 14:19
Re: [bug#61865] [PATCH 7/8] gnu: libotf: fix cross-compile.
(name . Z572)(address . 873216071@qq.com)(address . 61865@debbugs.gnu.org)
ZHyBb1785lU7gy0G@3900XT
This one I didn't apply. I don't believe adding freetype as a
native-input is correct but I could see adding it as an input. In the
end libotf links to freetype, and we don't want it to link to the one in
native-inputs.

I don't think the phase is the correct way to do this. I didn't see any
error related to it when I was building it before applying the patch,
and I made it pretty far after overriding the location of
freetype-config.

On Tue, Feb 28, 2023 at 04:33:39PM +0800, Z572 via Guix-patches via wrote:
Toggle quote (43 lines)
> * gnu/packages/fontutils.scm(libotf): fix cross-compile.
> [native-inputs]:
> add freetype, when cross-compile, add libtool, autoconf automake.
> [arguments]: when cross-compile, add phase to fix rpl_malloc undefined reference
> ---
> gnu/packages/fontutils.scm | 17 ++++++++++++++++-
> 1 file changed, 16 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
> index 72621cc006..d451f5e504 100644
> --- a/gnu/packages/fontutils.scm
> +++ b/gnu/packages/fontutils.scm
> @@ -1392,7 +1392,22 @@ (define-public libotf
> (base32 "0sq6g3xaxw388akws6qrllp3kp2sxgk2dv4j79k6mm52rnihrnv8"))))
> (build-system gnu-build-system)
> (native-inputs
> - (list pkg-config))
> + (append (if (%current-target-system)
> + (list libtool
> + autoconf automake)
> + '())
> + (list pkg-config freetype)))
> + (arguments (if (%current-target-system)
> + (list
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'fix-rpl_malloc
> + (lambda _
> + (substitute* "configure.ac"
> + (("AC_FUNC_MALLOC")
> + ""))
> + (invoke "sh" "autogen.sh")))))
> + '()))
> (propagated-inputs
> (list freetype))
> (home-page "https://www.nongnu.org/m17n/")
> --
> 2.39.1
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR8gW8ACgkQQarn3Mo9
g1H0pQ//aIcDPNn7ETK8LQHu2/LboJOSAJbdoPYMW9WrYusIc4NRzKzseniSPezu
vHhI4H4Cglmm7T7JH2rMtfCNeXHlr2Cpe2oZ2XzGQX851OwFdM5ZWbJKBQskztfV
Xj87o03mtrifiWSqJ41gesI9gDG98+5tWCjW8NOeXBRPaWt1FPUYQsDMHoQ7f2Am
No969qhohMz4+5mcBbJEOjWkOkBhjLYH+mFDboiN5xKjOhYczvZGPMiCSjty3go0
B7MJRVw0OnrGfhxFbKXHj0rM28cbGR072fttNJbW2ZIZkELTrvrc/ffzKPgYrpdd
kZIGj2lS+ganzH1QNp1uwx+/pjdo+mmJGGRO+TSIQ4wUm/+b8PnOl/BeslQ5OT9P
1o7aNSGV4jJBL7gMCQ7987bd5aFz3kbkdn6zjyk+aH7XNb/mZjpyD0hryqOUxzlr
uY6jPB6gppCjj3hsmSIgeOItD6HB7akfNlefBX6k+uOL21YFF/WFT47crpOT//GI
CvvtHjD/YPacDs7xnt9zq0LH3SoEmqIR4/p/P/ofDNA7yZaEjswJjLYQ8Zlr/mA5
J+MSoBERx55r1t/Rp4v0vSQUeYmieeUYj6Z8UorkaWz9LEbGhnqayGega44aE77r
uLLPGc+wrP5HY80MC7FXTfC0W6CN7r0AimMnERdElNGRpPEgrO4=
=JCkm
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 4 Jun 2023 14:20
Re: [bug#61865] [PATCH 8/8] gnu: librsvg-2.40: fix cross-compile.
(name . Z572)(address . 873216071@qq.com)(address . 61865@debbugs.gnu.org)
ZHyBdQZIgQCcAFU2@3900XT
I didn't apply this patch. I wasn't able to cross-compile some of the
packages which came before this package to see where it failed when
cross-compiling.

On Tue, Feb 28, 2023 at 04:33:40PM +0800, Z572 via Guix-patches via wrote:
Toggle quote (33 lines)
> * gnu/packages/gnome.scm(librsvg-2.40): fix cross-compile.
> [native-inputs]: add gdk-pixbuf.
> [inputs]: add gobject-introspection.
> ---
> gnu/packages/gnome.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 1c818b01b4..3705909742 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -3793,11 +3793,12 @@ (define-public librsvg-2.40
> "bugs/340047.svg"
> "bugs/749415.svg"))))))))
> (native-inputs
> - (list pkg-config
> + (list gdk-pixbuf
> + pkg-config
> `(,glib "bin") ; glib-mkenums, etc.
> gobject-introspection)) ; g-ir-compiler, etc.
> (inputs
> - (list pango libcroco libxml2))
> + (list pango libcroco libxml2 gobject-introspection))
> (propagated-inputs
> ;; librsvg-2.0.pc refers to all of that.
> (list cairo gdk-pixbuf glib))
> --
> 2.39.1
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR8gXUACgkQQarn3Mo9
g1E7ow//To0WM/6weIBmt110rcqNfu6y95hii6X/HyncwVryXnL3PRA3IXrWMUnC
GG2WU7CgbhJfLX0IAiK4iXY6Y47ASOVBpUKOgqrLU3xpIFwBujXcV8GnLIwiUNWg
ivdycXQgwx2e6uUt2Ai3sKtsuRf567YnwZvnIGsipEfNLLUKrbm0YgdT5th76YTq
Yo41ga1elZUDfeI3y89zOX3+bQHyirqKX7Le949KkfidYkVhgEQkmAEDY3URtvJL
Fl5IVQJvGfBYk4G+ouaOvu4Tbif0ruNUg7+U24fl6R5+pBfXKWoVstXnm1bJEPhC
ryAqzkZzM56IRdqwdYi5FR2DR5gXN3xU3D8qnEzvBSwWHoEmknyunTmTep+q9ef1
d/vKb2F0/S3/o/8N392T/16uCBcN4zIb5H7ZKsmssOjP2E4qHZ8jri63poTSqcFV
HsOaRMsOmTlXX1ie+sG1QCV7PxXo5IBv5IYc+WRodBGUyhhsEANEBKva0o892iGm
DJJTl2gp9wUFujbJNxFGjGrviVXv6P/pZQqPErUmM5JPKCLMjzcGl8rQJk4Q0Mr4
CZcpabgVhfSQPRc9+ZBw17eiL/798CK4Ur7MfWngKQ9LjQhHI0LfYQyzLeGGwP97
SbTRLnxXV1ponccLzBhBMBkJObMykDLGBoWSAvxFobz/Tug/o4Y=
=PHnM
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 4 Jun 2023 14:20
Re: [bug#61865] [PATCH 0/8] fix some packages cross-compile
(name . Z572)(address . 873216071@qq.com)(address . 61865-done@debbugs.gnu.org)
ZHyBe8ZPpSJ8EMRL@3900XT
Thanks. I pushed most of the patches.

On Tue, Feb 28, 2023 at 04:30:45PM +0800, Z572 via Guix-patches via wrote:
Toggle quote (30 lines)
> Hello, guix.
>
> This patchset fix some package cross-compile.
>
> Zheng Junjie (8):
> gnu: xcb-util-wm: fix riscv64 cross-compile.
> gnu: libxv: fix riscv64 cross-compile.
> gnu: libxtst: fix riscv64 cross-compile.
> gnu: mtdev: fix riscv64 cross-compile.
> gnu: gobject-introspection: fix riscv64 cross-compile.
> gnu: gsettings-desktop-schemas: fix cross-compile.
> gnu: libotf: fix cross-compile.
> gnu: librsvg-2.40: fix cross-compile.
>
> gnu/packages/fontutils.scm | 17 ++++++++++-
> gnu/packages/glib.scm | 5 +++-
> gnu/packages/gnome.scm | 7 +++--
> gnu/packages/xdisorg.scm | 20 +++++++++++--
> gnu/packages/xorg.scm | 59 ++++++++++++++++++++++++++++++++++----
> 5 files changed, 95 insertions(+), 13 deletions(-)
>
>
> base-commit: c0e9ddfa290056f137ee21a53be6be4fbb8586ea
> --
> 2.39.1
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR8gXsACgkQQarn3Mo9
g1FhHw/+LzixGlkdoq/2Wi7amsXLGHDWvZxTNvu4hgMKfb/iEqwJpZQAE7xfNB/t
E85F7j0ufjdHe6pbejkd5PkZJTD+x58MHLQBRNsmgMaXxgkOFdwT94W8nqCYRB5Y
FOiwNp3no27NgYEg0Xprz5+Bwrk5PjvvQFWaY670uuXtC0AWWc5GiDsa2Ty75PJ6
dKNhzNfTDvPYd9HyPDxU0bqQZd3suhrz+POlYjd4gRyfwW1KIjsqy/JirTeMS2Pn
sLNVInbdh+FoqEByV6Bc6kXt/FEOUkdJqSyUcKatXv2Z1CU8yTmQKVG5PU18LlHb
YL3LvHn+two9ZxdVxKAGwoiNDH8/wHeu7GHRRZgx7F6MtN/PNn1tYwIGmRi2I78d
G9+L1bDZZMOBnC2DSYUN4EQhPUJIKg18cjl6AMzsht6x3SOml0zi5xuwTS9G+16P
7FvYuAatrJuBg8zxD9GOi3Mt/o6J2O24eK8KImOb59yQ4McPrKZQ5ZAe09g6/uDL
XTuQ/tG8/9ChxZ9PCfh4wtKUiLB47QdqgL8Ix+E3YA05BlgR1Qk3jNGv5K8UpMEB
2LXpDkvmULJsoA//zMHnQ76teAJQh0JZARIvTGgC5KJ9CzMSeMuwZcCEgLM9menq
Dsco6055ctt9QxqHPfr4t0564k3fnCLul82QN92KK//Lco0vkuk=
=2o2h
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61865@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61865
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch