(name . bug-guix)(address . bug-guix@gnu.org)
Hi!
I wanted to note some findings regarding the improved
mpd-configuration/mdp-service-type (thanks!)
(5c5f0fc1135ff15f9c4adfc5f27eadd9a592b5d1, "services: mpd: Refactor MPD
service.") after having reconfigured my machine yesterday. I've noted
these two backward incompatible changes:
1. the mixer type must now be a string instead of a symbol, and takes
"none" instead of 'null for the null mixer:
Toggle snippet (11 lines)
@@ -239,7 +239,7 @@
(mpd-output
(name "streaming")
(type "httpd")
- (mixer-type 'null)
+ (mixer-type "none")
(extra-options
`((encoder . "lame")
(port . "6601")
It'd be nice if there was some deprecation warning and automatic healing
code for now. The doc should also be updated, because it still mention
the @code{null} value:
Toggle snippet (8 lines)
‘mixer-type’ (default: ‘"none"’) (type: string)
This field accepts a string that specifies which mixer should
be used for this audio output: the ‘hardware’ mixer, the
‘software’ mixer, the ‘null’ mixer (allows setting the volume,
but with no effect; this can be used as a trick to implement
an external mixer External Mixer) or no mixer (‘none’).
2. The MPD user appears to be created instead of using an existing
one. I was using my own account, like this:
Toggle snippet (16 lines)
(service mpd-service-type
(mpd-configuration
(user "maxim")
(address "0.0.0.0")
(outputs
(list (mpd-output)
(mpd-output
(name "streaming")
(type "httpd")
(mixer-type "none")
(extra-options
`((encoder . "lame")
(port . "6601")
(bitrate . "320"))))))))
and 'guix system reconfigure' is now warning that a user is defined
twice, and my user description following reconfiguration is: "Music
Player Daemon (MPD) user" :-).
Perhaps it should check if a user already exists and not add it if it
does? Else an error rather than a warning when multiple same-name users
are defined would be more appropriate, I think.
--
Thanks,
Maxim