[PATCH 0/2] gnu: Stellarium: Update to 1.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 8 Feb 2023 03:27
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230208022759.3470-1-sharlatanus@gmail.com
Hi Guix!

I've attempted to update Stellarium to the latest version by keeping it on Qt5
which has passed the build successfully both on x86_64 and aarch64 systems.

Also this patch series is digestible and does not include a long chain which
might be scheduled for some future work to bring Stellarium on Qt6 as it was

Sharlatan Hellseher (2):
gnu: Add qxlsx.
gnu: stellarium: Update to 1.2.

gnu/packages/astronomy.scm | 77 +++++++++++++++++++++++++-------------
gnu/packages/qt.scm | 39 +++++++++++++++++++
2 files changed, 90 insertions(+), 26 deletions(-)


base-commit: ccf742f120452acf587d16e40adea570d15169c4
prerequisite-patch-id: 864e7338762166d118e7b2d713d49c4fd829c5fc
prerequisite-patch-id: b9bf91b8f0f3d66d6244802ea967f5a13c34aa3a
prerequisite-patch-id: 7535543b241b2299200d91e176d3ac60e52de3e4
prerequisite-patch-id: 5a8d831a1e98d5da777f273a03f9d320ae8f464e
--
2.39.1
S
S
Sharlatan Hellseher wrote on 8 Feb 2023 03:30
[PATCH] gnu: cl-croatoan: Update to 0.0.1-7.622a590.
(address . 61357@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230208023008.3641-2-sharlatanus@gmail.com
* gnu/packages/lisp-xyz.scm (sbcl-croatoan): Update to 0.0.1-7.622a590.
[arguments]{asd-systems} Add croatoan, croatoan-ncurses and ansi-escape.
[arguments]{phases}(fix-paths): Use search-input-file procedure.
---
gnu/packages/lisp-xyz.scm | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 39fe5c3f76..947e7fa6ed 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -17121,8 +17121,8 @@ (define-public cl-tooter
(sbcl-package->cl-source-package sbcl-tooter))
(define-public sbcl-croatoan
- (let ((commit "35c92fcc6c4458339c7e27bdf16f7fa908d95eb8")
- (revision "6"))
+ (let ((commit "622a5902c38b45248bf843e66158a2ee19468018")
+ (revision "7"))
(package
(name "sbcl-croatoan")
(version (git-version "0.0.1" revision commit))
@@ -17134,18 +17134,17 @@ (define-public sbcl-croatoan
(commit commit)))
(file-name (git-file-name "cl-croatoan" version))
(sha256
- (base32 "0v1lrdjd29krjb6pr0mql9hjj5c2lv760xwpr17dbsw263vx29xz"))))
+ (base32 "015xq5bbmv05bnl9hynw0bc7c6dv49hak72f5h45ry8zmpxx5cr5"))))
(build-system asdf-build-system/sbcl)
(arguments
- '(#:phases
+ '(#:asd-systems '("croatoan" "croatoan-ncurses" "ansi-escape")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "ncurses/ncurses.lisp"
- (("libncursesw" all)
- (string-append (assoc-ref inputs "ncurses")
- "/lib/"
- all))))))))
+ (("libncursesw.so")
+ (search-input-file inputs "/lib/libncursesw.so"))))))))
(inputs
(list ncurses
sbcl-cffi
--
2.38.1
S
S
Sharlatan Hellseher wrote on 8 Feb 2023 03:30
[PATCH 1/2] gnu: Add qxlsx.
(address . 61357@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230208023008.3641-1-sharlatanus@gmail.com
* gnu/packages/qt.scm (qxlsx): New variable.
---
gnu/packages/qt.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7a1d60a2e5..70c534dcb6 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 Yash Tiwari <yasht@mailbox.org>
+;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1107,6 +1108,44 @@ (define-public qtx11extras
(description "The QtX11Extras module includes the library to access X11
from within Qt 5.")))
+(define-public qxlsx
+ (package
+ (name "qxlsx")
+ (version "1.4.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/QtExcel/QXlsx")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h95h96vz47cnfp62j7bx6ih725gbv005hm0cfqanfvqd5xd9qsg"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "../source/QXlsx"
+ "-DCMAKE_BUILD_TYPE=Release"
+ (string-append "-DCMAKE_INSTALL_PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "../source/TestExcel"
+ (invoke "qmake")
+ (invoke "make" "-j" (number->string (parallel-job-count)))
+ (invoke "./TestExcel"))))))))
+ (inputs
+ (list qtbase-5))
+ (home-page "https://qtexcel.github.io/QXlsx/")
+ (synopsis "C++ library to read/write Excel XLSX files using Qt")
+ (description
+ "QXlsx is a successor of QtXlsx and providies a functionality to work with Excel
+XLSX document format.")
+ (license license:expat)))
+
(define-public qtxmlpatterns
(package (inherit qtsvg-5)
(name "qtxmlpatterns")
--
2.39.1
S
S
Sharlatan Hellseher wrote on 8 Feb 2023 03:30
[PATCH 2/2] gnu: stellarium: Update to 1.2.
(address . 61357@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
20230208023008.3641-3-sharlatanus@gmail.com
As reported in https://issues.guix.gnu.org/58481attempt to update to
1.0 with Qt6 has been failed. Stellarium is kept on Qt5 with future work
to migrate to Qt6 when all components are ready.

* gnu/packages/astronomy.scm (stellarium): Update to 1.2.
[arguments]{tests}: Disable tests, with further review of INDI package.
[arguments]{configure-flags}: Explicitly disable Qt6 (prevent failing
build) and ShowMySky (not packed yet).
[phases]{set-offscreen-display}: Remove trail #t in lambda.
[inputs]: Remove labels and add gpsd, indi, libnova, openssl,
qtcharts, qtpositioning, qttranslations, qtwebengine-5, qxlsx.
[native-inputs]: Remove labels and add doxygen, graphviz, mesa,
python-wrapper.
---
gnu/packages/astronomy.scm | 77 +++++++++++++++++++++++++-------------
1 file changed, 51 insertions(+), 26 deletions(-)

Toggle diff (124 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2f08b656c0..5cee981671 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -37,6 +37,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
@@ -44,6 +45,8 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gps)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages image-processing)
@@ -70,6 +73,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages wxwidgets)
@@ -835,45 +839,66 @@ (define-public stackistry
(define-public stellarium
(package
(name "stellarium")
- (version "0.21.1")
+ (version "1.2")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Stellarium/stellarium"
- "/releases/download/v" version
- "/stellarium-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Stellarium/stellarium")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "049jlc8vx06pad5h2syrmf7f1l346yr5iraai0wkn8s8pk30j8q7"))))
+ (base32 "1655lz848k7m4vqs7n3vxjwn5n4pkykwl6x7nbanqcqzlixm5xnk"))))
(build-system cmake-build-system)
+ ;; TODO: Complete documentation build and split into dedicated outputs.
+ (arguments
+ (list
+ ;; FIXME: Tests keep failing on 100% when preparing test-suit for INDI.
+ #:tests? #f
+ #:test-target "test"
+ #:configure-flags
+ #~(list "-DENABLE_GPS=1"
+ ;; TODO: Enable when all of the dependencies are availalbe for Qt6.
+ "-DENABLE_QT6=0"
+ ;; TODO: Pack missing in Guix https://10110111.github.io/CalcMySky/
+ "-DENABLE_SHOWMYSKY=0"
+ "-DENABLE_TESTING=0"
+ (string-append "-DCMAKE_CXX_FLAGS=-isystem "
+ #$(this-package-input "qtserialport") "/include/qt5"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-offscreen-display
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "HOME" "/tmp"))))))
(inputs
- (list qtbase-5
+ (list gpsd
+ indi
+ libnova
+ openssl
+ qtbase-5
+ qtcharts
qtlocation
qtmultimedia-5
+ qtpositioning
qtscript
qtserialport
+ qttranslations
+ qtwebengine-5
+ qxlsx
zlib))
(native-inputs
- `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
- ("perl" ,perl) ; for pod2man
- ("qtbase" ,qtbase-5) ; Qt MOC is needed at compile time
- ("qttools-5" ,qttools-5)))
- (arguments
- `(#:test-target "test"
- #:configure-flags (list "-DENABLE_TESTING=1"
- (string-append
- "-DCMAKE_CXX_FLAGS=-isystem "
- (assoc-ref %build-inputs "qtserialport")
- "/include/qt5"))
- #:phases (modify-phases %standard-phases
- (add-before 'check 'set-offscreen-display
- (lambda _
- ;; Make Qt render "offscreen", required for tests.
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp")
- #t)))))
+ (list doxygen
+ gettext-minimal
+ graphviz
+ mesa
+ perl
+ python-wrapper
+ qttools-5))
(home-page "https://stellarium.org/")
(synopsis "3D sky viewer")
- (description "Stellarium is a planetarium. It shows a realistic sky in
+ (description
+ "Stellarium is a planetarium. It shows a realistic sky in
3D, just like what you see with the naked eye, binoculars, or a telescope. It
can be used to control telescopes over a serial port for tracking celestial
objects.")
--
2.39.1
S
S
Sharlatan Hellseher wrote on 8 Feb 2023 11:14
(address . 61357@debbugs.gnu.org)
CAO+9K5p0puCxXcBaNLJsqyDpiV-AZ7KOTbuOp105g3X5LduiiA@mail.gmail.com
Hi,

I accidentally included not relate patch to this issue

Toggle quote (2 lines)
> [PATCH] gnu: cl-croatoan: Update to 0.0.1-7.622a590.

Please ignore it.

Thanks,
Oleg
Attachment: file
S
S
Sharlatan Hellseher wrote on 18 Feb 2023 22:28
(address . 61357@debbugs.gnu.org)
CAO+9K5pbeW6sGCFAyGxaoHB8voJJtZEht=tpmdG2uXjOD0iW9Q@mail.gmail.com
Hi,
I see QA is grey, still not picked it up.
I've passed build locally for x86_64 and aarch64 but with disabled
tests they are failed on the 100% due to issue with latest INDI
package where tests disabled as well (it's on my radar to fix togather
with updating large astro packages.).
Is anything blocking this patch?
Thanks,
Oleg
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
N
N
Nicolas Goaziou wrote on 20 Feb 2023 14:14
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 61357-done@debbugs.gnu.org)
87k00cqy0o.fsf@nicolasgoaziou.fr
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/qt.scm (qxlsx): New variable.

Applied both patches (in wrong order… :( Ah,well…). Thank you.

Regards,
--
Nicolas Goaziou
Closed
?