[WIP PATCH 0/9] gnu: stellarium: Update to 1.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Cairn
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Cairn
Severity
normal
C
(name . Cairn via Guix-patches via)(address . guix-patches@gnu.org)
94mAek164ENauq8r9O2XguR2a7BFYVU2ypJqpJr5Z42OJKl96FxC5qetFugtvngiV5uewDij2lo1zuoI7XEDvQ_GIEZRL4fc1DFI0k6U03w=@pm.me
Hey Guix!

This patchset updates Stellarium to version 1.0. Along the way, I had to update a few Qt packages and add a few dependencies. I used Maxim's Jami patchset[1] as a guide to updating the Qt packages. All the dependencies work, but I'm definitely looking for suggestions on if some of the packages could be improved.

Unfortunately, the only thing that isn't working yet is the Stellarium package itself. At 77% of the build process, it fails with an enormous amount of errors, which makes it seem like some dependency version is incompatible. I fumbled around with variations of the package arguments a lot; I couldn't solve it with extra configuration flags, and it doesn't seems to need any other dependencies. I tried adding `qtbase` explicity with an `-isystem` flag in the same way as `qtserialport`, but that doesn't seem to be it either.

I've already spent a couple of days messing with this, and I'm a little tired of it. I decided to share what I was able to finish in the hope that someone can help figure out this last issue. I'm attatching the (lengthy) build log to the next email, if you'd like to take a look without setting it up yourself.

Thanks in advance! Looking forward to being able to send a repaired and improved V2.


Cairn (9):
gnu: qtcharts: Rename variable to qtcharts-5.
gnu: Add qtcharts, version 6.3.1.
gnu: qtserialport: Rename variable to qtserialport-5.
gnu: Add qtserialport, version 6.3.1.
gnu: qtimageformats: Rename variable to qtimageformats-5.
gnu: Add qtimageformats, version 6.3.1.
gnu: Add qxlsx.
gnu: Add calcmysky.
gnu: stellarium: Update to 1.0.

gnu/packages/astronomy.scm | 107 +++++++++++++++++--------
gnu/packages/engineering.scm | 4 +-
gnu/packages/geo.scm | 4 +-
gnu/packages/image-viewers.scm | 2 +-
gnu/packages/kde.scm | 6 +-
gnu/packages/qt.scm | 137 ++++++++++++++++++++++++++++++---
gnu/packages/radio.scm | 16 ++--
gnu/packages/telegram.scm | 2 +-
8 files changed, 222 insertions(+), 56 deletions(-)

--

2.38.0
Attachment: signature.asc
C
Stellarium build log
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
pol9NwIC5NmEo_EVN7kVEnmIB6knnkDM_Yzn2jQ_stkXyUnmfh1Rmc_p9vmY6BLy-yhEGwKJhfQQsjQDmE49dEPaxOWQNOw2sXnF2qTAV5M=@pm.me
Errors start at line #9845.
Attachment: signature.asc
C
[PATCH 1/9] gnu: qtcharts: Rename variable to qtcharts-5.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
dU3ZvhVuqirwy8phpmKnrzwtD4KHHazdYcUkPzYfIrWWz9S0brnLEubXRDLzI44d_7D4e9hKnsJS3bB9u589iQqcRU_YLeTPaJZYFvk3TaQ=@pm.me
This is in preparation of updating qtcharts to version 6.

This change was automated via the following command:

git grep -l '\bqtcharts\b' | xargs sed 's/qtcharts/qtcharts-5/g' -i
---
gnu/packages/kde.scm | 2 +-
gnu/packages/qt.scm | 4 ++--
gnu/packages/radio.scm | 4 ++--
3 files changed, 5 insertions(+), 5 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 20df62fdfa..e4ec70bc7a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1247,7 +1247,7 @@ (define-public kuserfeedback
;;("phpunit" ,phpunit)
))
(inputs
- (list qtbase-5 qtcharts qtdeclarative-5 qtsvg-5))
+ (list qtbase-5 qtcharts-5 qtdeclarative-5 qtsvg-5))
(arguments
`(#:tests? #f)) ;; 4/17 fail
(home-page "https://api.kde.org/frameworks/kuserfeedback/html/")
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 6e30980505..1efac2fb50 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2008,9 +2008,9 @@ (define-public qtpurchasing
(description "The Qt Purchasing module provides and in-app API for
purchasing goods and services.")))

-(define-public qtcharts
+(define-public qtcharts-5
(package (inherit qtsvg-5)
- (name "qtcharts")
+ (name "qtcharts-5")
(version "5.15.2")
(source (origin
(method url-fetch)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index f466678289..cba6d25b9f 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2009,7 +2009,7 @@ (define-public welle-io
mpg123
rtl-sdr
qtbase-5
- qtcharts
+ qtcharts-5
qtdeclarative-5
qtgraphicaleffects
qtmultimedia-5
@@ -2257,7 +2257,7 @@ (define-public sdrangel
opus
pulseaudio
qtbase-5
- qtcharts
+ qtcharts-5
qtdeclarative-5
qtlocation
qtmultimedia-5
--

2.38.0
Attachment: signature.asc
C
[PATCH 2/9] gnu: Add qtcharts, version 6.3.1.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
1-VbVDknMqvpSpgcwaXvffVK0JTueWkLiL_y3aF6gDVkJhFCT6kt9xWrbiD82SDnmqtyfzN7gYLQEdTUtAEVd7nZ7WgV1GNlPrTAPZ5yeq4=@pm.me
* gnu/packages/qt.scm (qtcharts): New variable.
---
gnu/packages/qt.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 1efac2fb50..e213657249 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2031,6 +2031,28 @@ (define-public qtcharts-5
selecting one of the charts themes.")
(license license:gpl3)))

+(define-public qtcharts
+ (package (inherit qtsvg)
+ (name "qtcharts")
+ (version "6.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (sha256
+ (base32
+ "1xvwsabyfln3sih9764xknl2s3w4w069k210kgbh94bj50iwqc7k"))))
+ (arguments
+ (list #:tests? #f)) ; TODO: Enable tests (two fail)
+ (inputs
+ (list qtbase qtdeclarative))
+ (synopsis "Qt Charts module")
+ (description "The Qt Charts module provides a set of easy to use chart
+components. It uses the Qt Graphics View Framework, therefore charts can be
+easily integrated to modern user interfaces. Qt Charts can be used as QWidgets,
+QGraphicsWidget, or QML types. Users can easily create impressive graphs by
+selecting one of the charts themes.")
+ (license license:gpl3)))
+
(define-public qtdatavis3d
(package (inherit qtsvg-5)
(name "qtdatavis3d")
--

2.38.0
Attachment: signature.asc
C
[PATCH 3/9] gnu: qtserialport: Rename variable to qtserialport-5.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
OyjuSIPTS-Q7FHGIWJ_uvwNy-FkjRKesvhSaXcinH8a-_gk1W57X9b6SKh8EmP-4zvCipm27-2IHiwb16xPcGX28vKDVMdv8RBVoP0aPI3E=@pm.me
This is in preparation of updating qtserialport to version 6.

This change was automated via the following command:

git grep -l '\bqtserialport\b' | xargs sed 's/qtserialport/qtserialport-5/g' -i
---
gnu/packages/astronomy.scm | 4 ++--
gnu/packages/engineering.scm | 4 ++--
gnu/packages/geo.scm | 2 +-
gnu/packages/kde.scm | 4 ++--
gnu/packages/qt.scm | 10 +++++-----
gnu/packages/radio.scm | 12 ++++++------
6 files changed, 18 insertions(+), 18 deletions(-)

Toggle diff (184 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index aaa9207e0e..8c53611427 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -745,7 +745,7 @@ (define-public stellarium
qtlocation
qtmultimedia-5
qtscript
- qtserialport
+ qtserialport-5
zlib))
(native-inputs
`(("gettext" ,gettext-minimal) ; xgettext is used at compile time
@@ -757,7 +757,7 @@ (define-public stellarium
#:configure-flags (list "-DENABLE_TESTING=1"
(string-append
"-DCMAKE_CXX_FLAGS=-isystem "
- (assoc-ref %build-inputs "qtserialport")
+ (assoc-ref %build-inputs "qtserialport-5")
"/include/qt5"))
#:phases (modify-phases %standard-phases
(add-before 'check 'set-offscreen-display
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5c84b9ede0..7ee8691a7f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -713,7 +713,7 @@ (define-public fritzing
"phoenix.pro")))))))
(inputs
`(("qtbase" ,qtbase-5)
- ("qtserialport" ,qtserialport)
+ ("qtserialport-5" ,qtserialport-5)
("qtsvg-5" ,qtsvg-5)
("libgit2" ,libgit2)
("boost" ,boost)
@@ -3818,7 +3818,7 @@ (define-public candle
"08rqhl6a5a8s67a8yl16944zgcsnnb08xfv4klzyqwlvaqgfp783"))))
(build-system gnu-build-system)
(native-inputs (list qttools-5))
- (inputs (list qtbase-5 qtserialport))
+ (inputs (list qtbase-5 qtserialport-5))
(arguments
(list #:tests? #f ; no tests.
#:phases #~(modify-phases %standard-phases
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5e484c6e1c..97f561e362 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2622,7 +2622,7 @@ (define-public qgis
qtdeclarative-5
qtkeychain
qtlocation
- qtserialport
+ qtserialport-5
qtsvg-5
qwt
;; saga
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index e4ec70bc7a..7b47abdc6d 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -833,7 +833,7 @@ (define-public labplot
libcerf
lz4
netcdf
- qtserialport
+ qtserialport-5
zlib))
(home-page "https://labplot.kde.org/")
(synopsis "Interactive graphing and analysis of scientific data")
@@ -1048,7 +1048,7 @@ (define-public marble-qt
qtbase-5
qtdeclarative-5
qtlocation
- qtserialport
+ qtserialport-5
qtsvg-5
qtwebchannel-5
qtwebengine-5
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index e213657249..d589f653fb 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1550,9 +1550,9 @@ (define-public qtwayland
(home-page (package-home-page qtbase))
(license (package-license qtbase))))

-(define-public qtserialport
+(define-public qtserialport-5
(package (inherit qtsvg-5)
- (name "qtserialport")
+ (name "qtserialport-5")
(version "5.15.2")
(source (origin
(method url-fetch)
@@ -1604,7 +1604,7 @@ (define-public qtserialbus
(format #f "QStringLiteral(~s)" libcansocket.so)))
#t)))))))
(inputs
- (list libsocketcan qtbase-5 qtserialport))
+ (list libsocketcan qtbase-5 qtserialport-5))
(synopsis "Qt Serial Bus module")
(description "The Qt Serial Bus API provides classes and functions to
access the various industrial serial buses and protocols, such as CAN, ModBus,
@@ -1731,7 +1731,7 @@ (define-public qtlocation
(substitute-keyword-arguments (package-arguments qtsvg-5)
((#:tests? _ #f) #f))) ; TODO: Enable the tests
(native-inputs
- (list perl qtdeclarative-5 qtquickcontrols-5 qtserialport))
+ (list perl qtdeclarative-5 qtquickcontrols-5 qtserialport-5))
(inputs
(list icu4c openssl qtbase-5 zlib))
(synopsis "Qt Location and Positioning modules")
@@ -3081,7 +3081,7 @@ (define-public python-pyqt
("qtlocation" ,qtlocation)
("qtmultimedia-5" ,qtmultimedia-5)
("qtsensors" ,qtsensors)
- ("qtserialport" ,qtserialport)
+ ("qtserialport-5" ,qtserialport-5)
("qtsvg-5" ,qtsvg-5)
("qttools-5" ,qttools-5)
("qtwebchannel-5" ,qtwebchannel-5)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index cba6d25b9f..bebbbda071 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1381,7 +1381,7 @@ (define-public wsjtx
("libusb" ,libusb)
("qtbase" ,qtbase-5)
("qtmultimedia-5" ,qtmultimedia-5)
- ("qtserialport" ,qtserialport)))
+ ("qtserialport-5" ,qtserialport-5)))
(arguments
`(#:tests? #f)) ; No test suite
(synopsis "Weak-signal ham radio communication program")
@@ -1420,7 +1420,7 @@ (define-public jtdx
qtbase-5
qtwebsockets-5
qtmultimedia-5
- qtserialport))
+ qtserialport-5))
(arguments
`(#:tests? #f)) ; No test suite
(synopsis "Weak-signal ham radio communication program, forked from WSJTX")
@@ -1464,7 +1464,7 @@ (define-public js8call
("libusb" ,libusb)
("qtbase" ,qtbase-5)
("qtmultimedia-5" ,qtmultimedia-5)
- ("qtserialport" ,qtserialport)))
+ ("qtserialport-5" ,qtserialport-5)))
(arguments
`(#:tests? #f ; No test suite
#:phases
@@ -2262,7 +2262,7 @@ (define-public sdrangel
qtlocation
qtmultimedia-5
qtquickcontrols2-5
- qtserialport
+ qtserialport-5
qtspeech
qtwebchannel-5
qtwebengine-5
@@ -2394,7 +2394,7 @@ (define-public wfview
(base32 "1kpkwxhcacgmprbr8xz840rj9a22513vxrh2q7d3js5i1dva8j2z"))))
(build-system qt-build-system)
(inputs
- (list opus qcustomplot qtbase-5 qtmultimedia-5 qtserialport))
+ (list opus qcustomplot qtbase-5 qtmultimedia-5 qtserialport-5))
(arguments
`(#:tests? #f ; No test suite.
#:phases
@@ -2694,7 +2694,7 @@ (define-public qdmr
(substitute* "lib/CMakeLists.txt"
(("(DESTINATION \")/etc/udev/" _ directive)
(string-append directive #$output "/lib/udev/"))))))))
- (inputs (list libusb qtbase-5 qtlocation qtserialport yaml-cpp))
+ (inputs (list libusb qtbase-5 qtlocation qtserialport-5 yaml-cpp))
(native-inputs (list qttools-5))
(home-page "https://dm3mat.darc.de/qdmr/")
(synopsis "GUI application and command line tool to program DMR radios")
--

2.38.0
Attachment: signature.asc
C
[PATCH 4/9] gnu: Add qtserialport, version 6.3.1.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
ngkyUlmGgut35PNxTb1vkxoK74AUlf7pfWsKM0QnmURB1WE6CRJJla1P3gOPloPp1pITSjnCphwPQE5iVfnkVhkGRac-yneAGjV0gjG2Lmw=@pm.me
* gnu/packages/qt.scm (qtserialport): New variable.
---
gnu/packages/qt.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d589f653fb..d0d2c906a4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1580,6 +1580,35 @@ (define-public qtserialport-5
(description "The Qt Serial Port module provides the library for
interacting with serial ports from within Qt.")))

+(define-public qtserialport
+ (package (inherit qtsvg)
+ (name "qtserialport")
+ (version "6.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (sha256
+ (base32
+ "0vk17cjj9jpdkgd8qwb1x0lijg0p2jxdzx4d67hd57brcl7didjf"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-dlopen-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/serialport/qtudev_p.h"
+ ;; Use the absolute paths for dynamically loaded libs,
+ ;; otherwise the lib will be searched in LD_LIBRARY_PATH which
+ ;; typically is not set in guix.
+ (("^\\s*(udevLibrary->setFileNameAndVersion\\(QStringLiteral\\(\")(udev\"\\),\\s*[0-9]+\\);)" _ a b)
+ (string-append a #$(this-package-input "eudev") "/lib/lib" b))))))))
+ (native-inputs
+ (list perl pkg-config))
+ (inputs
+ (list qtbase eudev))
+ (synopsis "Qt Serial Port module")
+ (description "The Qt Serial Port module provides the library for
+interacting with serial ports from within Qt.")))
+
(define-public qtserialbus
(package (inherit qtsvg-5)
(name "qtserialbus")
--

2.38.0
Attachment: signature.asc
C
[PATCH 5/9] gnu: qtimageformats: Rename variable to qtimageformats-5.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
06tsV7P2mFf3plajeILmCw1cf9WJKHVkoxyorrpSarxzNb8U50PD8VoUsOTw1PqVmN1X_LwrAkCocjXwSbON1xyaI-JtxBrlBc9UuEFA3HA=@pm.me
This is in preparation of updating qtimageformats to version 6.

This change was automated via the following command:

git grep -l '\bqtimageformats\b' | xargs sed 's/qtimageformats/qtimageformats-5/g' -i
---
gnu/packages/geo.scm | 2 +-
gnu/packages/image-viewers.scm | 2 +-
gnu/packages/qt.scm | 4 ++--
gnu/packages/telegram.scm | 2 +-
4 files changed, 5 insertions(+), 5 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 97f561e362..0ecfbc75c5 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2229,7 +2229,7 @@ (define-public openorienteering-mapper
("gdal" ,gdal)
("proj" ,proj)
("qtbase" ,qtbase-5)
- ("qtimageformats" ,qtimageformats)
+ ("qtimageformats-5" ,qtimageformats-5)
("qtlocation" ,qtlocation)
("qtsensors" ,qtsensors)
("zlib" ,zlib)))
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 77979e8b8f..6e41cb5fdb 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -714,7 +714,7 @@ (define-public qview
(native-inputs
(list qttools-5))
(inputs
- (list qtbase-5 qtimageformats qtsvg-5))
+ (list qtbase-5 qtimageformats-5 qtsvg-5))
(home-page "https://interversehq.com/qview/")
(synopsis "Convenient and minimal image viewer")
(description "qView is a Qt image viewer designed with visually
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d0d2c906a4..85f9c0716c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -948,9 +948,9 @@ (define-public qtsvg
(home-page (package-home-page qtbase))
(license (package-license qtbase))))

-(define-public qtimageformats
+(define-public qtimageformats-5
(package (inherit qtsvg-5)
- (name "qtimageformats")
+ (name "qtimageformats-5")
(version "5.15.2")
(source (origin
(method url-fetch)
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 82c9227ba8..d64d2eaf1d 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -500,7 +500,7 @@ (define-public telegram-desktop
pulseaudio
qrcodegen-cpp
qtbase-5
- qtimageformats
+ qtimageformats-5
qtsvg-5
qtwayland-5
range-v3
--

2.38.0
Attachment: signature.asc
C
[PATCH 6/9] gnu: Add qtimageformats, version 6.3.1.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
Z9XeL8KiodmtGo1LW0J7Qq_Ssi9eB6nqzcqS5Zv_G_X3HSsKW4YPrsOZO6cJ5yhdQYu3ah_odCRpZIT5q0qMaEFoUMHTrSudOL-xBllgPuo=@pm.me
* gnu/packages/qt.scm (qtimageformats): New variable.
---
gnu/packages/qt.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 85f9c0716c..2d9923b19f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -986,6 +986,47 @@ (define-public qtimageformats-5
(description "The QtImageFormats module contains plugins for adding
support for MNG, TGA, TIFF and WBMP image formats.")))

+(define-public qtimageformats
+ (package (inherit qtsvg)
+ (name "qtimageformats")
+ (version "6.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (sha256
+ (base32
+ "0br1vqgx0hcc2nx32xviic94mvj6fbagrnzskdr7zdmvvyw140xd"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "src/3rdparty")
+ #t))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute*
+ "src/plugins/imageformats/jp2/qjp2handler.cpp"
+ (("^#include <jasper/jasper.h>")
+ "#include <jasper/jasper.h>\n#include <QtCore/qmath.h>"))))
+ (add-before 'check 'set-offscreen-display
+ (lambda _
+ ;; Make Qt render "offscreen", required for tests.
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "HOME" "/tmp"))))))
+ (inputs
+ (list jasper
+ libmng
+ libtiff
+ libwebp
+ mesa
+ qtbase
+ zlib))
+ (synopsis "Additional Image Format plugins for Qt")
+ (description "The QtImageFormats module contains plugins for adding
+support for MNG, TGA, TIFF and WBMP image formats.")))
+
(define-public qtx11extras
(package (inherit qtsvg-5)
(name "qtx11extras")
--

2.38.0
Attachment: signature.asc
C
[PATCH 7/9] gnu: Add qxlsx.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
E4seBzJObUerwuhsZU6uJ-1RWQkhi0MJhhWARlPzPA5S-oJkoPBq5VZutpiOn47VkRp6lR-Th1RiF4SZ8aDOcwwz7cozxMPVyTEc_-7Oauo=@pm.me
* gnu/packages/qt.scm (qxlsx): New variable.
---
gnu/packages/qt.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2d9923b19f..6169d8bb65 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Cairn <cairn@pm.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4390,6 +4391,32 @@ (define-public kdsoap
web server.")
(license (list license:gpl2 license:gpl3))))

+(define-public qxlsx
+ (package
+ (name "qxlsx")
+ (version "1.4.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/QtExcel/QXlsx/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h11pviill9m749408xygkvkxik002va27n1d6zyg7bbjiwbnlfk"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ; No rule for tests
+ #:configure-flags
+ #~(list "-G" "Unix Makefiles" "../source/QXlsx")))
+ (inputs
+ (list qtbase libxkbcommon))
+ (home-page "https://qtexcel.github.io/QXlsx/")
+ (synopsis "Excel file reader/writer library using Qt")
+ (description "This is a libary for reading and writing Excel files
+(.xlsx) using either Qt 5 or 6.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--

2.38.0
Attachment: signature.asc
C
[PATCH 8/9] gnu: Add calcmysky.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
r2QbnV5hqDk9_Ff1Soecb4nGCYiM1r4MX5O_jP3pjCXPwhPOyy_Zz03HBg2AzmHyb9ndn-u9_9TNc7YyjJonZ2ksZ41Aq1REuMEtwsJmns0=@pm.me
* gnu/packages/astronomy.scm (calcmysky): New variable.
---
gnu/packages/astronomy.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 8c53611427..72e923e895 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2022 Cairn <cairn@pm.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -727,6 +728,34 @@ (define-public stackistry
deconvolution). Such post-processing is not performed by Stackistry.")
(license license:gpl3+)))

+(define-public calcmysky
+ (package
+ (name "calcmysky")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/10110111/CalcMySky")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13wk73c0xyh6c1zpxjzny987x0qdy1gcqy2y5r5a5hiqx4fz3lfj"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=6")))
+ (inputs
+ (list qtbase
+ glm
+ eigen))
+ (home-page "https://10110111.github.io/CalcMySky/")
+ (synopsis "Simulator of light scattering by planetary atmospheres")
+ (description "CalcMySky is a software package that simulates scattering
+of light by the atmosphere to render daytime and twilight skies (without
+stars). It consists of three parts: CalcMySky, ShowMySky and libShowMySky.")
+ (license license:gpl3)))
+
(define-public stellarium
(package
(name "stellarium")
--

2.38.0
Attachment: signature.asc
C
[PATCH 9/9] gnu: stellarium: Update to 1.0.
(name . 58481@debbugs.gnu.org)(address . 58481@debbugs.gnu.org)
9Ur0xxihNkidL-6S43Jm9z1DAfHbwsPs1kHSQPfHktINUEbnY7fJ6DwXNjqdG19bRXa1fNqLx93RxD4xmAFkwOUxTkx251DCVooi2Ci8H9I=@pm.me
* gnu/packages/astronomy.scm (stellarium): Update to 1.0.
---
gnu/packages/astronomy.scm | 80 +++++++++++++++++++++++---------------
1 file changed, 49 insertions(+), 31 deletions(-)

Toggle diff (120 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 72e923e895..5798d8004f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -43,6 +43,8 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gps)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libusb)
@@ -66,6 +68,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages wxwidgets)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -74,6 +77,7 @@ (define-module (gnu packages astronomy)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build utils)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -759,42 +763,56 @@ (define-public calcmysky
(define-public stellarium
(package
(name "stellarium")
- (version "0.21.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/Stellarium/stellarium"
- "/releases/download/v" version
- "/stellarium-" version ".tar.gz"))
- (sha256
- (base32 "049jlc8vx06pad5h2syrmf7f1l346yr5iraai0wkn8s8pk30j8q7"))))
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Stellarium/stellarium"
+ "/releases/download/v" version
+ "/stellarium-" version ".tar.gz"))
+ (sha256
+ (base32 "0gzksnskk0a105dji5j7hjizmyc7bs9riz6650hv417bq70i46as"))))
(build-system cmake-build-system)
(inputs
- (list qtbase-5
- qtlocation
- qtmultimedia-5
- qtscript
- qtserialport-5
+ (list qtbase
+ qtmultimedia
+ qtpositioning
+ qttools
+ qtimageformats
+ qtwebengine
+ qtwebchannel
+ qtcharts
+ qtserialport
+ qtdeclarative
+ libxkbcommon
+ calcmysky
+ qxlsx
+ indi
+ libnova
+ gpsd
zlib))
(native-inputs
- `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
- ("perl" ,perl) ; for pod2man
- ("qtbase" ,qtbase-5) ; Qt MOC is needed at compile time
- ("qttools-5" ,qttools-5)))
+ (list gettext-minimal ; xgettext is used at compile time
+ perl ; for pod2man
+ qtbase ; Qt MOC is needed at compile time
+ graphviz
+ doxygen
+ qttools))
(arguments
- `(#:test-target "test"
- #:configure-flags (list "-DENABLE_TESTING=1"
- (string-append
- "-DCMAKE_CXX_FLAGS=-isystem "
- (assoc-ref %build-inputs "qtserialport-5")
- "/include/qt5"))
- #:phases (modify-phases %standard-phases
- (add-before 'check 'set-offscreen-display
- (lambda _
- ;; Make Qt render "offscreen", required for tests.
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp")
- #t)))))
+ (list #:test-target "test"
+ #:configure-flags
+ #~(list "-DENABLE_TESTING=1"
+ "-DENABLE_QT6=1"
+ (string-append
+ "-DCMAKE_CXX_FLAGS=-isystem "
+ #$(this-package-input "qtserialport")
+ "/include/qt6"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-offscreen-display
+ (lambda _
+ ;; Make Qt render "offscreen", required for tests.
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "HOME" "/tmp"))))))
(home-page "https://stellarium.org/")
(synopsis "3D sky viewer")
(description "Stellarium is a planetarium. It shows a realistic sky in
--

2.38.0
Attachment: signature.asc
S
S
Sharlatan Hellseher wrote on 3 May 2023 10:24
(address . 58481@debbugs.gnu.org)
CAO+9K5pkMkZ9jC=uNw1vwS+kD3mNsfn5C_P+1XV-e1dPAQgJ5A@mail.gmail.com
Hi,

I've managed to update Stellarium (in Guix now) to the latest (23.1)
version with Qt5 support and in process to add Qt6 builds for each missing
inputs.

If you are still interested in this let's share the efforts?

Regards,
Oleg
Attachment: file
S
S
Sharlatan Hellseher wrote on 8 Feb 19:27 +0100
(address . 58481-done@debbugs.gnu.org)
875xyyvmkf.fsf@gmail.com
Hi,

Closing this issue as Stellarium is updated already, and this patch
series is not actual any longer.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXFHQAACgkQdtcnv/Ys
0rVpeQ//UXIZJ6MT0w4f94HkGbEhMAEim0vytm7bbpihU6fpl5rIdyzsK+LdEYDa
hpoet6aAA0JhcsFzVoSbJF3xsFVN90AyFgXWqmBAx99KTe8WOmkHDtGlB5QoT0F1
oCZBzttvRbnLsPq3sl55yAeaH5LepcBIE5keyYzNdMPIqVxnQT6aIwGnu7eUJsZP
XQqQMu39qktDfi959m+6F1cLuxYWmQ/fCLbTnGjtfnW5P39ipBsBfGQse65Fx4DW
edM5bT6J4f+Ek9Y/RZ8vd1No73Fj7xQM+AHGhOeZNLRON8oQmllsFkxqckLiect/
OrW5b9AVt6BJ5BB+tkFmeICqd4NI6vdb1N0r7Yx8ccre2tYHrzZQ9vgznXaVoBiN
CQP7EkOrisoEuJB2QTGcqZg8K1uJgzhl5WZ6rerevGf4WtApNEOIZePaGaE/gjgO
r6yZL/lHVAnGmO5AX9UwTA98fPswSEvLsWYDVSva5G/Qj4jSWPGtuWhKjTYIsM3F
lBqzG+r7m4ivgy4aqXr24SgKBZzK0hPp7XA4vkRZewdLKf+gIqrzbSV2u/1K+XXJ
jMxKxUFH+KlsV46knItytjIuQvwGg6DbwTQyZV2ra2VlmDjltcdOqEF3/iWeDHuB
cFbuFHs6j0yI0ZC91cG96joYuCGQVYDul8iQKSqsSu9U/aeO+0E=
=5tpr
-----END PGP SIGNATURE-----

Closed
?