Thanks for the tip. In my case I'm using a certain SBC and am in a
catch-22 situation, so I still think there's a bug here:
1. Use linux-libre so kernel config options for various Guix services
are set, but not have all the config options required to boot and run
the board.
1. Adding config options with dependencies via customize-linux can
best be described as a pain. [1]
2. Use linux-libre-arm64-generic to boot the board, but need to manually
enable additional config options for every service that requires them.
I can eventually either power through 1 or piece together the options I
need for 2, but this behavior is definitely surprising. I have three
proposed solutions in order of complexity:
1. The documentation for -generic kernels can be improved so their
meaning is clearer. -generic as in "as close to upstream as possible".
See [2].
2. Add more entries to %default-extra-linux-options using config options
required by various services.
3. A "linux-config-service" or similar could be created that other
services extend with their required kernel support, if any.
Of the 3, 3 seems the most elegant. It could easily complicate the
substitutability of the kernel however. Perhaps it could simply be a
system build-time check to confirm that the kernel's .config file does
in fact have those options set.
--
Take it easy,
Richard Sent
Making my computer weirder one commit at a time.