guix_defconfig options cannot be overridden in customize-linux function

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Nathan Dehnel
Owner
unassigned
Submitted by
Nathan Dehnel
Severity
normal

Debbugs page

Nathan Dehnel wrote 1 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
CAEEhgEubUaQpBrS9UrphQn7cyV2aEyh69p6eUB3JM=7qT3nPOw@mail.gmail.com
(let ((linux-package
(customize-linux
#:name name
#:linux linux
;; #:configs
;; '("CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y"
;; "CONFIG_DMA_PERNUMA_CMA=y"
;; "CONFIG_FONTS=y"
;; "CONFIG_FONT_8x16=y"
;; "CONFIG_FONT_SUN12x22=y"
;; "CONFIG_FONT_TER16x32=y")
#:defconfig
;; this defconfig contains the config options above (among others)
(local-file "defconfig-6.6")

#:configs and #:defconfig both cause this error:

Mismatching configurations in .config and
arch/arm64/configs/guix_defconfig
(("CONFIG_FRAMEBUFFER_CONSOLE_ROTATION" (#f "y")) ("CONFIG_DM
A_PERNUMA_CMA" (#f "y")) ("CONFIG_FONTS" (#f "y")) ("CONFIG_FONT_8x16"
(#f "y")) ("CONFIG_FONT_SUN12x22" (#f "y")) ("CONFIG_FONT_TER16x32
" (#f "y")))
Maxim Cournoyer wrote 1 years ago
(name . Nathan Dehnel)(address . ncdehnel@gmail.com)(address . 66355@debbugs.gnu.org)
87a5sxtdu5.fsf@gmail.com
Hi Nathan,

Nathan Dehnel <ncdehnel@gmail.com> writes:

Toggle quote (24 lines)
> (let ((linux-package
> (customize-linux
> #:name name
> #:linux linux
> ;; #:configs
> ;; '("CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y"
> ;; "CONFIG_DMA_PERNUMA_CMA=y"
> ;; "CONFIG_FONTS=y"
> ;; "CONFIG_FONT_8x16=y"
> ;; "CONFIG_FONT_SUN12x22=y"
> ;; "CONFIG_FONT_TER16x32=y")
> #:defconfig
> ;; this defconfig contains the config options above (among others)
> (local-file "defconfig-6.6")
>
> #:configs and #:defconfig both cause this error:
>
> Mismatching configurations in .config and
> arch/arm64/configs/guix_defconfig
> (("CONFIG_FRAMEBUFFER_CONSOLE_ROTATION" (#f "y")) ("CONFIG_DM
> A_PERNUMA_CMA" (#f "y")) ("CONFIG_FONTS" (#f "y")) ("CONFIG_FONT_8x16"
> (#f "y")) ("CONFIG_FONT_SUN12x22" (#f "y")) ("CONFIG_FONT_TER16x32
> " (#f "y")))

customize-linux is very limited in that it doesn't resolve the config
inter-dependencies. So if you try to enable CONFIG_FONTS but forget to
also enable any of its required options, you'll end up in the situation
above.

I'd suggest producing a defconfig file with all the correctly resolved
dependencies using the 'make savedefconfig' or similar after modifying
the config with 'make menuconfig'.

Let me know how it goes.

--
Thanks,
Maxim
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66355@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66355
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help