openbios-qemu-ppc fails to build on aarch64

  • Done
  • quality assurance status badge
Details
3 participants
  • Akira Kyle
  • Andrew Patterson
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Andrew Patterson
Severity
normal
A
A
Andrew Patterson wrote on 10 Jan 2023 23:35
(address . bug-guix@gnu.org)
87wn5uhu31.fsf@gmail.com
openbios-qemu-ppc currently fails to compile on aarch64, with
build errors about missing __u32 and __u16 types somehow existing
in a linux header file that includes the header file that defines
those types. (Log attached.)
Attachment: file
--
Andrew Patterson
R
R
Ricardo Wurmus wrote on 13 Jan 2023 00:17
Re: [aarch64] grub-efi cannot be built because of qemu changes
(address . guix-devel@gnu.org)
875ydbl4up.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (3 lines)
> commit 71b8707100e2fbc00f123566717ba3958c6afabb seems to have broken
> reconfiguration of my aarch64 machine.

A
A
Andrew Patterson wrote on 17 Jan 2023 05:12
Re: bug#60719: Acknowledgement (openbios-qemu-ppc fails to build on aarch64)
87wn5ln5vn.fsf@gmail.com
From altogether too much searching around with gcc -M, it looks
like the problem is that openbios has in its include directory an
asm/types.h. Because things added to the header search path by -I
shadow system headers and are global, this replaces the
<asm/types.h> that <asm/sigcontext.h> relies on, causing the
error. On aarch64, <bits/sigcontext.h> (which I think <signal.h>
includes?) imports <asm/sigcontext.h>, so the whole thing fails to
build. On x86_64, <bits/sigcontext.h> does not import
<asm/sigcontext.h>, so this whole problem never occurs.

I don't know how to fix this on guix's end, but I guess I now need
to complain to upstream and hope they can work out a fix.

(I have a newfound hatred of #include.)
--
Andrew Patterson
A
A
Andrew Patterson wrote on 17 Jan 2023 06:16
87sfg9n3j8.fsf@gmail.com
Toggle quote (4 lines)
> I don't know how to fix this on guix's end, but I guess I now
> need to
> complain to upstream and hope they can work out a fix.

I've submitted an issue to upstream:

--
Andrew Patterson
A
A
Akira Kyle wrote on 30 Jan 2023 01:52
openbios-qemu-ppc fails to build on aarch64
(address . 60719@debbugs.gnu.org)
87cz6wx2rc.fsf@akirakyle.com
Andrew Patterson wrote on 17 Jan 06:16 +0100:

Toggle quote (3 lines)
> I've submitted an issue to upstream:
> https://github.com/openbios/openbios/issues/11

It looks like from the other open issues, that the openbios team doesn't actually use the github issue tracker but their own mailing list, which I'm CC'ing, along with the qemu-ppc mailing list.

For anyone following this issue who wants to work around it and be able to `guix system reconfigure` on aarch64, I've copied the qemu package definition from before Marius unbundled a bunch of the qemu firmware, including openbios, to here:


The relevant parts of my system config are then

(use-modules (akira qemu))

(define %qemu-package-replacements
`((,qemu-minimal . ,my-qemu-minimal)))

(define with-my-qemu
(package-input-rewriting %qemu-package-replacements))

(define my-grub-efi
(with-my-qemu grub-efi))

(define my-grub-efi-bootloader
(bootloader
(inherit grub-efi-bootloader)
(package my-grub-efi)))


(operating-system
...
(bootloader (bootloader-configuration
(bootloader my-grub-efi-bootloader)
(targets '("/boot"))
(keyboard-layout keyboard-layout)))
...)
A
A
Andrew Patterson wrote on 21 Feb 2023 06:08
Re: bug#60719: Acknowledgement (openbios-qemu-ppc fails to build on aarch64)
871qmjiokz.fsf@gmail.com
Fixed as of 042b92edb20648c030dcbaf59acd176731550b70

--
Andrew Patterson
?
Your comment

This issue is archived.

To comment on this conversation send an email to 60719@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60719
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch