[PATCH] gnu: Add python-tcod.

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
Merged with
A
A
Adam Kandur wrote on 18 Dec 2022 22:11
(address . guix-patches@gnu.org)(name . Adam Kandur)(address . manualbot@icloud.com)
20221218211116.3955-1-manualbot@icloud.com
* gnu/packages/game-development.scm (python-tcod): New variable.
---
gnu/packages/game-development.scm | 47 +++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 8fec474d0b..2746c43a5f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -64,6 +64,7 @@ (define-module (gnu packages game-development)
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
+ #:use-module (gnu packages c)
#:use-module (gnu packages compression)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -86,6 +87,7 @@ (define-module (gnu packages game-development)
#:use-module (gnu packages guile)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
#:use-module (gnu packages m4)
@@ -97,6 +99,7 @@ (define-module (gnu packages game-development)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
@@ -2604,6 +2607,50 @@ (define-public libtcod
utilities frequently used in roguelikes.")
(license license:bsd-3)))
+(define-public python-tcod
+ ;; named branch is outdated
+ (let ((commit "d3419a5b4593c7df1580427fc07616d798c85856")
+ (revision "1"))
+ (package
+ (name "python-tcod")
+ (version "13.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libtcod/python-tcod")
+ (commit commit)
+ (recursive? #true)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b0ligrswvz307bbx5jp8wnnqz52v5s4gcgakxy4i3jvccalm2if"))))
+ (build-system python-build-system)
+ ;; tests fail for a strange reason
+ ;; "ERROR docs/conf.py - FileNotFoundError",
+ ;; but this file is in the checkout
+ (arguments
+ '(#:tests? #f))
+ (native-inputs
+ (list sdl2
+ python-pcpp
+ python-pycparser
+ python-requests
+ python-pytest-runner
+ python-pytest-benchmark
+ python-pytest-cov))
+ (propagated-inputs
+ (list python-numpy
+ python-typing-extensions
+ python-cffi))
+ (home-page "https://github.com/libtcod/python-tcod")
+ (synopsis
+ "This library is a Python cffi port of libtcod")
+ (description
+ "A high-performance Python port of libtcod.
+Includes the libtcodpy module for backwards compatibility with older projects.")
+ (license license:bsd-2))))
+
(define-public warsow-qfusion
;; As of 2020-04-09, the latest stable version 2.1.0 is deprecated.
;; The 2.5 beta as published on the homepage is commit
--
2.38.1
L
L
Ludovic Courtès wrote on 26 Jan 2023 10:42
control message for bug #60192
(address . control@debbugs.gnu.org)
87o7qlr5r5.fsf@gnu.org
merge 60192 60193
quit
C
C
Christopher Baines wrote on 1 Mar 2023 10:17
tag 60193 moreinfo
(address . control@debbugs.gnu.org)
877cw0ygmw.fsf@cbaines.net
tags 60193 + moreinfo
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 60193@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 60193
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch