[PATCH] gnu: Add python-tcod.

  • Open
  • quality assurance status badge
Details
4 participants
  • Adam Kandur
  • Ludovic Courtès
  • Christopher Baines
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
Merged with
A
A
Adam Kandur wrote on 18 Dec 2022 22:02
(address . guix-patches@gnu.org)(name . Adam Kandur)(address . manualbot@icloud.com)
20221218210216.3920-1-manualbot@icloud.com
* gnu/packages/game-development.scm (python-tcod): New variable.
---
gnu/packages/game-development.scm | 47 +++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 8fec474d0b..2746c43a5f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -64,6 +64,7 @@ (define-module (gnu packages game-development)
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
+ #:use-module (gnu packages c)
#:use-module (gnu packages compression)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
@@ -86,6 +87,7 @@ (define-module (gnu packages game-development)
#:use-module (gnu packages guile)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages llvm)
#:use-module (gnu packages lua)
#:use-module (gnu packages m4)
@@ -97,6 +99,7 @@ (define-module (gnu packages game-development)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
@@ -2604,6 +2607,50 @@ (define-public libtcod
utilities frequently used in roguelikes.")
(license license:bsd-3)))
+(define-public python-tcod
+ ;; named branch is outdated
+ (let ((commit "d3419a5b4593c7df1580427fc07616d798c85856")
+ (revision "1"))
+ (package
+ (name "python-tcod")
+ (version "13.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libtcod/python-tcod")
+ (commit commit)
+ (recursive? #true)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1b0ligrswvz307bbx5jp8wnnqz52v5s4gcgakxy4i3jvccalm2if"))))
+ (build-system python-build-system)
+ ;; tests fail for a strange reason
+ ;; "ERROR docs/conf.py - FileNotFoundError",
+ ;; but this file is in the checkout
+ (arguments
+ '(#:tests? #f))
+ (native-inputs
+ (list sdl2
+ python-pcpp
+ python-pycparser
+ python-requests
+ python-pytest-runner
+ python-pytest-benchmark
+ python-pytest-cov))
+ (propagated-inputs
+ (list python-numpy
+ python-typing-extensions
+ python-cffi))
+ (home-page "https://github.com/libtcod/python-tcod")
+ (synopsis
+ "This library is a Python cffi port of libtcod")
+ (description
+ "A high-performance Python port of libtcod.
+Includes the libtcodpy module for backwards compatibility with older projects.")
+ (license license:bsd-2))))
+
(define-public warsow-qfusion
;; As of 2020-04-09, the latest stable version 2.1.0 is deprecated.
;; The 2.5 beta as published on the homepage is commit
--
2.38.1
L
L
Ludovic Courtès wrote on 26 Jan 2023 10:42
control message for bug #60192
(address . control@debbugs.gnu.org)
87o7qlr5r5.fsf@gnu.org
merge 60192 60193
quit
L
L
Ludovic Courtès wrote on 26 Jan 2023 10:51
Re: bug#60192: [PATCH] gnu: Add python-tcod.
(name . Adam Kandur)(address . manualbot@icloud.com)(address . 60192@debbugs.gnu.org)
87k019r5ck.fsf@gnu.org
Hi,

Adam Kandur <manualbot@icloud.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/game-development.scm (python-tcod): New variable.

I suggest the attached changes.

However, one comment:

Toggle quote (21 lines)
> + ;; tests fail for a strange reason
> + ;; "ERROR docs/conf.py - FileNotFoundError",
> + ;; but this file is in the checkout
> + (arguments
> + '(#:tests? #f))
> + (native-inputs
> + (list sdl2
> + python-pcpp
> + python-pycparser
> + python-requests
> + python-pytest-runner
> + python-pytest-benchmark
> + python-pytest-cov))
> + (propagated-inputs
> + (list python-numpy
> + python-typing-extensions
> + python-cffi))
> + (home-page "https://github.com/libtcod/python-tcod")
> + (synopsis
> + "This library is a Python cffi port of libtcod")

That ‘FileNotFoundError’, could it be because libtcod itself is missing?
I would expect libtocd to be in ‘inputs’ since this package provides
bindings to libtcod, no?

Toggle quote (4 lines)
> + (description
> + "A high-performance Python port of libtcod.
> +Includes the libtcodpy module for backwards compatibility with older projects.")

Please improve the synopsis and description as per:


Could you send an updated patch?

Thanks,
Ludo’.
Toggle diff (26 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 304df3bd75..dd08241080 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2584,11 +2584,12 @@ (define-public python-tcod
(package
(name "python-tcod")
(version "13.9.1")
+ (home-page "https://github.com/libtcod/python-tcod")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/libtcod/python-tcod")
+ (url home-page)
(commit commit)
(recursive? #true)))
(file-name (git-file-name name version))
@@ -2613,7 +2614,6 @@ (define-public python-tcod
(list python-numpy
python-typing-extensions
python-cffi))
- (home-page "https://github.com/libtcod/python-tcod")
(synopsis
"This library is a Python cffi port of libtcod")
(description
A
A
Adam Kandur wrote on 26 Jan 2023 18:51
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 60192@debbugs.gnu.org)
d1c56dd5-c94d-4adf-b707-d4a8f6d14603@me.com
Sure, I will fix my patch and will try to build the package with suggested input (probably next week).On Jan 26, 2023, at 1:51 AM, Ludovic Courtès <ludo@gnu.org> wrote:Hi,Adam Kandur <manualbot@icloud.com> skribis:* gnu/packages/game-development.scm (python-tcod): New variable.I suggest the attached changes.However, one comment:+ ;; tests fail for a strange reason+ ;; "ERROR docs/conf.py - FileNotFoundError",+ ;; but this file is in the checkout+ (arguments+ '(#:tests? #f))+ (native-inputs+ (list sdl2+ python-pcpp+ python-pycparser+ python-requests+ python-pytest-runner+ python-pytest-benchmark+ python-pytest-cov))+ (propagated-inputs+ (list python-numpy+ python-typing-extensions+ python-cffi))+ (home-page "https://github.com/libtcod/python-tcod")+ (synopsis+ "This library is a Python cffi port of libtcod")That ‘FileNotFoundError’, could it be because libtcod itself is missing?I would expect libtocd to be in ‘inputs’ since this package providesbindings to libtcod, no?+ (description+ "A high-performance Python port of libtcod.+Includes the libtcodpy module for backwards compatibility with older projects.")Please improve the synopsis and description as per: https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.htmlCould you send an updated patch?Thanks,Ludo’.diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scmindex 304df3bd75..dd08241080 100644--- a/gnu/packages/game-development.scm+++ b/gnu/packages/game-development.scm@@ -2584,11 +2584,12 @@ (define-public python-tcod (package (name "python-tcod") (version "13.9.1")+ (home-page "https://github.com/libtcod/python-tcod") (source (origin (method git-fetch) (uri (git-reference- (url "https://github.com/libtcod/python-tcod")+ (url home-page) (commit commit) (recursive? #true))) (file-name (git-file-name name version))@@ -2613,7 +2614,6 @@ (define-public python-tcod (list python-numpy python-typing-extensions python-cffi))- (home-page "https://github.com/libtcod/python-tcod") (synopsis "This library is a Python cffi port of libtcod") (description
<html><body><div><div>Sure, I will fix my patch and will try to build the package with suggested input (probably next week).</div><div><br></div><blockquote type="cite"><div>On Jan 26, 2023, at 1:51 AM, Ludovic Courtès &lt;ludo@gnu.org&gt; wrote:<br></div><div><br></div><div><br></div><div><div><div>Hi,<br></div><div><br></div><div>Adam Kandur &lt;manualbot@icloud.com&gt; skribis:<br></div><div><br></div><blockquote type="cite">* gnu/packages/game-development.scm (python-tcod): New variable.<br></blockquote><div><br></div><div>I suggest the attached changes.<br></div><div><br></div><div>However, one comment:<br></div><div><br></div><blockquote type="cite"><div>+ ;; tests fail for a strange reason<br></div><div>+ ;; "ERROR docs/conf.py - FileNotFoundError",<br></div><div>+ ;; but this file is in the checkout<br></div><div>+ (arguments<br></div><div>+ '(#:tests? #f))<br></div><div>+ (native-inputs<br></div><div>+ (list sdl2<br></div><div>+ python-pcpp<br></div><div>+ python-pycparser<br></div><div>+ python-requests<br></div><div>+ python-pytest-runner<br></div><div>+ python-pytest-benchmark<br></div><div>+ python-pytest-cov))<br></div><div>+ (propagated-inputs<br></div><div>+ (list python-numpy<br></div><div>+ python-typing-extensions<br></div><div>+ python-cffi))<br></div><div>+ (home-page "<a rel="noopener noreferrer" href="https://github.com/libtcod/python-tcod"https://github.com/libtcod/python-tcod /a ") br /div div + (synopsis br /div div + "This library is a Python cffi port of libtcod") br /div /blockquote div br /div div That ‘FileNotFoundError’, could it be because libtcod itself is missing? br /div div I would expect libtocd to be in ‘inputs’ since this package provides br /div div bindings to libtcod, no? br /div div br /div blockquote type="cite" div + (description br /div div + "A high-performance Python port of libtcod. br /div div +Includes the libtcodpy module for backwards compatibility with older projects.") br /div /blockquote div br /div div Please improve the synopsis and description as per: br /div div br /div div a rel="noopener noreferrer" href="https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html" https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html /a br /div div br /div div Could you send an updated patch? br /div div br /div div Thanks, br /div div Ludo’. br /div /div div div diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm br /div div index 304df3bd75..dd08241080 100644 br /div div --- a/gnu/packages/game-development.scm br /div div +++ b/gnu/packages/game-development.scm br /div div @@ -2584,11 +2584,12 @@ (define-public python-tcod br /div div (package br /div div (name "python-tcod") br /div div (version "13.9.1") br /div div + (home-page " a rel="noopener noreferrer" href="https://github.com/libtcod/python-tcod" https://github.com/libtcod/python-tcod /a ") br /div div (source br /div div (origin br /div div (method git-fetch) br /div div (uri (git-reference br /div div - (url " a rel="noopener noreferrer" href="https://github.com/libtcod/python-tcod" https://github.com/libtcod/python-tcod /a ") br /div div + (url home-page) br /div div (commit commit) br /div div (recursive? #true))) br /div div (file-name (git-file-name name version)) br /div div @@ -2613,7 +2614,6 @@ (define-public python-tcod br /div div (list python-numpy br /div div python-typing-extensions br /div div python-cffi)) br /div div - (home-page " a rel="noopener noreferrer" href="https://github.com/libtcod/python-tcod" https://github.com/libtcod/python-tcod /a ") br /div div (synopsis br /div div "This library is a Python cffi port of libtcod") br /div div (description br /div /div /div /blockquote /div div br /div /body /html
C
C
Christopher Baines wrote on 1 Mar 2023 10:17
tag 60193 moreinfo
(address . control@debbugs.gnu.org)
877cw0ygmw.fsf@cbaines.net
tags 60193 + moreinfo
quit
A
A
Adam Kandur wrote on 22 Mar 2023 12:00
Update on issue
(address . 60192@debbugs.gnu.org)
CAJpP0NMxSwkaE05amsnpkVs71P4ZhsW9MQG9+aimgCbLRe-8aw@mail.gmail.com
Hi guix!
First of all, sorry for the late reply.
So, there are 2 problems with this package - turned off tests and
wrong synopsis and description. So I tried to fix it and here is my
suggestions:

1) I have added libtcod to propagated-inputs. Which seems reasonable
because this package provides bindings to it. But unfortunately this
didn't solve the problem with tests. Without them the package works
fine and can be used in projects.

2) I suggest these synopsis and description
(synopsis
"Python port of libtcod")
(description
"Python package which provides bindings to libtcod. This allows Python
users to use libtcod in their Python projects. libtcod itself is a collection
of tools and algorithms for developing traditional roguelikes. Such as
field-of-view, pathfinding, and a tile-based terminal emulator.")

So if these changes are acceptable, can I resend an updated version?
?