[PATCH] scripts: system: Skip initrd modules check when using --target.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 14 Dec 2022 02:53
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
20221214015303.18991-1-maxim.cournoyer@gmail.com
* guix/scripts/system.scm (perform-action): Do not call CHECK-INITRD-MODULES
when the %current-target-system parameter is set.
---
guix/scripts/system.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (31 lines)
diff --git a/guix/scripts/system.scm b/guix/scripts/system.scm
index 6482318168..54a79501ec 100644
--- a/guix/scripts/system.scm
+++ b/guix/scripts/system.scm
@@ -842,7 +842,10 @@ (define bootcfg
(check-mapped-devices os)
(when (zero? (getuid))
(check-file-system-availability (operating-system-file-systems os))
- (check-initrd-modules os)))
+ (unless (%current-target-system)
+ ;; Skip the check if the user is making use of --target, as it doesn't
+ ;; make sense in this context.
+ (check-initrd-modules os))))
(mlet* %store-monad
((sys (system-derivation-for-action image action

base-commit: 0ffa501f2b3e83ae56e9c2bd31418439090e869a
prerequisite-patch-id: 660177fb9eee55d11983ea9360c072730d0d21a5
prerequisite-patch-id: 776778c03bce9b7ad3ab94a120f42b764c00fcae
prerequisite-patch-id: 4910d08bdc27384d76030b6ac491ad2c2ed0957f
prerequisite-patch-id: fd4074fb4cf068ccac3122c19138f098a610542a
prerequisite-patch-id: b9b6f21a2db3f7a5ef82bb11ed23f69749cc6b3d
prerequisite-patch-id: 51cecbabc04c69d4338addaece536c42a075660f
prerequisite-patch-id: 2c67bfd85b343a65440e6c63451e5417129dea6f
prerequisite-patch-id: b24087b240dad97b6417e37176915c24a543e887
prerequisite-patch-id: 2b8e69760af1f7bfb66c1edb44471653b6b229d1
prerequisite-patch-id: 2cb8792eedc8cfc23b4728f9ec44366aa394b954
prerequisite-patch-id: 8684fb6949ced334698dbf32ae71dd76c5eb2cfe
--
2.38.1
L
L
Ludovic Courtès wrote on 21 Dec 2022 14:34
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 60055@debbugs.gnu.org)
87wn6k518n.fsf@gnu.org
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (3 lines)
> * guix/scripts/system.scm (perform-action): Do not call CHECK-INITRD-MODULES
> when the %current-target-system parameter is set.

[...]

Toggle quote (5 lines)
> + (unless (%current-target-system)
> + ;; Skip the check if the user is making use of --target, as it doesn't
> + ;; make sense in this context.
> + (check-initrd-modules os))))

s/doesn’t make sense.*/cannot be checked against the running kernel./

Otherwise LGTM, thanks!

Ludo’.
M
M
Maxim Cournoyer wrote on 21 Dec 2022 20:24
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 60055-done@debbugs.gnu.org)
87zgbg36ho.fsf@gmail.com
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (18 lines)
> Hi,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> * guix/scripts/system.scm (perform-action): Do not call CHECK-INITRD-MODULES
>> when the %current-target-system parameter is set.
>
> [...]
>
>> + (unless (%current-target-system)
>> + ;; Skip the check if the user is making use of --target, as it doesn't
>> + ;; make sense in this context.
>> + (check-initrd-modules os))))
>
> s/doesn’t make sense.*/cannot be checked against the running kernel./
>
> Otherwise LGTM, thanks!

Thanks for precising the comment. Applied with the suggestion!

--
Thanks,
Maxim
Closed
?