[PATCH 00/12] Update fmt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Christopher Baines
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 4 Nov 2022 19:02
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1667584547.git.code@greghogan.com
All dependent packages successfully build except for the already failing
fcitx5-gtk4-5.0.9 and hyperledger-iroha-1.1.1.

The packages dependent on fmt-8 fail to build against the new version of
fmt, even when upgraded.

solidity (dependent on fmt-for-solidity) fails to build against fmt-8,
even when upgraded.

Greg Hogan (12):
gnu: Add fmt-8.
gnu: zxing-cpp: Pin fmt version.
gnu: osm2pgsql: Pin fmt version.
gnu: openimageio: Pin fmt version.
gnu: opendht: Pin fmt version.
gnu: ceph: Pin fmt version.
gnu: spdlog: Update to 1.11.0.
gnu: waybar: Update to 0.9.15.
gnu: blender: Update to 3.3.1.
gnu: libmatroska: Update to 1.7.1.
gnu: mkvtoolnix: Update to 71.1.0.
gnu: fmt: Update to 9.1.0.

gnu/packages/aidc.scm | 2 +-
gnu/packages/geo.scm | 2 +-
gnu/packages/graphics.scm | 6 +++---
gnu/packages/logging.scm | 4 ++--
gnu/packages/networking.scm | 2 +-
gnu/packages/pretty-print.scm | 16 ++++++++++++++--
gnu/packages/storage.scm | 2 +-
gnu/packages/video.scm | 17 ++++++++++-------
gnu/packages/wm.scm | 4 ++--
9 files changed, 35 insertions(+), 20 deletions(-)

--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 02/12] gnu: zxing-cpp: Pin fmt version.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
569f2ecbdbdc9d1c090b1ac32b95a779a8992a7a.1667584547.git.code@greghogan.com
* gnu/packages/aidc.scm (zxing-cpp)[inputs]: Replace fmt with fmt-8.
---
gnu/packages/aidc.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 5e77ae3c5a..5767291cfa 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -65,7 +65,7 @@ (define-public zxing-cpp
"1yl2cpaqiv1g4nq9v0xfj1vd5faz55k4541vz6hsffvcxgn9nmc5"))))
(build-system cmake-build-system)
(native-inputs
- (list fmt googletest))
+ (list fmt-8 googletest))
(synopsis "C++ port of ZXing")
(description "ZXing-CPP is a barcode scanning library.")
(home-page "https://github.com/nu-book/zxing-cpp")
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 03/12] gnu: osm2pgsql: Pin fmt version.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
685da9753c96ca9473b07d31fde49ed931104151.1667584547.git.code@greghogan.com
* gnu/packages/geo.scm (osm2pgsql)[inputs]: Replace fmt with fmt-8.
---
gnu/packages/geo.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index dc5a77e820..9895756864 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1384,7 +1384,7 @@ (define-public osm2pgsql
(list boost
bzip2
expat
- fmt
+ fmt-8
libosmium
lua
postgresql
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 01/12] gnu: Add fmt-8.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
97512642be57edaf1e086df425bee4923dd82959.1667584547.git.code@greghogan.com
* gnu/packages/pretty-print.scm (fmt-8): New variable.
---
gnu/packages/pretty-print.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 9745a9ba10..4f78b32142 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -188,6 +188,18 @@ (define-public fmt
;; The library is bsd-2, but documentation and tests include other licenses.
(license (list bsd-2 bsd-3 psfl))))
+(define-public fmt-8
+ (package
+ (inherit fmt)
+ (version "8.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
+ version "/fmt-" version ".zip"))
+ (sha256
+ (base32 "0p8f82ijqa57sk72hjf0qviv1wwinmns0p87wiv2v8fvisnqnxr3"))))))
+
(define-public fmt-for-solidity
(package
(inherit fmt)
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 04/12] gnu: openimageio: Pin fmt version.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
d7e699982e15bde61063a16a99fd6604b4c1db56.1667584547.git.code@greghogan.com
* gnu/packages/graphics.scm (openimageio)[inputs]: Replace fmt with
fmt-8.
---
gnu/packages/graphics.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 1d19e1b388..68f78b06af 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1251,7 +1251,7 @@ (define-public openimageio
(list pkg-config))
(inputs
`(("boost" ,boost)
- ("fmt" ,fmt)
+ ("fmt" ,fmt-8)
("libheif" ,libheif)
("libpng" ,libpng)
("libjpeg" ,libjpeg-turbo)
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 05/12] gnu: opendht: Pin fmt version.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
46b3e0ecad811ce26c7cac6bd1771f70d76cabef.1667584547.git.code@greghogan.com
* gnu/packages/networking.scm (opendht)[inputs]: Replace fmt with
fmt-8.
---
gnu/packages/networking.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cd095a0ed8..1cd9495412 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3737,7 +3737,7 @@ (define-public opendht
(chmod dhtcluster #o555)
(wrap-program dhtcluster
`("GUIX_PYTHONPATH" prefix (,site-packages)))))))))
- (inputs (list bash-minimal fmt readline))
+ (inputs (list bash-minimal fmt-8 readline))
(propagated-inputs
(list msgpack ;included in several installed headers
restinio ;included in opendht/http.h
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 06/12] gnu: ceph: Pin fmt version.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
09b334bab7d9e69522dae22bc6ede407a1135a97.1667584547.git.code@greghogan.com
* gnu/packages/storage.scm (ceph)[inputs]: Replace fmt with fmt-8.
---
gnu/packages/storage.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 86ae1c883f..9d360e8eb3 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -201,7 +201,7 @@ (define-public ceph
("cryptsetup" ,cryptsetup)
("expat" ,expat)
("fcgi" ,fcgi)
- ("fmt" ,fmt)
+ ("fmt" ,fmt-8)
("fuse" ,fuse)
("icu4c" ,icu4c)
("jemalloc" ,jemalloc)
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 07/12] gnu: spdlog: Update to 1.11.0.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
8d1e9ba92754bada5dd8992472e9ba56de5f6fd2.1667584547.git.code@greghogan.com
* gnu/packages/logging.scm (spdlog): Update to 1.11.0.
---
gnu/packages/logging.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 2781ac5194..ab08574bbd 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -212,7 +212,7 @@ (define-public multitail
(define-public spdlog
(package
(name "spdlog")
- (version "1.10.0")
+ (version "1.11.0")
(source
(origin
(method git-fetch)
@@ -221,7 +221,7 @@ (define-public spdlog
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "02xz017ba9fssm1rp1fcfld7h79awbr6fqai9dxaqp02akp3davk"))
+ (base32 "0i3a1cqrg1sz0w50g7zz9x73rf838igqri12q8ijh4rzpq0qq3ch"))
(modules '((guix build utils)))
(snippet
;; Prevent race on busy hardware. Remove snippet for versions
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 08/12] gnu: waybar: Update to 0.9.15.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
57bfbde6d81f8560a94335c8a186e9d633cb6b37.1667584547.git.code@greghogan.com
* gnu/packages/wm.scm (waybar): Update to 0.9.15.
---
gnu/packages/wm.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index eedd339c6c..78aa79a05d 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1722,7 +1722,7 @@ (define-public swaybg
(define-public waybar
(package
(name "waybar")
- (version "0.9.13")
+ (version "0.9.15")
(source
(origin
(method git-fetch)
@@ -1731,7 +1731,7 @@ (define-public waybar
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "15fy21cipih80amv78g7g4k2gylf107phbv0fjacn3w3n0i3cf2k"))))
+ (base32 "0mvwsd3krrlniga0fq13b0qvsf1fj22mk9nzsfgz49r55lqw8sdv"))))
(build-system meson-build-system)
(inputs (list date
fmt
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 09/12] gnu: blender: Update to 3.3.1.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
2546207cd50f7a601d1ba74279057c9d83a89aef.1667584547.git.code@greghogan.com
* gnu/packages/graphics.scm (blender): Update to 3.3.1.
---
gnu/packages/graphics.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 68f78b06af..200f9dcaea 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -429,14 +429,14 @@ (define-public openvdb
(define-public blender
(package
(name "blender")
- (version "3.0.1")
+ (version "3.3.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.blender.org/source/"
"blender-" version ".tar.xz"))
(sha256
(base32
- "0hblgls5pclqamsxk0vb14f4fm30hdiq7fb2bm5mq2ly4sb0mfqr"))))
+ "1jlc26axbhh97d2j6kfg9brgiq8j412mgmw7p41ah34apzq4inia"))))
(build-system cmake-build-system)
(arguments
(let ((python-version (version-major+minor (package-version python))))
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 10/12] gnu: libmatroska: Update to 1.7.1.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
2f18610f046f49db3ee59e6d43218b8933962c6d.1667584547.git.code@greghogan.com
* gnu/packages/video.scm (libmatroska): Update to 1.7.1.
---
gnu/packages/video.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a75be99b58..4e449c7e42 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1433,14 +1433,14 @@ (define-public libdv
(define-public libmatroska
(package
(name "libmatroska")
- (version "1.6.3")
+ (version "1.7.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://dl.matroska.org/downloads/"
"libmatroska/libmatroska-" version ".tar.xz"))
(sha256
- (base32 "06h81sxyz2riic0gpzik6ffcnq32wrqphi8c6k55glcdymiimyfs"))))
+ (base32 "1cqq61qgv6x3xjzjrw71dya7lbsbrsmi9raqm2k4hgfrp0rk0ajp"))))
(build-system cmake-build-system)
(inputs
(list libebml))
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 11/12] gnu: mkvtoolnix: Update to 71.1.0.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
906eb6fbb6d497a754df9b1560a512e76e235a62.1667584547.git.code@greghogan.com
* gnu/packages/video.scm (mkvtoolnix): Update to 71.1.0.
[inputs]: Add gmp, qtsvg; replace qtbase-5 with qtbase and
qtmultimedia-5 with qtmultimedia.
[native-inputs]: Replace qttools-5 with qttools.
---
gnu/packages/video.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4e449c7e42..1b36ba2292 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -157,6 +157,7 @@ (define-module (gnu packages video)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages multiprecision)
#:use-module (gnu packages music)
#:use-module (gnu packages mp3)
#:use-module (gnu packages ncurses)
@@ -980,14 +981,14 @@ (define-public libx264
(define-public mkvtoolnix
(package
(name "mkvtoolnix")
- (version "52.0.0")
+ (version "71.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://mkvtoolnix.download/sources/"
"mkvtoolnix-" version ".tar.xz"))
(sha256
- (base32 "15y7ahlifsclnkl70wn5w34dil8nwcwcjnw3k2ydqc6dz4vb0j5s"))
+ (base32 "0iyarx9cpbb54aizhklk8x64j9ml0f2mbp3rd00sk762hgjl6d0m"))
(modules '((guix build utils)))
(snippet '(begin
;; Delete bundled libraries.
@@ -1009,6 +1010,7 @@ (define-public mkvtoolnix
file
flac
fmt
+ gmp
libdvdread
libmatroska
libogg
@@ -1016,8 +1018,9 @@ (define-public mkvtoolnix
lzo
pcre2
pugixml
- qtbase-5
- qtmultimedia-5
+ qtbase
+ qtmultimedia
+ qtsvg
utfcpp
zlib))
(native-inputs
@@ -1029,7 +1032,7 @@ (define-public mkvtoolnix
("perl" ,perl)
("pkg-config" ,pkg-config)
("po4a" ,po4a)
- ("qttools-5" ,qttools-5)
+ ("qttools" ,qttools)
("ruby" ,ruby)))
(arguments
`(#:configure-flags
--
2.38.0
G
G
Greg Hogan wrote on 4 Nov 2022 19:04
[PATCH 12/12] gnu: fmt: Update to 9.1.0.
(address . 59020@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
7d152c24593ad22d7c614920746ccdc1cb50fe52.1667584547.git.code@greghogan.com
* gnu/packages/pretty-print.scm (fmt): Update to 9.1.0.
---
gnu/packages/pretty-print.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 4f78b32142..eb14691e1d 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -166,14 +166,14 @@ (define-public enscript
(define-public fmt
(package
(name "fmt")
- (version "8.1.1")
+ (version "9.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
version "/fmt-" version ".zip"))
(sha256
- (base32 "0p8f82ijqa57sk72hjf0qviv1wwinmns0p87wiv2v8fvisnqnxr3"))))
+ (base32 "15n9yi6xzzs7g9rm87kg8y5yhl2zrqj3bjr845saa63f6swlrsyc"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
--
2.38.0
C
C
Christopher Baines wrote on 7 Nov 2022 08:23
Re: [bug#59020] [PATCH 00/12] Update fmt.
(name . Greg Hogan)(address . code@greghogan.com)
87k047fcop.fsf@cbaines.net
Greg Hogan <code@greghogan.com> writes:

Toggle quote (3 lines)
> All dependent packages successfully build except for the already failing
> fcitx5-gtk4-5.0.9 and hyperledger-iroha-1.1.1.

Thanks for working on this Greg. I happened to look here
https://qa.guix.gnu.org/issue/59020and that suggests that there may be
some dependent packages that fail to build.

This is the list:


In particular, mpd stood out to me.

Does that match up with what you're seeing locally?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNoswZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcRTQ/6AihcmfPM93EK7P07y2YK9mQa/gvJsCWv
AM5E90gTIWKQJEHujThTGkNS51eRFaTwAilRv3+ObWXPlBlMzyKJfeB0YKu5+gOj
AP5PpvrlCA5nRqEYpbHaPEECb9qNGrJRSPhrWal61PIYt9+pTeBbzqpG/9dHCXu/
x7/fF+oZmt/YfSy2BQXoqwjBbdKBsVpgHyLrdXY4YAU3zaFjyGAomPdTnU5W3IVj
nmcSopS5McFy3vCk6wFkiJeyYyp/K/dPTsaDET+ow/vOaRrULc9C9QtJqErlaFI9
IOWvuEGdhnm7Oiw3+oGG5TdGOs5UsIrE3qdsGS5ZpkT+17kfmrJ5AyQl+Q41rRq/
MlnTrAI8QemeTVVOHSTvZefullrZ/oP9fidKD8Ifj85VuCMqtUHblao6OSByjVsz
9as6CSC3TjMyhDEzVz90fRUfz51AU+R7RfF/58CUvcYO55LHXwzuq+1FATdOjRHy
AgXmUp1HOt4VinXWRMq+WRrWvOLJ8Ww4VHZTi4Zs5xlWLDXIqwLlc68c79obGH28
qmrcjTD4HBMlZtgW5t9/0LX2vq0mD9yHFBEWtpuYQjDB/i08IXfFFUJIqWZnMWLP
9frx0ABOy+18mVUxGiCFf9j70jgPNom6TVz2kJrxva/CaiNqHQ5ICZ4fcLeoK1X7
1gSrk+kDW9k=
=IzYd
-----END PGP SIGNATURE-----

G
G
Greg Hogan wrote on 6 Mar 20:25 +0100
(address . 59020-done@debbugs.gnu.org)(address . guix-patches@gnu.org)
CA+3U0Z=URh8ciDHdBo6LvWT-ezukyEQzkUD0kpO3kd11hEWitw@mail.gmail.com
On Mon, Nov 7, 2022 at 2:26?AM Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (23 lines)
>
>
> Greg Hogan <code@greghogan.com> writes:
>
> > All dependent packages successfully build except for the already failing
> > fcitx5-gtk4-5.0.9 and hyperledger-iroha-1.1.1.
>
> Thanks for working on this Greg. I happened to look here
> https://qa.guix.gnu.org/issue/59020 and that suggests that there may be
> some dependent packages that fail to build.
>
> This is the list:
>
> https://data.qa.guix.gnu.org/compare/package-derivations?base_commit=31e46e71e07fe272626da6c3e2a90d02a02b2b47&target_commit=1c7de64a27905a59f326cf6a334f61862f00484b&system=i686-linux&target=none&build_change=broken
>
> In particular, mpd stood out to me.
>
> Does that match up with what you're seeing locally?
>
> Thanks,
>
> Chris

This issue is still listed as open at
https://issues.guix.gnu.org/59020even though Chris sent this response
to 59020-done (and I received the "closed" email). So I will attempt a
second closing of this issue.

Greg
?