---
gnu/packages/crypto.scm | 57 +++++++++++++++++++++--------------------
1 file changed, 29 insertions(+), 28 deletions(-)
Toggle diff (72 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index ac6055265f..2221479f4d 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2022 Allan Adair <allan@adair.no>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2022 Jacob 'Kreyren' Hrbek <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1741,31 +1742,31 @@ (define-public keychain
(license license:gpl2)))
(define-public zsign
- (package
- (name "zsign")
- (version "21012022")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/zhlynn/zsign")
- (commit "27016df1150eeaf27e8d8c148ccb3cad10d31e73")))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1vszwpxaaxs0iy7mrkn6wmjdv9nb4nmwzki5i7zgjayiczshjx8d"))))
- (build-system cmake-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (delete 'check) ; Seemingly no test suite
- (replace 'install
- (lambda _
- (install-file "zsign"
- (string-append %output "/bin/"))
- #t)))))
- (native-inputs
- (list openssl
- zlib))
- (synopsis "FIXME")
- (description "FIXME")
- (home-page "https://github.com/zhlynn/zsign")
- (license license:bsd-3)))
+ (let ((commit "27016df1150eeaf27e8d8c148ccb3cad10d31e73"))
+ (package
+ (name "zsign")
+ (version (git-version "0.0.0" "0" commit)) ;no release tag
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zhlynn/zsign")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vszwpxaaxs0iy7mrkn6wmjdv9nb4nmwzki5i7zgjayiczshjx8d"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'check) ;Seemingly no test suite
+ (replace 'install
+ (lambda _
+ (install-file "zsign"
+ (string-append %output "/bin/")) #t)))))
+ (native-inputs (list openssl zlib))
+ (synopsis
+ "Solution for signature of application archive files (.ipa) for iDevices")
+ (description
+ "Usually used by cross-platform developers and jailbreakers to sign their applications")
+ (home-page "https://github.com/zhlynn/zsign")
+ (license license:bsd-3))))