[PATCH] zsign: New package

  • Open
  • quality assurance status badge
Details
One participant
  • Jacob Hrbek
Owner
unassigned
Submitted by
Jacob Hrbek
Severity
normal
J
J
Jacob Hrbek wrote on 8 Oct 2022 23:46
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
DgEwwmb1UpF3-ZnoEKFogCk5DgJWrr7DhZgLwrAtEg7p4TEj4lhAnw0hVt_PrPPDFC0FoN9-WyS-OURaUWoBmKdmM3niZf9LL3Uv3MCCzs4=@rixotstudio.cz
zsign is a libre code signature alternative to sign application archive files (.ipa) used mainly by cross-platform developers and jailbreakers to install alternative OS on their idevices such as GNU Guix on iPad2 (me)[1].

I didn't find any test suite in the repository so the 'check' phase was removed.

Packaging checklist:

- [X] guix lint PACKAGE? passes
- [X] Code formatted using guix style PACKAGE
- [X] Build log attached with proof of the package working
- [X] Submitted into a correct branch -- No dependent packages other then itself -> Master

References:

- Tracking of installing GNU Guix on iPad2 -- https://git.dotya.ml/kreyren/kreyren/issues/30
Attachment: file
Attachment: zsign-build.log
J
J
Jacob Hrbek wrote on 8 Oct 2022 23:56
(address . 58385@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221008215315.2640-1-kreyren@rixotstudio.cz
---
gnu/packages/crypto.scm | 57 +++++++++++++++++++++--------------------
1 file changed, 29 insertions(+), 28 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index ac6055265f..2221479f4d 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2022 Allan Adair <allan@adair.no>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2022 Jacob 'Kreyren' Hrbek <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1741,31 +1742,31 @@ (define-public keychain
(license license:gpl2)))

(define-public zsign
- (package
- (name "zsign")
- (version "21012022")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/zhlynn/zsign")
- (commit "27016df1150eeaf27e8d8c148ccb3cad10d31e73")))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1vszwpxaaxs0iy7mrkn6wmjdv9nb4nmwzki5i7zgjayiczshjx8d"))))
- (build-system cmake-build-system)
- (arguments
- `(#:phases (modify-phases %standard-phases
- (delete 'check) ; Seemingly no test suite
- (replace 'install
- (lambda _
- (install-file "zsign"
- (string-append %output "/bin/"))
- #t)))))
- (native-inputs
- (list openssl
- zlib))
- (synopsis "FIXME")
- (description "FIXME")
- (home-page "https://github.com/zhlynn/zsign")
- (license license:bsd-3)))
+ (let ((commit "27016df1150eeaf27e8d8c148ccb3cad10d31e73"))
+ (package
+ (name "zsign")
+ (version (git-version "0.0.0" "0" commit)) ;no release tag
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zhlynn/zsign")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vszwpxaaxs0iy7mrkn6wmjdv9nb4nmwzki5i7zgjayiczshjx8d"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'check) ;Seemingly no test suite
+ (replace 'install
+ (lambda _
+ (install-file "zsign"
+ (string-append %output "/bin/")) #t)))))
+ (native-inputs (list openssl zlib))
+ (synopsis
+ "Solution for signature of application archive files (.ipa) for iDevices")
+ (description
+ "Usually used by cross-platform developers and jailbreakers to sign their applications")
+ (home-page "https://github.com/zhlynn/zsign")
+ (license license:bsd-3))))
--
2.37.3
J
J
Jacob Hrbek wrote on 9 Oct 2022 00:17
(address . 58385@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221008221728.12290-1-kreyren@rixotstudio.cz
---
gnu/packages/crypto.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 074fa5bf31..2221479f4d 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2022 Allan Adair <allan@adair.no>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2022 Jacob 'Kreyren' Hrbek <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1739,3 +1740,33 @@ (define-public keychain
configured to start gpg-agent.")
(home-page "https://www.funtoo.org/Keychain")
(license license:gpl2)))
+
+(define-public zsign
+ (let ((commit "27016df1150eeaf27e8d8c148ccb3cad10d31e73"))
+ (package
+ (name "zsign")
+ (version (git-version "0.0.0" "0" commit)) ;no release tag
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zhlynn/zsign")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vszwpxaaxs0iy7mrkn6wmjdv9nb4nmwzki5i7zgjayiczshjx8d"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'check) ;Seemingly no test suite
+ (replace 'install
+ (lambda _
+ (install-file "zsign"
+ (string-append %output "/bin/")) #t)))))
+ (native-inputs (list openssl zlib))
+ (synopsis
+ "Solution for signature of application archive files (.ipa) for iDevices")
+ (description
+ "Usually used by cross-platform developers and jailbreakers to sign their applications")
+ (home-page "https://github.com/zhlynn/zsign")
+ (license license:bsd-3))))
--
2.37.3
J
J
Jacob Hrbek wrote on 9 Oct 2022 00:30
(address . 58385@debbugs.gnu.org)(name . Jacob Hrbek)(address . kreyren@rixotstudio.cz)
20221008223035.19868-1-kreyren@rixotstudio.cz
---
gnu/packages/crypto.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 074fa5bf31..f458e6a264 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2022 Allan Adair <allan@adair.no>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2022 Jacob 'Kreyren' Hrbek <kreyren@rixotstudio.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1739,3 +1740,33 @@ (define-public keychain
configured to start gpg-agent.")
(home-page "https://www.funtoo.org/Keychain")
(license license:gpl2)))
+
+(define-public zsign
+ (let ((commit "27016df1150eeaf27e8d8c148ccb3cad10d31e73"))
+ (package
+ (name "zsign")
+ (version (git-version "0.0.0" "0" commit)) ;no release tag
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zhlynn/zsign")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vszwpxaaxs0iy7mrkn6wmjdv9nb4nmwzki5i7zgjayiczshjx8d"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (delete 'check) ;Seemingly no test suite
+ (replace 'install
+ (lambda _
+ (install-file "zsign"
+ (string-append %output "/bin/")) #t)))))
+ (native-inputs (list openssl zlib))
+ (synopsis
+ "Solution for signature of application archive files (.ipa) for iDevices")
+ (description
+ "Usually used by cross-platform developers and jailbreakers to sign their applications")
+ (home-page "https://github.com/zhlynn/zsign")
+ (license license:bsd-3))))
--
2.37.3
J
J
Jacob Hrbek wrote on 9 Oct 2022 00:32
(name . 58385@debbugs.gnu.org)(address . 58385@debbugs.gnu.org)
wr4qAJDwcM_ybvbdzvhTRujlrJadI2kTitnaNSAzb7rFbJ95P6rFFWFKwPvpfyxZ8X28NpguYePkUVWVIWVDViTYdjwb0EZlYEPHanzjoTk=@rixotstudio.cz
Discard the https://issues.guix.gnu.org/58385#1and https://issues.guix.gnu.org/58385#2
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 58385@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58385
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch