[PATCH] gnu: blesh: Substitute with readlink directly.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
ba9bb18465c2c2ee97d4619779ac3037d46664f7.1664657752.git.kiasoc5@disroot.org
---
gnu/packages/bash.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 86af26d648..7545f331e6 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -483,8 +483,7 @@ (define-public blesh
(lambda _
(substitute* "ble.pp"
(("PATH=/bin:/usr/bin readlink")
- (search-input-file %build-inputs
- "/bin/readlink")))))
+ "readlink"))))
(delete 'configure) ;no configure
(add-before 'check 'use-LANG-for-tests
(lambda _

base-commit: cbe8391d7c570a12416acfbfbbb818404d8b9203
--
2.37.3
Ludovic Courtès wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 58234-done@debbugs.gnu.org)
87lepo4up5.fsf@gnu.org
Hi,

kiasoc5 <kiasoc5@disroot.org> skribis:

Toggle quote (2 lines)
I added a commit log and applied it, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 58234@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58234
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help