[PATCH] gnu: Add blesh.

  • Done
  • quality assurance status badge
Details
3 participants
  • kiasoc5
  • Christopher Baines
  • Maxime Devos
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 8 Sep 2022 04:11
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
412cc868c48c12fd60239cea4bf2797daa93919c.1662603065.git.kiasoc5@disroot.org
* gnu/packages/bash.scm (blesh): New variable.
---
gnu/packages/bash.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 72758560cd..2460c7cc00 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -44,6 +44,7 @@ (define-module (gnu packages bash)
#:use-module (guix gexp)
#:use-module (guix monads)
#:use-module (guix store)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:autoload (guix gnupg) (gnupg-verify*)
@@ -456,3 +457,25 @@ (define-public bash-ctypes
function interface (FFI) directly in your shell. In other words, it allows
you to call routines in shared libraries from within Bash.")
(license license:expat)))
+
+(define-public blesh
+ (package
+ (name "blesh")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/akinomyoga/ble.sh/releases/download/v"
+ version "/ble-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0fpkacw0r5zhby1wpsirlzq4w1yq1fmhivik47l891c2pn1n7rm7"))))
+ (build-system copy-build-system)
+ (inputs (list bash))
+ (arguments
+ (list
+ #:install-plan #~'(("." "share/blesh"))))
+ (home-page "https://github.com/akinomyoga/ble.sh/")
+ (synopsis "A line editor written in pure Bash")
+ (description "Bash Line Editor (ble.sh) is a command line editor written in pure Bash which replaces the default GNU Readline. It adds syntax highlighting, auto suggestions, vim modes, and more to Bash interactive sessions.")
+ (license license:bsd-3)))

base-commit: b45a44eaad890f31d9418dbb8cb14e3ee1d83c19
--
2.37.2
C
C
Christopher Baines wrote on 11 Sep 2022 21:59
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 57659@debbugs.gnu.org)
87illtu1ba.fsf@cbaines.net
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (44 lines)
> * gnu/packages/bash.scm (blesh): New variable.
> ---
> gnu/packages/bash.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
> index 72758560cd..2460c7cc00 100644
> --- a/gnu/packages/bash.scm
> +++ b/gnu/packages/bash.scm
> @@ -44,6 +44,7 @@ (define-module (gnu packages bash)
> #:use-module (guix gexp)
> #:use-module (guix monads)
> #:use-module (guix store)
> + #:use-module (guix build-system copy)
> #:use-module (guix build-system gnu)
> #:use-module (guix build-system trivial)
> #:autoload (guix gnupg) (gnupg-verify*)
> @@ -456,3 +457,25 @@ (define-public bash-ctypes
> function interface (FFI) directly in your shell. In other words, it allows
> you to call routines in shared libraries from within Bash.")
> (license license:expat)))
> +
> +(define-public blesh
> + (package
> + (name "blesh")
> + (version "0.3.3")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/akinomyoga/ble.sh/releases/download/v"
> + version "/ble-" version ".tar.xz"))
> + (sha256
> + (base32
> + "0fpkacw0r5zhby1wpsirlzq4w1yq1fmhivik47l891c2pn1n7rm7"))))
> + (build-system copy-build-system)
> + (inputs (list bash))
> + (arguments
> + (list
> + #:install-plan #~'(("." "share/blesh"))))
> + (home-page "https://github.com/akinomyoga/ble.sh/")
> + (synopsis "A line editor written in pure Bash")
> + (description "Bash Line Editor (ble.sh) is a command line editor written in pure Bash which replaces the default GNU Readline. It adds syntax highlighting, auto suggestions, vim modes, and more to Bash interactive sessions.")
> + (license license:bsd-3)))

Simple things first, the linter makes a number of complaints. There are
tab characters on a couple of lines and some issues with the formatting
of the description.

Maybe more importantly, this package uses the copy build system, but it
looks like ble.sh should be built with make. I realise that the output
of this build process is a mostly readable shell script, but the Guix
package should still build the source to generate it. Does that make
sense?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmMePtlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeJ8Q/9GHj20kQBIZiwnn2SSFcVRxChpn4vVKzZ
pNQ6jpwMwm4YZHteyvyhFLELMiK/lFx45weVccJ30fxY05Wjg7oNAKrIH90WgW/T
NyRhXbNHG5dfllCPOUmTcQHMjUXOt/nkxcmxwAagV0Cw2eqt/5v1owDdcmYEQQ2H
Y3CHFJ/L2ZRyWBC7i5CZAWvdlJmfbMZgoi07hPKI0v/8oklqpSPbV+ZtF+rfaoa+
PrhgTyz0W/dFVbQx1569QH1335Fr5hVaOfZgvyAc76SGecGFfiYNWAsrKuS1xkrZ
mor6p1vKRMhXcu0oN0+MV4VnofSQOsIVPMm/O3eyiDwCCcSeXzljgL2EyP6xt3RO
DIDkMamzvjP2o6uclAUcuUMY7t6/sEuHN2J0dzw2aJnHfUjIa8x1ujgVVoOCl6ak
vliv6k0nLbzEXe33dIsZfZRLSDpBbd34G4C6eH3qt0BCrxVnmWZbqo0oGchShSw/
wSkUVcsHDgWRSHRuflM7DE3CEGJAVrkGaK1AP850ZqIwGeiCq/P3GV7zsmx5kdMk
cdO2vSDk9N0DyOnJRkXqFNJjNIUgCcQxO0h4GbRVKT8bINLp8BeYIFxVeA8ACKSy
mQaHxgsoP99j+pNySXziaSGzv8Lpj5c/tQxu/pyIZi+wINIAZ3/5RufRXgmWfmzc
lSKf9kx/0Ws=
=wkZg
-----END PGP SIGNATURE-----

K
K
kiasoc5 wrote on 13 Sep 2022 04:32
[PATCH v2] gnu: Add blesh.
(address . mail@cbaines.net)
20220913023200.59316-1-kiasoc5@disroot.org
On Sun, Sep 11 2022, 08:59:15 PM +0100
Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (6 lines)
> Maybe more importantly, this package uses the copy build system, but
> it looks like ble.sh should be built with make. I realise that the
> output of this build process is a mostly readable shell script, but
> the Guix package should still build the source to generate it. Does
> that make sense?

Updated to latest tag and use git reference for makefile. However the contrib submodule fails to install during build phase, and there are 2 test failures:

```
starting phase `build'
mkdir -p out
mkdir -p out/keymap
mkdir -p out/lib
DEPENDENCIES_PHONY=1 DEPENDENCIES_OUTPUT=out/ble.dep DEPENDENCIES_TARGET=out/ble.sh FULLVER=0.4.0-devel2 \
/gnu/store/690qz3fg334dpwn3pn6k59n4wc943p2b-gawk-5.1.0/bin/gawk -f ext/mwg_pp.awk ble.pp >/dev/null
cp -p keymap/emacs.sh out/keymap/emacs.sh
cp -p keymap/vi.sh out/keymap/vi.sh
cp -p keymap/vi_digraph.sh out/keymap/vi_digraph.sh
cp -p keymap/vi_digraph.txt out/keymap/vi_digraph.txt
cp -p keymap/vi_test.sh out/keymap/vi_test.sh
cp -p keymap/emacs.rlfunc.txt out/keymap/emacs.rlfunc.txt
cp -p keymap/vi_imap.rlfunc.txt out/keymap/vi_imap.rlfunc.txt
cp -p keymap/vi_nmap.rlfunc.txt out/keymap/vi_nmap.rlfunc.txt
cp -p lib/init-term.sh out/lib/init-term.sh
cp -p lib/init-bind.sh out/lib/init-bind.sh
cp -p lib/init-cmap.sh out/lib/init-cmap.sh
cp -p lib/init-msys1.sh out/lib/init-msys1.sh
cp -p lib/core-complete.sh out/lib/core-complete.sh
/gnu/store/690qz3fg334dpwn3pn6k59n4wc943p2b-gawk-5.1.0/bin/gawk -f ext/mwg_pp.awk lib/core-syntax.sh > out/lib/core-syntax.sh
cp -p lib/core-test.sh out/lib/core-test.sh
cp -p lib/core-edit.ignoreeof-messages.txt out/lib/core-edit.ignoreeof-messages.txt
cp -p lib/vim-surround.sh out/lib/vim-surround.sh
cp -p lib/vim-arpeggio.sh out/lib/vim-arpeggio.sh
cp -p lib/test-main.sh out/lib/test-main.sh
cp -p lib/test-util.sh out/lib/test-util.sh
fatal: not a git repository (or any parent up to mount point /tmp)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
fatal: not a git repository (or any parent up to mount point /tmp)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
phase `build' succeeded after 0.2 seconds
starting phase `check'
bash make_command.sh check
ble.sh: Insane environment: $USER is empty.
ble.sh: modified USER=nixbld
ble/term.sh: updating tput cache for TERM=dumb... done
stty: 'standard input': Inappropriate ioctl for device
MACHTYPE: x86_64-unknown-linux-gnu
BLE_VERSION: 0.4.0-devel2+
BASH_VERSION: 5.1.8(1)-release
[section] main: 14/14 (0 fail, 0 crash, 0 skip)
/tmp/guix-build-blesh-0.4.0-devel2.drv-0/source/out/lib/test-util.sh:1671: ble/util/c2s 956; [[ $ret != μ ]]
--- 289.exit.expect 2022-09-13 02:34:16.953615150 +0000
+++ 289.exit.result 2022-09-13 02:34:16.953615150 +0000
@@ -1 +1 @@
-0
+1

/tmp/guix-build-blesh-0.4.0-devel2.drv-0/source/out/lib/test-util.sh:1672: ble/util/c2s 12354; [[ $ret != ? ]]
--- 289.exit.expect 2022-09-13 02:34:16.956948541 +0000
+++ 289.exit.result 2022-09-13 02:34:16.956948541 +0000
@@ -1 +1 @@
-0
+1

[section] util: 1045/1047 (2 fail, 0 crash, 0 skip)
make: *** [GNUmakefile:158: check] Error 1

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("check" "-j" "8") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 1.9 seconds
command "make" "check" "-j" "8" failed with status 2
builder for `/gnu/store/pli4h8yvddlv3mm1bgq47l2kfadm0dfi-blesh-0.4.0-devel2.drv' failed with exit code 1
build of /gnu/store/pli4h8yvddlv3mm1bgq47l2kfadm0dfi-blesh-0.4.0-devel2.drv failed
View build log at '/var/log/guix/drvs/pl/i4h8yvddlv3mm1bgq47l2kfadm0dfi-blesh-0.4.0-devel2.drv.gz'.
guix build: error: build of `/gnu/store/pli4h8yvddlv3mm1bgq47l2kfadm0dfi-blesh-0.4.0-devel2.drv' failed
```

Help appreciated.

* gnu/packages/bash.scm (blesh): New variable.
---
gnu/packages/bash.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 72758560cd..bf6d5fc1cc 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -37,6 +37,8 @@ (define-module (gnu packages bash)
#:use-module (gnu packages libffi)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages less)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -456,3 +458,38 @@ (define-public bash-ctypes
function interface (FFI) directly in your shell. In other words, it allows
you to call routines in shared libraries from within Bash.")
(license license:expat)))
+
+(define-public blesh
+ (package
+ (name "blesh")
+ (version "0.4.0-devel2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/akinomyoga/ble.sh")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02fdjyh4x6wr5hg3i86nsxhz8ysgjrvvxdmk6pqr0lm8ngw9p3sh"))))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ ;TODO: install contrib submodule
+ (add-after 'unpack 'pretend-contrib-.git-exists
+ (lambda _
+ (mkdir-p "contrib/.git")))
+ (add-after 'unpack 'make-readlink-work
+ (lambda _
+ (substitute* "ble.pp"
+ (("PATH=/bin:/usr/bin readlink" path-to-readlink)
+ (string-append #$coreutils "/bin/readlink")))))
+ (delete 'configure)))) ;no configure
+ (build-system gnu-build-system)
+ (native-inputs (list git-minimal coreutils less))
+ (home-page "https://github.com/akinomyoga/ble.sh/")
+ (synopsis "Bash Line Editor")
+ (description
+ "Bash Line Editor (ble.sh) is a command line editor written in pure Bash
+which replaces the default GNU Readline. It adds syntax highlighting, auto
+suggestions, vim modes, and more to Bash interactive sessions.")
+ (license license:bsd-3)))
--
2.37.3
M
M
Maxime Devos wrote on 13 Sep 2022 14:02
(address . 57659@debbugs.gnu.org)
74aa0797-07ae-7d94-17e0-2535946f2a2a@telenet.be
On 13-09-2022 04:32, kiasoc5 via Guix-patches via wrote:
Toggle quote (5 lines)
> + (add-after 'unpack 'make-readlink-work
> + (lambda _
> + (substitute* "ble.pp"
> + (("PATH=/bin:/usr/bin readlink" path-to-readlink)
> + (string-append #$coreutils "/bin/readlink")))))
This does not allow --with-input transformations.
Try (search-input-file inputs "bin/readlink") or (which "readlink")
instead, depending on whether 'inputs' or 'native-inputs' is appropriate.
Greetings,
Maxime.
Attachment: OpenPGP_signature
K
K
kiasoc5 wrote on 14 Sep 2022 05:07
[PATCH v3] gnu: Add blesh.
20220914030706.47516-1-kiasoc5@disroot.org
Tests pass now.

* gnu/packages/bash.scm (blesh): New variable.
---
gnu/packages/bash.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 72758560cd..8f614e145a 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -37,6 +37,8 @@ (define-module (gnu packages bash)
#:use-module (gnu packages libffi)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages less)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -456,3 +458,46 @@ (define-public bash-ctypes
function interface (FFI) directly in your shell. In other words, it allows
you to call routines in shared libraries from within Bash.")
(license license:expat)))
+
+(define-public blesh
+ (package
+ (name "blesh")
+ (version "0.4.0-devel2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/akinomyoga/ble.sh")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02fdjyh4x6wr5hg3i86nsxhz8ysgjrvvxdmk6pqr0lm8ngw9p3sh"))))
+ (arguments
+ (list #:make-flags #~(list (string-append "PREFIX="
+ #$output))
+ #:phases #~(modify-phases %standard-phasesg
+ (add-after 'unpack 'pretend-contrib-.git-exists
+ (lambda _
+ (mkdir-p "contrib/.git")))
+ (add-after 'unpack 'make-readlink-work
+ (lambda _
+ (substitute* "ble.pp"
+ (("PATH=/bin:/usr/bin readlink")
+ (search-input-file %build-inputs
+ "/bin/readlink")))))
+ (delete 'configure) ;no configure
+ (add-before 'check 'use-LC_ALL-for-tests
+ (lambda _
+ (setenv "LANG"
+ (getenv "LC_ALL"))
+ (unsetenv "LC_ALL"))))))
+ (build-system gnu-build-system)
+ (inputs (list coreutils))
+ (native-inputs (list git-minimal less))
+ (home-page "https://github.com/akinomyoga/ble.sh")
+ (synopsis "Bash Line Editor")
+ (description
+ "Bash Line Editor (ble.sh) is a command line editor written in pure Bash
+which replaces the default GNU Readline. It adds syntax highlighting, auto
+suggestions, vim modes, and more to Bash interactive sessions.")
+ (license license:bsd-3)))

base-commit: 491dd62b38e1772f3e50de58118d9b9ac97272ff
--
2.37.3
C
C
Christopher Baines wrote on 14 Sep 2022 10:40
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 57659-done@debbugs.gnu.org)
87edwe8hyn.fsf@cbaines.net
kiasoc5 <kiasoc5@disroot.org> writes:

Toggle quote (7 lines)
> Tests pass now.
>
> * gnu/packages/bash.scm (blesh): New variable.
> ---
> gnu/packages/bash.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 45 insertions(+)

Thanks. I've tweaked the name of one of the phaess (use-LANG-for-tests
rather than use-LC_ALL-for-tests) as that seemed more correct. I also
removed some inputs that were redundant (coreutils is provided by the
gnu-build-system, so is an implicit input), and git-minimal didn't seem
to be required.

I pushed to master as 592ca01d8d25849d077035d54d969d90ed5c2609.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmMhlBFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfAcQ//cSn2t54dbo1uu75kRCtLSZ9bhgJvbO12
Oe4uXeuBbHaGdybuO9HLVlkIqFim51B8owxkKLaU1bxEeMHEw2yHir+eEPCoJ/cD
5N4FhkaX73HK49Gh0E8brRIW7Z0z+nkwnWGs9g4vDnxuQgoWnmJ3jJyJSTDk0IBe
AJgwNdTLSyQomxyfQVrKoZpbEFo7MfYP1z0wRNKQe/JfRvnimxUBF/Sxbvuytfsz
UfNBoAeWRJI0lQeHNzeSt6SK01etV43XrFj7CdEIDPfkTzDGs2KDVW1z8H5PHAG2
GrtWlIYLO7/8WEXI79PnWoowtcHquhR7VAj4dnLb00dqskqt3Hrlkd64RaZcuneu
gbJpUn11jhPSneptK2GJIcBiai8aLXe3vEwvSI7ajT32/0BmU0VKSaAc6QHPZnaN
opiZDqOF96pwkS0O9JtFT43SuUlVP0rmxMdOmVzITC5CnvejWPHtjfoTX2Qk7E0q
DPChZxh0a7UYPDsWHpXA+5GV02NMPE3brDHUAVVzHoBplFYNnFi0Dyz1HRs4WK4z
qeyS6QUE600ZNe9BxPER/Ueu9Qe10OL9I68FUa++aNXXKsUpX/iVb7hm4OhIIOcK
F2RN0vTfDAgBdqoIbDy73uki+Y1XbKdrO60etLTbQFomk/KwispLvRw4jixwAEUz
7xFvmEjKhDM=
=dTkQ
-----END PGP SIGNATURE-----

Closed
M
M
Maxime Devos wrote on 15 Sep 2022 17:26
Re: bug#57659: [PATCH v3] gnu: Add blesh.
4aa38651-563e-000f-3bb0-7a36f01bad6f@telenet.be
On 14-09-2022 10:40, Christopher Baines wrote:
Toggle quote (15 lines)
>
> kiasoc5 <kiasoc5@disroot.org> writes:
>
>> Tests pass now.
>>
>> * gnu/packages/bash.scm (blesh): New variable.
>> ---
>> gnu/packages/bash.scm | 45 +++++++++++++++++++++++++++++++++++++++++++
>> 1 file changed, 45 insertions(+)
>
> Thanks. I've tweaked the name of one of the phaess (use-LANG-for-tests
> rather than use-LC_ALL-for-tests) as that seemed more correct. I also
> removed some inputs that were redundant (coreutils is provided by the
> gnu-build-system, so is an implicit input), and git-minimal didn't seem
> to be required.
gnu-build-system only provides a _natively compiled_ coreutils (for
--system), not a cross-compiled coreutils (for --target). As such, it
is not redundant (unless it compile-time only (*), the build system
isn't clear to me).
>+ (add-after 'unpack 'make-readlink-work
>+ (lambda _
>+ (substitute* "ble.pp"
>+ (("PATH=/bin:/usr/bin readlink")
>+ (search-input-file %build-inputs
>+ "/bin/readlink")))))
You're mixing G-exp (new) and %build-inputs (old). How about
(search-input-file inputs "bin/readlink") or (which "readlink")
(depending on whether inputs or native-inputs is appropriate) instead?
Greetings,
Maxime.
(*) can be verified by using "guix gc --references".
Attachment: OpenPGP_signature
K
K
kiasoc5 wrote on 16 Sep 2022 02:05
(name . Maxime Devos)(address . maximedevos@telenet.be)
20220916000511.69ff46e9@aria
On Thu, Sep 15 2022, 05:26:30 PM +0200
Maxime Devos <maximedevos@telenet.be> wrote:

Toggle quote (23 lines)
> On 14-09-2022 10:40, Christopher Baines wrote:
> >
> > kiasoc5 <kiasoc5@disroot.org> writes:
> >
> >> Tests pass now.
> >>
> >> * gnu/packages/bash.scm (blesh): New variable.
> >> ---
> >> gnu/packages/bash.scm | 45
> >> +++++++++++++++++++++++++++++++++++++++++++ 1 file changed, 45
> >> insertions(+)
> >
> > Thanks. I've tweaked the name of one of the phaess
> > (use-LANG-for-tests rather than use-LC_ALL-for-tests) as that
> > seemed more correct. I also removed some inputs that were redundant
> > (coreutils is provided by the gnu-build-system, so is an implicit
> > input), and git-minimal didn't seem to be required.
>
> gnu-build-system only provides a _natively compiled_ coreutils (for
> --system), not a cross-compiled coreutils (for --target). As such,
> it is not redundant (unless it compile-time only (*), the build
> system isn't clear to me).

Readlink should be required for runtime, how about substituting
"PATH=/bin:/usr/bin readlink" -> "readlink" instead of the path to
readlink?

Toggle quote (12 lines)
> >+ (add-after 'unpack 'make-readlink-work
> >+ (lambda _
> >+ (substitute* "ble.pp"
> >+ (("PATH=/bin:/usr/bin readlink")
> >+ (search-input-file %build-inputs
> >+
> >"/bin/readlink")))))
>
> You're mixing G-exp (new) and %build-inputs (old). How about
> (search-input-file inputs "bin/readlink") or (which "readlink")
> (depending on whether inputs or native-inputs is appropriate) instead?

If we keep coreutils as an input then it would be search-file-inputs.

--
?