Tealdeer: compile failure

  • Open
  • quality assurance status badge
Details
2 participants
  • Christopher Howard
  • Maxime Devos
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 2 years ago
(name . Bug Guix)(address . bug-guix@gnu.org)
YzNQFBonAuU4Z085@theoden
Tealdeer-1.4.1 fails to build with this error:

```
Compiling openssl-macros v0.1.0
error[E0659]: `parse_quote_spanned` is ambiguous (`macro_rules` vs non-`macro_rules` from other module)
--> /tmp/guix-build-tealdeer-1.4.1.drv-0/tealdeer-1.4.1/guix-vendor/rust-pin-project-internal-0.4.22.tar.gz/src/pin_project/derive.rs:859:67
|
859 | proj_generics.make_where_clause().predicates.push(parse_quote_spanned! { span =>
| ^^^^^^^^^^^^^^^^^^^ ambiguous name
|
note: `parse_quote_spanned` could refer to the macro defined here
--> /tmp/guix-build-tealdeer-1.4.1.drv-0/tealdeer-1.4.1/guix-vendor/rust-pin-project-internal-0.4.22.tar.gz/src/utils.rs:22:1
|
22 | / macro_rules! parse_quote_spanned {
23 | | ($span:expr => $($tt:tt)*) => {
24 | | syn::parse2(quote::quote_spanned!($span => $($tt)*)).unwrap_or_else(|e| panic!("{}", e))
25 | | };
26 | | }
| |_^
note: `parse_quote_spanned` could also refer to the macro imported here
--> /tmp/guix-build-tealdeer-1.4.1.drv-0/tealdeer-1.4.1/guix-vendor/rust-pin-project-internal-0.4.22.tar.gz/src/pin_project/derive.rs:7:5
|
7 | *,
| ^
= help: use `self::parse_quote_spanned` to refer to this macro unambiguously

error[E0659]: `parse_quote_spanned` is ambiguous (`macro_rules` vs non-`macro_rules` from other module)
--> /tmp/guix-build-tealdeer-1.4.1.drv-0/tealdeer-1.4.1/guix-vendor/rust-pin-project-internal-0.4.22.tar.gz/src/pinned_drop.rs:108:21
|
108 | *path = parse_quote_spanned! { path.span() =>
| ^^^^^^^^^^^^^^^^^^^ ambiguous name
|
note: `parse_quote_spanned` could refer to the macro defined here
--> /tmp/guix-build-tealdeer-1.4.1.drv-0/tealdeer-1.4.1/guix-vendor/rust-pin-project-internal-0.4.22.tar.gz/src/utils.rs:22:1
|
22 | / macro_rules! parse_quote_spanned {
23 | | ($span:expr => $($tt:tt)*) => {
24 | | syn::parse2(quote::quote_spanned!($span => $($tt)*)).unwrap_or_else(|e| panic!("{}", e))
25 | | };
26 | | }
| |_^
note: `parse_quote_spanned` could also refer to the macro imported here
--> /tmp/guix-build-tealdeer-1.4.1.drv-0/tealdeer-1.4.1/guix-vendor/rust-pin-project-internal-0.4.22.tar.gz/src/pinned_drop.rs:3:50
|
3 | use syn::{spanned::Spanned, visit_mut::VisitMut, *};
| ^
= help: use `self::parse_quote_spanned` to refer to this macro unambiguously

For more information about this error, try `rustc --explain E0659`.
error: could not compile `pin-project-internal` due to 2 previous errors
warning: build failed, waiting for other jobs to finish...
error: build failed
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "cargo" arguments: ("build" "--release") exit-status: 101 term-signal: #f stop-signal: #f>
phase `build' failed after 41.0 seconds
command "cargo" "build" "--release" failed with status 101
```

My system:

```
christopher@theoden ~$ neofetch --stdout
christopher@theoden
-------------------
OS: Guix System x86_64
Host: OptiPlex 9020 00
Kernel: 5.18.19-gnu
Uptime: 20 days, 2 hours, 45 mins
Packages: 93 (guix-system), 177 (guix-user)
Shell: bash 5.1.8
Resolution: 1920x1080
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: .gnome-terminal
CPU: Intel i5-4570 (4) @ 3.600GHz
GPU: Intel HD Graphics
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
Memory: 3075MiB / 7867MiB
```

--
馃摏 Christopher Howard
馃殌 gemini://gem.librehacker.com

讘专讗砖讬转 讘专讗 讗诇讛讬诐 讗转 讛砖诪讬诐 讜讗转 讛讗专抓
Maxime Devos wrote 2 years ago
405c2dcc-abdb-8d31-ed5e-2fb1b7250305@telenet.be
merge 57867 58124
thanks
https://issues.guix.gnu.org/has a search function you can use for
already reported issues.
I have a proposal for a solution at https://issues.guix.gnu.org/57867#2.
Toggle quote (22 lines)
> My system:
>
> ```
> christopher@theoden ~$ neofetch --stdout
> christopher@theoden
> -------------------
> OS: Guix System x86_64
> Host: OptiPlex 9020 00
> Kernel: 5.18.19-gnu
> Uptime: 20 days, 2 hours, 45 mins
> Packages: 93 (guix-system), 177 (guix-user)
> Shell: bash 5.1.8
> Resolution: 1920x1080
> DE: GNOME
> Theme: Adwaita [GTK2/3]
> Icons: Adwaita [GTK2/3]
> Terminal: .gnome-terminal
> CPU: Intel i5-4570 (4) @ 3.600GHz
> GPU: Intel HD Graphics
> GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
> Memory: 3075MiB / 7867MiB
> ```
I think the output of "guix describe", in particular the output for the
'guix' channel, would be more useful.
Greetings,
Maxime.
Attachment: OpenPGP_signature
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 58124@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 58124
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help