Hi,
On Sat, 17 Sep 2022 at 11:55, "Daniel Sockwell" <daniel@codesections.com> wrote:
Toggle quote (2 lines)
> The relevant error message from the build log appears to be:
Indeed, this evaluation of the CI [1] reports [2] this error:
Toggle quote (3 lines)
> Compiling openssl-macros v0.1.0
> error[E0659]: `parse_quote_spanned` is ambiguous (`macro_rules` vs non-`macro_rules` from other module)
Well, it is part of the Evaluation 5349 [3] which points commit
e6dd58cfb511c23beb4d2732f898bb5479bd52d5, and it reads:
Toggle snippet (26 lines)
$ git log --format="%h %cd %s" | grep -C 11 e6dd58cfb
e5cfb7674a Mon Nov 28 14:02:37 2022 +0400 gnu: rust-clap-3: Update to 3.1.18.
05528a7b10 Mon Nov 28 14:02:20 2022 +0400 gnu: rust-clap-derive-3: Update to 3.1.18.
d32ed485e1 Mon Nov 28 14:02:12 2022 +0400 gnu: Add rust-clap-lex-0.2.
8bbc4dc2fb Mon Nov 28 14:01:56 2022 +0400 gnu: Add rust-rt-format-0.3.
dc685baad0 Mon Nov 28 14:01:44 2022 +0400 gnu: Add rust-swayipc-3.
622c3be7b6 Mon Nov 28 13:36:41 2022 +0400 Revert "gnu: Add rust-swayipc-3."
7922f610d2 Mon Nov 28 13:36:40 2022 +0400 Revert "gnu: Add rust-rt-format-0.3."
ddb3450684 Mon Nov 28 13:36:38 2022 +0400 Revert "gnu: Add rust-clap-lex-0.2."
1cc89f0be3 Mon Nov 28 13:36:36 2022 +0400 Revert "gnu: rust-clap-derive-3: Update to 3.1.18."
fd0bd21e66 Mon Nov 28 13:36:34 2022 +0400 Revert "gnu: rust-clap-3: Update to 3.1.18."
87e36d7478 Mon Nov 28 13:36:27 2022 +0400 Revert "gnu: Add swayr."
e6dd58cfb5 Mon Nov 28 12:50:22 2022 +0400 gnu: waybar: Update to 0.9.16.
b8a000b33b Mon Nov 28 12:50:21 2022 +0400 gnu: Add swayr.
93edae81b6 Mon Nov 28 12:50:20 2022 +0400 gnu: rust-clap-3: Update to 3.1.18.
7760e3fb09 Mon Nov 28 12:50:19 2022 +0400 gnu: rust-clap-derive-3: Update to 3.1.18.
4cb299e22e Mon Nov 28 12:50:18 2022 +0400 gnu: Add rust-clap-lex-0.2.
bf7c69b043 Mon Nov 28 12:50:17 2022 +0400 gnu: Add rust-rt-format-0.3.
655956131c Mon Nov 28 12:50:16 2022 +0400 gnu: Add rust-swayipc-3.
2db12d3c31 Mon Nov 28 12:50:15 2022 +0400 gnu: Add rust-swayipc-types-1.
df038ad39b Mon Nov 28 12:50:14 2022 +0400 gnu: Add rust-textwrap-0.15.
f7c95ecb67 Mon Nov 28 12:50:13 2022 +0400 gnu: rust-thiserror-1: Update to 1.0.37.
51cf11739d Mon Nov 28 12:50:12 2022 +0400 gnu: rust-thiserror-impl-1: Update to 1.0.37.
7f9a2930bf Sun Nov 27 00:24:56 2022 +0100 gnu: ardour: Update to 7.1
It means the culprit is probably one of these updates:
e6dd58cfb5 gnu: waybar: Update to 0.9.16.
93edae81b6 gnu: rust-clap-3: Update to 3.1.18.
7760e3fb09 gnu: rust-clap-derive-3: Update to 3.1.18.
f7c95ecb67 gnu: rust-thiserror-1: Update to 1.0.37.
51cf11739d gnu: rust-thiserror-impl-1: Update to 1.0.37.
Well, because it is not “inputs” but “hidden” in ’arguments’ via
#:cargo-inputs or #:cargo-development-inputs, “guix graph --path” is
useless here. However,
Toggle snippet (5 lines)
$ guix graph -t derivation tealdeer | grep label | grep rust-thiserror
"/gnu/store/2yqdbbrprafpi8a8zbf9vg9fl29m4bgb-rust-thiserror-impl-1.0.37.tar.gz.drv" [label = "rust-thiserror-impl-1.0.37.tar.gz.drv", shape = box, fontname = sans];
"/gnu/store/a0zc524q6im368xvwm3sp8bn9368p83b-rust-thiserror-1.0.37.tar.gz.drv" [label = "rust-thiserror-1.0.37.tar.gz.drv", shape = box, fontname = sans];
therefore, one (or both) is the culprit. It seems worth to try with
1.0.26 instead of 1.0.37. Any taker?
Cheers,
simon