[PATCH] gnu: Add tetzle.

  • Done
  • quality assurance status badge
Details
2 participants
  • Björn Höfling
  • Hendursaga
Owner
unassigned
Submitted by
Hendursaga
Severity
normal
Merged with

Debbugs page

Hendursaga wrote 2 years ago
(address . guix-patches@gnu.org)
20220914193847.24644-1-hendursaga@aol.com
* gnu/packages/games.scm (tetzle): New public variable.
---
gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 60ce0167a6..d22caf4ed9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -73,6 +73,7 @@
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2684,6 +2685,35 @@ (define-public superstarfighter
(license (list license:expat ; game
license:silofl1.1)))) ; fonts
+(define-public tetzle
+ (package
+ (name "tetzle")
+ (version "2.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://gottcode.org/"
+ name
+ "/"
+ name
+ "-"
+ version
+ "-src.tar.bz2"))
+ (sha256
+ (base32
+ "1m4j4lzqp8fnwmvyglmzcn3vh14ix4hhh52ycmcsjgrsgj1w4p6a"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (native-inputs (list qttools))
+ (inputs (list qtbase))
+ (home-page "https://gottcode.org/tetzle/")
+ (synopsis "Jigsaw puzzle game that uses tetrominoes for the pieces")
+ (description
+ "Tetzle is a jigsaw puzzle game that uses tetrominoes for the pieces. Any image
+can be imported and used to create puzzles with a wide range of sizes. Games are
+saved automatically, and you can select between currently in progress games.")
+ (license license:gpl3+)))
+
(define %ufoai-commit "a542a87a891f96b1ab2c44d35b2f6f16859a5019")
(define %ufoai-revision "0")
(define %ufoai-version (git-version "2.6.0_dev" %ufoai-revision %ufoai-commit))
--
2.37.1
Björn Höfling wrote 2 years ago
merge 57743 57812
(address . control@debbugs.gnu.org)
20220922101355.333d9a53@alma-ubu.fritz.box
merge 57743 57812
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYywZQwAKCRC/KGy2WT5f
/VJYAJsFaQ2BKeGaLXVPCVxI7rMusVWGtQCgpEDaR5Lw5jZCTakfC3iTn5vwO1U=
=kU18
-----END PGP SIGNATURE-----


Björn Höfling wrote 2 years ago
tetzle
(name . Hendursaga)(address . hendursaga@aol.com)
20220922112025.3919412a@alma-ubu.fritz.box
Hi,

I pushed your patch as:

81ad759ab96a3bfb9801467b7182af6a2d13159d

Thanks.

One note: I merged the patches 57743 and 57812. In the future, please
submit updated patches to the already existing patch/ticket, such that
the discussion is kept on one place.

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYywo2QAKCRC/KGy2WT5f
/UIqAJ9fKYwEfo+F8dcdeDbI7a7U2nO1FQCgrJbEr3/E8WuesSvX/4jt3wajw7g=
=f+7s
-----END PGP SIGNATURE-----


Closed
Hendursaga wrote 2 years ago
87pmfn32z7.fsf@aol.com
Toggle quote (2 lines)
> I pushed your patch as:

Thanks!

Toggle quote (3 lines)
> One note: I merged the patches 57743 and 57812. In the future, please
> submit updated patches to the already existing patch/ticket

Yes, sorry about that! I was still figuring out git-send-email!

~ Hendursaga
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57812@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57812
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help