[PATCH] gnu: Add tetzle.

  • Done
  • quality assurance status badge
Details
3 participants
  • Björn Höfling
  • Hendursaga
  • Christopher Baines
Owner
unassigned
Submitted by
Hendursaga
Severity
normal
Merged with

Debbugs page

Hendursaga wrote 2 years ago
(address . guix-patches@gnu.org)(name . Hendursaga)(address . hendursaga@aol.com)
20220911214712.59471-1-hendursaga@aol.com
* gnu/packages/games.scm (tetzle): New public variable.
---
gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2c7f892f19..a5179b86fa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -73,6 +73,7 @@
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11169,3 +11170,32 @@ (define-public freerct
Should they go unwise, a theme park plunge into chaos with vandalizing guests
and unsafe rides. Which path will you take?")
(license license:gpl2)))
+
+(define-public tetzle
+ (package
+ (name "tetzle")
+ (version "2.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://gottcode.org/"
+ name
+ "/"
+ name
+ "-"
+ version
+ "-src.tar.bz2"))
+ (sha256
+ (base32
+ "1m4j4lzqp8fnwmvyglmzcn3vh14ix4hhh52ycmcsjgrsgj1w4p6a"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs (list qttools))
+ (inputs (list qtbase))
+ (home-page "https://gottcode.org/tetzle/")
+ (synopsis "Jigsaw puzzle game that uses tetrominoes for the pieces")
+ (description
+ "Tetzle is a jigsaw puzzle game that uses tetrominoes for the pieces. Any image
+can be imported and used to create puzzles with a wide range of sizes. Games are
+saved automatically, and you can select between currently in progress games.")
+ (license license:gpl3+)))
--
2.37.1
Christopher Baines wrote 2 years ago
(name . Hendursaga)(address . hendursaga@aol.com)(address . 57743@debbugs.gnu.org)
87illq8ix3.fsf@cbaines.net
Hendursaga via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/games.scm (tetzle): New public variable.
> ---
> gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)

Hey Hendursaga,

Thanks for the patch. I've made one comment below.

Toggle quote (37 lines)
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 2c7f892f19..a5179b86fa 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -73,6 +73,7 @@
> ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
> ;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
> ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> +;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -11169,3 +11170,32 @@ (define-public freerct
> Should they go unwise, a theme park plunge into chaos with vandalizing guests
> and unsafe rides. Which path will you take?")
> (license license:gpl2)))
> +
> +(define-public tetzle
> + (package
> + (name "tetzle")
> + (version "2.2.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://gottcode.org/"
> + name
> + "/"
> + name
> + "-"
> + version
> + "-src.tar.bz2"))
> + (sha256
> + (base32
> + "1m4j4lzqp8fnwmvyglmzcn3vh14ix4hhh52ycmcsjgrsgj1w4p6a"))))
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f))

Why are the tests disabled? It's good to run the tests if that's
possible. If it's not possible, it's good to add a comment describing
why the tests can't be run.

Toggle quote (9 lines)
> + (native-inputs (list qttools))
> + (inputs (list qtbase))
> + (home-page "https://gottcode.org/tetzle/")
> + (synopsis "Jigsaw puzzle game that uses tetrominoes for the pieces")
> + (description
> + "Tetzle is a jigsaw puzzle game that uses tetrominoes for the pieces. Any image
> +can be imported and used to create puzzles with a wide range of sizes. Games are
> +saved automatically, and you can select between currently in progress games.")
> + (license license:gpl3+)))
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmMhjzhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeJAw//TETnUUdkRGtcqybmg/WHn6Na192jTCF7
S+H8DDv9N19gttwjVOP9o85+0FRf8Y4mXnkN0FxxBvBRlT1vRUlAc1gxmaoE+cdn
KtPOTDXzq+4lDe+S9/wXJHGvtPf4udUxc20y437Pgm/+ebZMegfphpfbIpPeDTBU
d3uDDBjrb5NmXGiZSPKLQYUXM1bHfWB8ivIhYeS+Wy5ygMMZHh2M+UcFbE/Dbql+
KPrz0sMOS0tDhsKWWo87o7eUXs29nZ2IW4Uql+DJdEr5xZFiwBm96kAdk9fDwnXG
fjvOrwRL3zgPSeusMWqfZs7qaXhe5jb8iBdKc2ReaFoppY8WQXofLt4+w77rOlsn
fSxBs8XKorF2cY/CTCywdwvq4+IyQxZ/1/td/JohbBi1Di2wsVeexWpMHumbBUx0
E4LvkK2hV8VpmtoBqPTMANwreSQpzcBe1zzXRgIJy9yy5lnAqLzEtBSWxOGZbzN/
aJsT2HN1esGvw43B4P9FCpPdgyr464x/GvqybD6S51WSgA3sBQC88lvSZvdx+nUQ
PVIQ2c2ZacXuBTqEcFCXP0Qs9Dp7RFDkm/1gp1aV44tFDjzsSWJPk2Rmpm5TDpoZ
LF1nqMVmTqZQ+88YTwE+hHV9sWeGUpxU2bGcuiCyLrLD+vP7qVg0BLel50uCFksE
80vJ9qWynjE=
=4it+
-----END PGP SIGNATURE-----

Björn Höfling wrote 2 years ago
merge 57743 57812
(address . control@debbugs.gnu.org)
20220922101355.333d9a53@alma-ubu.fritz.box
merge 57743 57812
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYywZQwAKCRC/KGy2WT5f
/VJYAJsFaQ2BKeGaLXVPCVxI7rMusVWGtQCgpEDaR5Lw5jZCTakfC3iTn5vwO1U=
=kU18
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 57743@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57743
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help